Microservices
Source: https://github.com/mfornos/awesome-microservices at
417c83dc4de7
License: CC0-1.0
Read the English original
This edition is an AI-assisted translation.
Auswahl an Ressourcen zu Microservices 
Abschnitt betitelt „Auswahl an Ressourcen zu Microservices “Eine kuratierte Liste von Prinzipien und Technologien zur Microservice-Architektur.
Inhaltsverzeichnis
- Bahnsteige
- Frameworks / Laufzeiten
- Service Toolkits
- Frontend/UI
- Kapazitäten
- Continuous Integration & Delivery
- Web API Modellierung & Dokumentation
- Normen / Empfehlungen
- Organisationsdesign / Teamdynamik
- Unternehmen & Vertikale
- Theorie
- Lizenz
- Beitrag
Bahnsteige
Abschnitt betitelt „Bahnsteige“- 1Backend - AI-native Microservices Plattform.
- Jolie - Open Source Microservice-orientierte Programmiersprache.
- OpenWhisk Serverlose Open-Source-Cloud-Plattform, die Funktionen als Reaktion auf Ereignisse in jeder Größenordnung ausführt.
- Pulumi SDK für Cloud Native Infrastructure als Code. Verwenden Sie Ihre Lieblingssprache, um Updates für Ihre Apps und Infrastruktur anzuzeigen und zu verwalten und kontinuierlich in jeder Cloud bereitzustellen (keine YAML erforderlich).
- Triton Open-Source-Cloud-Management-Plattform, die eine containerbasierte, serviceorientierte Infrastruktur der nächsten Generation in einem oder mehreren Rechenzentren bereitstellt.
Frameworks / Laufzeiten
Abschnitt betitelt „Frameworks / Laufzeiten“- Akka Toolkit und Laufzeit für die Erstellung von hochgradig gleichzeitigen, verteilten und belastbaren nachrichtengesteuerten Anwendungen auf der JVM.
- Axon (c) Eine End-to-End-Entwicklungs- und Infrastrukturplattform für die einfache Entwicklung und Ausführung von DDD-, CQRS- und Event Sourcing-Anwendungen auf JVM.
- Ballerina Cloud native Programmiersprache.
- Bun - Schnelle All-in-One JavaScript Laufzeit.
- Dapr Open-Source-Laufzeit zum Schreiben hochperformanter Microservices in jeder Programmiersprache.
- Deno - JavaScript, TypeScript und WebAssembly Laufzeit mit sicheren Standardeinstellungen und einer großartigen Entwicklererfahrung.
- Eclipse Microprofile Ein offenes Forum zur Optimierung von Enterprise Java für eine Microservices-Architektur durch Innovation in mehreren Implementierungen und Zusammenarbeit in gemeinsamen Interessenbereichen mit dem Ziel der Standardisierung.
- Erlang/OTP Programmiersprache, die verwendet wird, um massiv skalierbare Soft-Echtzeit-Systeme mit hohen Anforderungen an die Verfügbarkeit zu erstellen.
- Finagle - Erweiterbares RPC-System für die JVM, verwendet, um Server mit hoher Frequenz zu konstruieren.
- Gleam - Eine freundliche Sprache für den Aufbau typsicherer, skalierbarer Systeme.
- GraalVM - Hochleistungslaufzeit, die signifikante Verbesserungen der Anwendungsleistung und -effizienz bietet, was ideal für Microservices ist.
- Helidon - Sammlung von Java-Bibliotheken zum Schreiben von Microservices, die auf einem schnellen Web-Core mit Netty ausgeführt werden.
- Ice Umfassendes RPC-Framework mit Unterstützung für C++, C#, Java, JavaScript, Python und mehr.
- Light-4j - Ein hoher Durchsatz, geringe Latenz, kleiner Speicher-Fußabdruck und eine produktivere Microservices-Plattform.
- Micronaut Ein modernes, JVM-basiertes Full-Stack-Framework für die Erstellung modularer, leicht testbarer Microservice-Anwendungen.
- Moleculer - Schnelles und leistungsstarkes Microservice-Framework für Node.js, Java, Go und Ruby.
- Open Liberty Ein leichtes offenes Framework für die Erstellung schneller und effizienter Cloud-nativer Java Microservices.
- Pears - Peer-to-Peer-Laufzeit, Entwicklung und Bereitstellung.
- SmallRye APIs und Implementierungen für die Cloud-Entwicklung, einschließlich Eclipse MicroProfile.
- Spin Ein Open-Source-Framework zum Erstellen und Ausführen schneller, sicherer und zusammensetzbarer Cloud-Microservices mit WebAssembly.
- ScaleCube - Toolkit zum Aufbau reaktiver Microservices für die JVM: niedrige Latenz, hoher Durchsatz, skalierbar und belastbar.
- Vert.X - Toolkit zum Erstellen reaktiver Anwendungen auf der JVM.
- Vert.X Toolbox - Eine Reihe von Vert.x-Komponenten zum Erstellen reaktiver Microservice-Anwendungen.
- Wangle Ein Framework, das eine Reihe gemeinsamer Client/Server-Abstraktionen für den Aufbau von Services auf konsistente, modulare und zusammensetzbare Weise bereitstellt.
Service Toolkits
Abschnitt betitelt „Service Toolkits“Polyglott
Abschnitt betitelt „Polyglott“- GRPC - Ein leistungsstarkes, Open Source, allgemeines RPC-Framework, das Mobile und HTTP/2 an die erste Stelle setzt. Bibliotheken in C, C++, Java, Go, Node.js, Python, Ruby, Objective-C, PHP und C#.
- Lwan - Hochleistungs- und skalierbarer Webserver.
- uSockets Miniscule Cross-Plattform-Eventing, Networking & Krypto für async-Anwendungen.
- Cap’n Proto RPC - Die Cap’n Proto C++ RPC Implementierung.
- C++ Micro Services - Ein OSGi-ähnliches C++ dynamisches Modulsystem und Dienstregistrierung.
- Enduro/X XATMI basiertes Service-Framework für GNU/Linux.
- Pistache - Ein leistungsstarkes REST-Toolkit in C++ geschrieben.
- Poco C++-Klassenbibliotheken zum Erstellen von netzwerkbasierten Anwendungen und Servern.
- Sogou Workflow - Enterprise-Grade-Programmiermaschine, die darauf abzielt, die meisten Backend-Entwicklungsanforderungen zu erfüllen.
- uWebSockets Einfacher, sicherer und standardkonformer Webserver für die anspruchsvollsten Anwendungen.
- Awesome Microservices .NET Core :star: - Eine Sammlung fantastischer Schulungsserien, Artikel, Videos, Bücher, Kurse, Beispielprojekte und Tools für Microservices in .NET Core.
- Vibe.d - Asynchrones I / O, das dir nicht im Weg steht, geschrieben in D.
Erlang VM
Abschnitt betitelt „Erlang VM“Elixier
Abschnitt betitelt „Elixier“- Phoenix Framework zum Erstellen von HTML5-Apps, API-Backends und verteilten Systemen.
- Plug - Eine Spezifikation und Komfort für komponierbare Module zwischen Webanwendungen.
- Cowboy - Kleiner, schneller, modularer HTTP-Server in Erlang geschrieben.
- Mochiweb - Erlang-Bibliothek zum Aufbau leichter HTTP-Server.
- Chi - Leichtgewichtiger, idiomatischer und zusammensetzbarer Router zum Erstellen von Go HTTP-Diensten.
- Echo - Schnelles und unfancy HTTP Server Framework für Go. Bis zu 10x schneller als der Rest.
- Fiber - Express inspiriertes Web-Framework, das auf Fasthttp, der schnellsten HTTP-Engine für Go, aufbaut. Entwickelt, um die Dinge für eine schnelle Entwicklung mit null Speicherzuweisung und Leistung zu erleichtern.
- Gin Gin ist ein HTTP-Web-Framework, das in Go (Golang) geschrieben ist. Es verfügt über eine Martini-ähnliche API mit viel besserer Leistung, bis zu 40-mal schneller.
- Goa - Designbasierte HTTP Microservices in Go.
- GoFr - Ein eigensinniges Microservice-Entwicklungs-Framework, das Skalierbarkeit und Robustheit betont. Entwickelt, um die Entwicklung von Microservices zu vereinfachen.
- Go Chassis - Ein Framework für die schnelle Entwicklung von Microservices in Go, das sich einfach in einige Cloud-Ökosysteme integrieren lässt.
- Go-micro Ein verteiltes Systementwicklungs-Framework.
- Go-zero - Ein Web- und RPC Distributed System Development Framework.
- Gorilla - Web-Toolkit für die Programmiersprache Go.
- Iris - Schnelles, einfaches und effizientes Micro Web Framework für Go.
- Lura Framework zum Erstellen von Ultra Performance API Gateways mit Middlewares.
- RPCX - Ein verteiltes RPC-Service-Framework auf Basis von NET/RPC wie Alibaba Dubbo und Weibo Motan.
Haskell
Abschnitt betitelt „Haskell“- Scotty - Micro Web Framework inspiriert von Ruby’s Sinatra, mit WAI und Warp.
- Servant Typ-Level Web DSL.
- Yesod Das Haskell RESTful Web Framework.
Java VM
Abschnitt betitelt „Java VM“Clojure
Abschnitt betitelt „Clojure“- Compojure - Eine prägnante Routing-Bibliothek für Ring / Clojure.
- Duct Ein serverseitiges Framework für Clojure.
- System Erbaut auf der Komponentenbibliothek von Stuart Sierra, bietet eine Reihe von vorgefertigten Komponenten.
- Tesla - Gemeinsame Basis für einige Clojure Microservices von Otto.de.
- ActiveJ Leichte und schnelle Bibliothek für komplexe hochlastige verteilte Anwendungen und Memcached-ähnliche Lösungen.
- Airlift Framework zum Erstellen von REST-Diensten in Java.
- Armeria Open-Source-asynchrone HTTP/2 RPC/REST-Client/Server-Bibliothek auf Basis von Java 8, Netty, Thrift und gRPC.
- Disruptor Hochleistungs-Inter-Thread-Messaging-Bibliothek.
- Dropwizard - Java-Framework für die Entwicklung ops-freundlicher, leistungsstarker, RESTful-Webdienste.
- Dubbo - Ein leistungsstarkes, Java-basiertes RPC-Framework, das von Alibaba Open Source bereitgestellt wird.
- Conjure - Opinionated Set von Bibliotheken zum Definieren und Erstellen von RESTish/RPC Servern und Clients basierend auf Feign oder Retrofit als Client und Dropwizard/Jersey mit JAX-RS Servicedefinitionen als Server.
- Jersey - RESTful Services in Java. JAX-RS Referenzimplementierung.
- Quarkus - A Kubernetes Native Java Stack zugeschnitten auf OpenJDK HotSpot und GraalVM, hergestellt aus den besten Java-Bibliotheken und Standards.
- Ratpack - Set von Java-Bibliotheken, die schnelle, effiziente, evolvierbare und gut getestete HTTP-Anwendungen ermöglichen. spezifische Unterstützung für die Groovy-Sprache bereitgestellt wird.
- Spring Boot - macht es einfach, eigenständige, produktionsfähige Spring-basierte Anwendungen zu erstellen.
- Http4k - Leichtes, aber voll ausgestattetes HTTP-Toolkit, das in reinem Kotlin geschrieben ist und die Bedienung und Nutzung von HTTP-Diensten auf funktionale und konsistente Weise ermöglicht.
- Ktor Framework zum Aufbau asynchroner Server und Clients in verbundenen Systemen unter Verwendung der Programmiersprache Kotlin.
- Finatra - Schnelle, testbare Scala HTTP-Dienste, die auf Twitter-Server und Finagle aufgebaut sind.
- Http4s - Eine minimale, idiomatische Scala-Schnittstelle für HTTP
- Play - Das High Velocity Web Framework für Java und Scala.
Node.js
Abschnitt betitelt „Node.js“- Actionhero - Multi-Transport Node.js API-Server mit integrierten Cluster-Fähigkeiten und verzögerten Aufgaben.
- Express - Schnelles, neutrales, minimalistisches Web-Framework für Node.js
- Fastify - Fastify, Fast and Low Overhead Web Framework, für Node.js.
- FeathersJS - Eine Open Source REST- und Echtzeit-API-Schicht für moderne Anwendungen.
- Hono Kleines, einfaches und ultraschnelles Web-Framework für die Edges. Es funktioniert mit jeder JavaScript-Laufzeit.
- Koa Next Generation Web Framework für Node.js
- Loopback Node.js Framework zum Erstellen von APIs und zum einfachen Verbinden mit Backend-Datenquellen.
- NestJS Ein Node.js-Framework zum Erstellen effizienter und skalierbarer serverseitiger Anwendungen mit integrierter Microservices-Unterstützung.
- Seneca - Ein Microservices Toolkit für Node.js
- Serverless Erstellen und pflegen Sie Web-, Mobil- und IoT-Anwendungen, die auf AWS Lambda und API Gateway (früher bekannt als JAWS) ausgeführt werden.
- tRPC Ende-zu-Ende typsichere APIs.
Perlmutt
Abschnitt betitelt „Perlmutt“- Cro Bibliotheken zum Erstellen reaktiver verteilter Systeme mit Perl 6.
- Mojolicious Next Generation Web Framework für Perl.
- API Platform API-First Web Framework auf Symfony mit JSON-LD, Schema.org und Hydra Unterstützung.
- Ecotone - Framework basierend auf den architektonischen Prinzipien von DDD, CQRS und Event Sourcing, das Bausteine für die Erstellung skalierbarer und erweiterbarer Anwendungen bereitstellt.
- Hyperf Hyperf ist ein extrem performantes und flexibles PHP-CLI-Framework, das auf Swoole 4.5+ basiert und auf dem hochmodernen Coroutine-Server und einer Vielzahl von kampferprobten Komponenten basiert.
- Lumen - Atemberaubend schnelles Mikro-Framework.
- Slim - Micro-Framework, mit dem Sie schnell einfache, aber leistungsstarke Webanwendungen und APIs schreiben können.
- Spiral - Framework für lang laufende Anwendungen mit RoadRunnerEs bietet erweiterte Funktionen wie die Integration mit dem Temporal Workflow-Engine und Centrifugo Websocket-Server. Es ist besonders effektiv für die Microservices-Architektur und bietet robuste Unterstützung für REST-APIs und gRPC-Dienste.
- Swoft - PHP Microservices Coroutine-Framework für den Aufbau von leistungsstarken Websystemen, APIs, Middleware und Basisdiensten.
- Symfony - Mikrorahmen basierend auf den Symfony-Komponenten.
- Aiohttp - HTTP Client/Server für asyncio.
- Bottle - Schnelles, einfaches und leichtes WSGI Micro Web-Framework für Python.
- Connexion Swagger/OpenAPI-Framework für Python auf Flask mit automatischer Endpunktvalidierung und OAuth2-Unterstützung.
- Falcon - Bare-Metal Python Web API Framework für den Aufbau sehr schneller App Backends und Microservices.
- FastAPI - Modernes, schnelles (Hochleistungs-) Web-Framework zum Erstellen von APIs mit Python 3.6+ basierend auf Standard-Python-Hinweisen.
- Flask Python Framework für Microservices auf Basis von Werkzeug und Jinja 2.
- Nameko Python Framework zum Erstellen von Microservices.
- Sanic Sanic ist ein Flask-ähnlicher Python 3.5+ Webserver, der geschrieben wurde, um schnell zu gehen.
- Tornado - Web-Framework und asynchrone Netzwerkbibliothek.
- Twisted - Event-driven Network Programming Engine.
- Web.py Minimalistisches Web-Framework für Python.
- Grape - Ein eigenverantwortliches Framework zum Erstellen von REST-ähnlichen APIs
- Hanami Ein modernes Web-Framework für Ruby.
- Praxis - Framework für die Gestaltung und Implementierung von APIs.
- Scorched Leichtgewichtiges Web-Framework für Ruby.
- Sinatra - Sinatra ist eine DSL zum schnellen Erstellen von Webanwendungen in Ruby mit minimalem Aufwand.
- Are we web yet? :star: - Eine Zusammenfassung des aktuellen Standes der Web-Programmierung in Rust.
- Actix Leistungsstarkes, pragmatisches und extrem schnelles Web-Framework für Rust.
- Tarpc - RPC-Framework für Rust mit Fokus auf Benutzerfreundlichkeit.
- Tokio - Asynchrone Laufzeit zum Schreiben von Netzwerkanwendungen.
- Tower Bibliothek modularer und wiederverwendbarer Komponenten zum Aufbau robuster Netzwerkclients und Server.
- Wtx HTTP/2 Client/Server-Framework.
Frontend/UI
Abschnitt betitelt „Frontend/UI“- Awesome Micro Frontends :star: - Eine kuratierte Liste von Ressourcen über Micro Frontends.
- Electrode - Universal React/Node.js Anwendungsplattform.
- Micro Frontends - Erweiterung der Microservice-Idee auf Frontend-Entwicklung.
- MiniApp White Paper - MiniApp Standardisierung White Paper.
Kapazitäten
Abschnitt betitelt „Kapazitäten“API Gateways / Edge Services
Abschnitt betitelt „API Gateways / Edge Services“- Ambassador (c) - Kubernetes-natives API-Gateway für Microservices auf Envoy.
- Apache APISIX - Hochleistungs-, Echtzeit-API-Gateway und AI-Gateway, basierend auf NGINX und etcd, mit heiß nachgeladenem Routing und 100+ Plugins.
- APIcast APIcast ist ein API-Gateway, das auf NGINX aufbaut. Es ist Teil der Red Hat 3scale API Management Platform.
- Bunker Web - Web-App-Hosting und Reverse-Proxy standardmäßig sicher.
- Caddy - Erweiterbarer HTTP/2-Webserver mit automatischem HTTPS.
- Camel Ermöglicht es Ihnen, Routing- und Mediationsregeln in einer Vielzahl von domänenspezifischen Sprachen zu definieren, einschließlich einer Java-basierten fließenden API, Spring- oder Blueprint-XML-Konfigurationsdateien und einer Scala DSL.
- Envoy - Open Source Edge und Service Proxy, von den Entwicklern von Lyft.
- HAProxy - Zuverlässiger, leistungsstarker TCP/HTTP Load Balancer.
- Istio Eine offene Plattform zur Verbindung, Verwaltung und Sicherung von Microservices.
- Keepalived Einfache und robuste Einrichtungen für Loadbalancing und Hochverfügbarkeit für Linux-System und Linux-basierte Infrastrukturen.
- Kong Open Source Management Layer für APIs.
- KrakenD Open Source Ultra Performance API Gateway.
- Kuma Plattformunabhängige Open-Source-Kontrollebene für Service Mesh und Microservices.
- Linkerd Resilient Service Mesh für Cloud Native Apps.
- Neutrino - Erweiterbarer Software Load Balancer.
- OpenResty - Schneller Webanwendungsserver, der auf Nginx aufbaut.
- Open Service Mesh Leichtes und erweiterbares Cloud Native Service Mesh.
- Otoroshi - Moderne HTTP Reverse Proxy mit leichtgewichtigem API-Management.
- Pingora Eine Bibliothek zum Aufbau schneller, zuverlässiger und evolvierbarer Netzwerkdienste.
- Skipper - HTTP-Router nützlich zum Entkoppeln des Routings von der Dienstlogik.
- Spring Cloud Gateway API Gateway auf Spring MVC. Ziel ist es, einen einfachen, aber effektiven Weg zu APIs zu finden.
- Tengine - Eine Distribution von Nginx mit einigen erweiterten Funktionen.
- Træfɪk - Ein moderner HTTP Reverse Proxy und Load Balancer für die einfache Bereitstellung von Microservices.
- Traffic Server - Hochleistungsbaustein für Cloud-Services.
- Tyk Open Source, schnelles und skalierbares API Gateway, Portal und API Management Plattform.
- Vulcand - Programmatic Load Balancer unterstützt durch Etcd.
- Zuul - Ein Edge-Service, der dynamisches Routing, Überwachung, Resilienz, Sicherheit und mehr bietet.
Konfiguration & Discovery
Abschnitt betitelt „Konfiguration & Discovery“- Central Dogma - Open-Source hochverfügbares versionengesteuertes Dienstkonfigurations-Repository basierend auf Git, ZooKeeper und HTTP/2.
- Consul Service Discovery und Konfiguration leicht gemacht. Verteilt, hochverfügbar und Datacenter-bewusst.
- Etcd Hochverfügbarer Key-Value-Store für die gemeinsame Konfiguration und Serviceerkennung.
- Eureka - REST-basierter Dienst, der hauptsächlich in der AWS-Cloud zur Ortung von Diensten zum Zwecke des Load Balancing und Failovers von Servern mittlerer Ebene verwendet wird.
- Microconfig - Moderne und einfache Art des Microservice-Konfigurationsmanagements.
- Nacos - Einfach zu bedienende dynamische Serviceerkennungs-, Konfigurations- und Servicemanagement-Plattform.
- SkyDNS - Verteilter Service für die Ankündigung und Entdeckung von Diensten, die auf etcd aufgebaut sind. Es verwendet DNS-Abfragen, um verfügbare Dienste zu finden.
- Spring Cloud Config Server- und clientseitige Unterstützung für die externe Konfiguration in einem verteilten System.
- ZooKeeper - Open Source Server, der eine sehr zuverlässige verteilte Koordination ermöglicht.
Workflow Orchestrierung
Abschnitt betitelt „Workflow Orchestrierung“- AWS Step Functions (c) - Koordinieren Sie die Komponenten verteilter Anwendungen und Microservices mithilfe visueller Workflows.
- Cadence - Fault-oblivious Stateful Code Plattform.
- Conductor - Eine Microservices Orchestrierungsmaschine.
- Inngest Dauerhafte Funktionen für zuverlässige Hintergrundlogik, von Hintergrundjobs bis hin zu komplexen Workflows.
- Kestra Open-Source-Mikroservices ereignisgesteuerte, sprachunabhängige Orchestrierungs- und Planungsplattform.
- Temporal - Open Source Microservices Orchestrierungsplattform für die Ausführung von Mission Critical Code in jedem Maßstab.
- Zeebe Definieren, orchestrieren und überwachen Sie Geschäftsprozesse über Microservices hinweg.
Elastizität
Abschnitt betitelt „Elastizität“- Hazelcast Open Source In-Memory Data-Grid. Ermöglicht es Ihnen, Daten und Berechnungen auf Server, Cluster und Regionen zu verteilen und sehr große Datensätze oder hohe Datenaufnahmeraten zu verwalten. Reife Technologie.
- Helix Generisches Cluster-Management-Framework für die automatische Verwaltung von partitionierten, replizierten und verteilten Ressourcen, die auf einem Cluster von Knoten gehostet werden.
- Ignite - Hochleistungs-, integrierte und verteilte In-Memory-Plattform für die Berechnung und Transaktion von großen Datensätzen in Echtzeit, Größenordnungen schneller als möglich mit herkömmlichen Festplatten- oder Flash-Technologien.
- Libp2p Ein Framework und eine Reihe von Protokollen zum Erstellen von Peer-to-Peer-Netzwerkanwendungen.
- Mesos Abstracts CPU, Speicher, Speicher und andere Rechenressourcen weg von Maschinen (physisch oder virtuell), so dass fehlertolerante und elastische verteilte Systeme einfach aufgebaut und effektiv ausgeführt werden können.
- Nomad - Verteilter, hochverfügbarer, Datacenter-fähiger Scheduler.
- Redisson Verteilte und skalierbare Java-Datenstrukturen auf dem Redis-Server.
- Serf Dezentrale Lösung für Clustermitgliedschaft, Fehlererkennung und Orchestrierung.
- Valkey - Ein neues Projekt zur Wiederaufnahme der Entwicklung des ehemaligen Open-Source-Projekts Redis.
- Zenoh Pub/Sub/Abfrage-Protokoll, das Daten in Bewegung, Daten in Ruhe und Berechnungen vereint. Verbindet traditionelles Pub / Sub effizient mit verteiltem Geo-Speicher, Abfragen und Berechnungen.
Job Schedulers / Workload Automation
Abschnitt betitelt „Job Schedulers / Workload Automation“- Celery - Asynchrone Aufgabenwarteschlange/Jobwarteschlange basierend auf verteilter Nachrichtenübergabe. Konzentriert sich auf den Echtzeitbetrieb und unterstützt die Planung.
- Dkron Verteiltes, fehlertolerantes Jobplanungssystem.
- Faktory - Language-agnostic persistenter Hintergrund-Jobserver.
- Rundeck (c) - Jobplaner und Runbook-Automatisierung. Ermöglichen Sie Self-Service-Zugriff auf vorhandene Skripte und Tools.
- Schedulix - Open Source Enterprise Job Scheduling System setzt bahnbrechende Standards für die professionelle Automatisierung von IT-Prozessen in fortschrittlichen Systemumgebungen.
Lokale Entwicklung
Abschnitt betitelt „Lokale Entwicklung“- mirrord - Führen Sie lokalen Code aus, als wäre es ein Pod in einer Fernbedienung Kubernetes Cluster.
Protokollierung
Abschnitt betitelt „Protokollierung“- Fluentd Open Source Datensammler für Unified Logging Layer.
- Graylog Vollständig integrierte Open Source Log Management Plattform.
- Kibana Flexible Analyse- und Visualisierungsplattform.
- LogDNA (c) Zentralisierte Log-Management-Software. Sammeln, zentralisieren und analysieren Sie Protokolle sofort in Echtzeit von jeder Plattform und jedem Volumen.
- Logstash - Tool zum Verwalten von Ereignissen und Protokollen.
- Loki - Wie Prometheus, aber für Logs.
Messaging
Abschnitt betitelt „Messaging“- ØMQ - Brokerless intelligente Transportschicht.
- ActiveMQ Leistungsstarke Open Source Messaging und Integration Pattern Server.
- Aeron Effizienter zuverlässiger UDP Unicast, UDP Multicast und IPC Nachrichtentransport.
- Beanstalk - Einfache, schnelle Warteschlange.
- Bull - Schnelle und zuverlässige Redis-basierte Warteschlange für Node.
- Crossbar Open-Source-Netzwerkplattform für verteilte und Microservice-Anwendungen. Es implementiert das offene Web Application Messaging Protocol (WAMP).
- Kafka Veröffentlichen-Abonnement-Messaging als verteiltes Commit-Log neu gedacht.
- Malamute - ZeroMQ Enterprise Messaging Broker.
- Mosquitto - Open Source Message Broker, der das MQTT-Protokoll implementiert.
- NATS Open Source, leistungsstarkes, leichtes Cloud-Messaging-System.
- NSQ - Eine verteilte Messaging-Plattform in Echtzeit.
- Pulsar Verteiltes Pub-Sub-Messaging-System.
- RabbitMQ - Open Source Erlang-basierter Message Broker, der einfach funktioniert.
- Redpanda Streaming-Datenplattform für Entwickler: Kafka API kompatibel, 10x schneller, kein ZooKeeper und keine JVM.
- RocketMQ Eine niedrige Latenz, zuverlässig, skalierbar, einfach zu bedienende nachrichtenorientierte Middleware, die aus dem massiven Messaging-Geschäft von alibaba stammt.
Monitoring & Debugging
Abschnitt betitelt „Monitoring & Debugging“- Beats Leichtgewichtige Verlader für Elasticsearch & Logstash.
- Elastalert - Einfache und flexible Alarmierung für Elasticsearch.
- Ganglia - Ein skalierbares verteiltes Überwachungssystem für Hochleistungsrechensysteme wie Cluster und Grids.
- Grafana - Ein Open Source, Feature Rich Metriken Dashboard und Graph-Editor für Graphite, InfluxDB & OpenTSDB.
- Graphite - Skalierbares Echtzeitgraphing.
- IOpipe (c) - Überwachung der Anwendungsleistung für Amazon Lambda.
- Jaeger - Ein Open Source, End-to-End Distributed Tracing
- OpenTelemetry - Hochwertige, allgegenwärtige und tragbare Telemetrie, um eine effektive Beobachtbarkeit zu ermöglichen.
- Prometheus - Ein Open Source Service Monitoring System und Zeitreihendatenbank.
- Riemann Überwacht verteilte Systeme.
- Sensu - Überwachung der heutigen Infrastruktur.
- SkyWalking - Anwendungs-Performance-Monitor-Tool für verteilte Systeme, speziell für Microservices, Cloud-nativ und Container-basiert (Docker), K8sMesos Architekturen.
- Zabbix - Open Source Enterprise-Class-Monitoring-Lösung.
- Zipkin Distributed Tracing System.
Reaktivität
Abschnitt betitelt „Reaktivität“- Arroyo - Distributed Stream Processing Engine zum Transformieren, Filtern, Aggregieren und Verbinden von Datenströmen durch Schreiben von SQL.
- Reactor.io Eine Reactive-Bibliothek der zweiten Generation zum Erstellen von nicht blockierenden Anwendungen auf der JVM basierend auf der Reactive Streams Specification.
- Reactive Kafka - Reactive Streams API für Apache Kafka.
- ReactiveX API für asynchrone Programmierung mit beobachtbaren Streams. Verfügbar für idiomatische Java, Scala, C#, C++, Clojure, JavaScript, Python, Groovy, JRuby und andere.
- RSocket Anwendungsprotokoll mit Reactive Streams-Semantik.
Resilienz
Abschnitt betitelt „Resilienz“- Awesome Chaos Engineering :star: - Eine kuratierte Liste von fantastischen Chaos Engineering Ressourcen.
- Raft Consensus Konsensalgorithmus, der so konzipiert ist, dass er leicht zu verstehen ist. Es entspricht Paxos in Fehlertoleranz und Leistung.
- Resilience4j Fehlertoleranzbibliothek für Java8 und funktionale Programmierung.
- Svix - Webhooks-Service, der Webhooks an Ihre Benutzer mit vollständigen Wiederholungszeitplänen, exponentiellem Backoff, Signaturverifizierung und Ereignistypen sendet.
Sicherheit
Abschnitt betitelt „Sicherheit“- Cerbos Hub - Autorisierungsmanagementsystem zum Erstellen, Testen und Bereitstellen von Zugriffsrichtlinien. Aufbau einer skalierbaren, feinkörnigen Autorisierung in einer Microservice-Architektur.
- Dex - Opinionated Auth / Verzeichnis-Service mit steckbaren Steckern. OpenID Connect-Anbieter und OAuth 2.0-Delegation von Drittanbietern.
- JWT JSON Web Tokens sind eine offene, branchenübliche RFC 7519-Methode zur sicheren Darstellung von Ansprüchen zwischen zwei Parteien.
- Keycloak - Voll ausgestatteter und erweiterbarer Auth Service. OpenID Connect-Anbieter und OAuth 2.0-Delegation von Drittanbietern.
- OAuth Bietet spezifische Autorisierungsflüsse für Webanwendungen, Desktop-Anwendungen, Mobiltelefone und Wohnzimmergeräte. Viele Implementierungen.
- OpenID Connect Bibliotheken, Produkte und Tools, die aktuelle OpenID-Spezifikationen und verwandte Spezifikationen implementieren.
- Open Ziti Zero Trust Security und Overlay Networking als reine Open Source Software.
- ORY - Open Source Identitätsinfrastruktur und -dienste.
- OWASP Agent Memory Guard Runtime Defense Layer für AI Agent Memory Poisoning (OWASP ASI06). Erkennt manipulierte Speichereinträge, prompte Injektion in Speicherpfade und geheime Leckagen. YAML-Richtlinien, Mikrosekunden-Latenz, null externe Abhängigkeiten.
- SCIM - System für bereichsübergreifendes Identitätsmanagement.
- Vault Sichert, speichert und kontrolliert den Zugriff auf Token, Passwörter, Zertifikate, API-Schlüssel und andere Geheimnisse im modernen Computing.
Serialisierung
Abschnitt betitelt „Serialisierung“- Avro Apache-Datenserialisierungssystem, das reichhaltige Datenstrukturen in einem kompakten, schnellen, binären Datenformat bereitstellt.
- Bond Plattformübergreifendes Framework für die Arbeit mit schematisierten Daten, das bei Microsoft in High-Scale-Diensten weit verbreitet ist.
- BooPickle Binäre Serialisierungsbibliothek für effiziente Netzwerkkommunikation. Für Scala und Scala.js
- Cap’n Proto - Wahnsinnig schnelles Datenaustauschformat und fähigkeitsbasiertes RPC-System.
- CBOR Implementierungen des CBOR-Standards (RFC 7049) in vielen Sprachen.
- Cereal - C++11 Bibliothek zur Serialisierung.
- Cheshire Clojure JSON und JSON SMILE Kodierung/Dekodierung.
- Etch Plattformübergreifendes, sprach- und transportunabhängiges Framework für den Aufbau und die Nutzung von Netzwerkdiensten.
- Fastjson - Schneller JSON Prozessor.
- Ffjson Schnellere JSON-Serialisierung für Go.
- FST - Schnelle Java-Serialisierung Drop-In-Ersatz.
- Jackson Eine Mehrzweck-Java-Bibliothek zur Verarbeitung des JSON-Datenformats.
- Jackson Afterburner - Jackson-Modul, das die Bytecode-Generierung verwendet, um die Datenbindung weiter zu beschleunigen (+30-40% Durchsatz für Serialisierung, Deserialisierung).
- Kryo - Java-Serialisierung und Klonen: schnell, effizient, automatisch.
- Lite³ JSON-kompatibles Zero Copy Serialisierungsformat.
- MessagePack Effizientes binäres Serialisierungsformat.
- Protostuff - Eine Serialisierungsbibliothek mit integrierter Unterstützung für Vorwärts-Rückwärts-Kompatibilität (Schemaentwicklung) und Validierung.
- SBinary Bibliothek zur Beschreibung von Binärformaten für Scala-Typen.
- Thrift - Das Apache Thrift Software-Framework für skalierbare sprachübergreifende Diensteentwicklung.
- yyjson - Die schnellste JSON Bibliothek in C.
Lagerung
Abschnitt betitelt „Lagerung“- Apache Cassandra - Spaltenorientiert und hohe Verfügbarkeit ohne Single Point of Failure.
- Aerospike (c) - Hochleistungs-NoSQL-Datenbank mit skalierbarer Geschwindigkeit.
- ArangoDB - Eine verteilte kostenlose Open-Source-Datenbank mit einem flexiblen Datenmodell für Dokumente, Grafiken und Schlüsselwerte.
- Citus Verteilte PostgreSQL als Erweiterung.
- CockroachDB (c) Eine Cloud-native SQL-Datenbank nach dem Vorbild von Google Spanner.
- Couchbase Eine verteilte Datenbank, die für Leistung, Skalierbarkeit und vereinfachte Verwaltung entwickelt wurde.
- Crate (c) - Skalierbare SQL-Datenbank mit den NoSQL Goodies.
- Druid - Schneller spaltenorientierter verteilter Datenspeicher.
- Elasticsearch Open Source verteilt, skalierbar und hochverfügbar Suchserver.
- Geode - Open Source, verteilte In-Memory-Datenbank für Scale-Out-Anwendungen.
- Infinispan - Hochkonkurrenter Schlüssel/Wert-Datenspeicher, der für das Caching verwendet wird.
- InfluxDB Skalierbarer Datenspeicher für Metriken, Ereignisse und Echtzeitanalysen.
- RethinkDB Open Source, skalierbare Datenbank, die das Erstellen von Echtzeit-Apps erleichtert.
- TiKV Verteilte transaktionale Key-Value-Datenbank.
- TimescaleDB - Eine Zeitreihen-Datenbank für leistungsstarke Echtzeit-Analysen, verpackt als Postgres-Erweiterung.
- Trino - Schnell verteilte SQL-Abfrage-Engine für Big Data Analytics, mit der Sie Ihr Datenuniversum erkunden können.
Prüfung
Abschnitt betitelt „Prüfung“- Goreplay Ein Tool zum Erfassen und Wiedergeben von Live-HTTP-Datenverkehr in einer Testumgebung.
- Keploy - Open-Source-Tool für API-Tests und -Mocking, indem realer Datenverkehr erfasst und in Testfälle und Stubs umgewandelt wird, was zuverlässiges Microservice-Testing ermöglicht.
- Mitmproxy Ein interaktives Konsolenprogramm, mit dem Verkehrsströme abgefangen, inspiziert, modifiziert und wiedergegeben werden können.
- MockServer - Mocking, Debugging von Proxy und Chaos Engineering für mehrere Protokolle (HTTP, gRPC, GraphQL, LLM, MCP, Kafka, TCP und mehr); Mock-Abhängigkeiten, Aufzeichnung / Wiedergabe von Datenverkehr, Überprüfung von Anforderungen und Injection von Fehlern für Integrations- und Resilienztests.
- Mountebank - Cross-Plattform, Multi-Protokoll-Test verdoppelt sich über den Draht.
- Pact Vertragstest-Framework für HTTP-APIs und nicht-HTTP-asynchrone Messaging-Systeme.
- RestQA Ein Tool zur Verwaltung von Microservices-Mocking, Unit- und Performance-Tests vor Ort mit bester Entwicklererfahrung.
- Specmatic - Konvertiert API-Spezifikationen (OpenAPI, AsyncAPI, GraphQL, gRPC usw.) in ausführbare Verträge für automatisiertes Testen, Service-Virtualisierung und Abwärtskompatibilitätsvalidierung, ohne Code zu schreiben.
- VCR Notieren Sie die HTTP-Interaktionen Ihrer Testsuite und wiederholen Sie sie während zukünftiger Testläufe für schnelle, deterministische und genaue Tests. Siehe die Liste der Ports für Implementierungen in anderen Sprachen.
- Wilma Kombinierter HTTP/HTTPS Service Stub und transparente Proxy-Lösung.
- WireMock - Flexible Bibliothek für Stubbbing und Spott Web-Services. Im Gegensatz zu allgemeinen Spott-Tools funktioniert es, indem es einen tatsächlichen HTTP-Server erstellt, mit dem sich Ihr getesteter Code verbinden kann, wie es ein echter Webdienst wäre.
- Hoverfly - Lightweight Service Virtualisierung / API-Simulationstool für Entwickler und Tester.
Continuous Integration & Delivery
Abschnitt betitelt „Continuous Integration & Delivery“- Awesome CI/CD DevOps :star: - Eine kuratierte Liste fantastischer Tools für Continuous Integration, Continuous Delivery und DevOps.
Web API Modellierung & Dokumentation
Abschnitt betitelt „Web API Modellierung & Dokumentation“- AsyncAPI - AsyncAPI-Spezifikation, der Industriestandard zur Definition asynchroner APIs.
GraphQL
Abschnitt betitelt „GraphQL“- GraphQL Abfragesprache, die entwickelt wurde, um Clientanwendungen zu erstellen, indem sie eine intuitive und flexible Syntax und ein System zur Beschreibung ihrer Datenanforderungen und Interaktionen bereitstellt.
- JSON:API Eine Spezifikation, wie ein Client anfordern sollte, dass Ressourcen abgerufen oder geändert werden, und wie ein Server auf diese Anforderungen reagieren sollte.
- API Blueprint - Tools für Ihren gesamten API-Lebenszyklus. Verwenden Sie es, um Ihre API mit anderen zu besprechen. Erstellen Sie die Dokumentation automatisch. Oder eine Test-Suite. Oder sogar ein bisschen Code.
- OpenAPI Die OpenAPI-Spezifikation (OAS) bietet ein konsistentes Mittel, um Informationen durch jede Phase des API-Lebenszyklus zu tragen.
- RAML - RESTful API Modeling Language, eine einfache und prägnante Art, praktisch RESTful APIs zu beschreiben.
- ReDoc - OpenAPI/Swagger-generierte API Dokumentation.
- Scalar - Open-Source-API-Plattform: schöne API-Referenzen und erstklassige OpenAPI / Swagger-Unterstützung.
- Slate - Schöne statische Dokumentation für Ihre API.
- Spring REST Docs - Dokumentieren Sie RESTful-Services durch die Kombination von handschriftlicher Dokumentation mit automatisch generierten Snippets, die mit Spring MVC Test erstellt wurden.
- Swagger - Eine einfache, aber leistungsstarke Darstellung Ihrer RESTful API.
Normen / Empfehlungen
Abschnitt betitelt „Normen / Empfehlungen“World Wide Web
Abschnitt betitelt „World Wide Web“- W3C.REC-Webarch Architektur des World Wide Web, Band Eins.
- RFC3986 Uniform Resource Identifier (URI): Generische Syntax.
- RFC6570 - URI Template.
- RFC7320 - URI Design und Eigentum.
Selbstverwaltung & Dezentralisierung
Abschnitt betitelt „Selbstverwaltung & Dezentralisierung“- DID - W3C-Spezifikation von dezentralen Identifikatoren (DIDs): ein neuer Typ von Identifikatoren, der überprüfbare, dezentrale digitale Identität ermöglicht.
- DIDComm - Private Kommunikationsmethodik, die auf dem dezentralen Design von DIDs aufbaut.
- DIDComm Protocols - Registrierung von Protokollen, die auf DIDComm aufbauen, für vertrauensvolle, selbstsouveräne Interaktionen über jeden Transport.
- IDSA Die International Data Spaces Association (IDSA) hat es sich zur Aufgabe gemacht, die Zukunft der globalen, digitalen Wirtschaft mit International Data Spaces (IDS) zu schaffen, einem sicheren, souveränen System des Datenaustauschs, in dem alle Teilnehmer den vollen Wert ihrer Daten realisieren können.
HTTP/1.1
Abschnitt betitelt „HTTP/1.1“- RFC7230 - Nachrichtensyntax und Routing.
- RFC7231 Semantik und Inhalt.
- RFC7232 - Bedingte Anfragen.
- RFC7233 Range Requests.
- RFC7234 - Caching.
- RFC7235 - Authentifizierung.
- RFC7807 - Problemdetails für HTTP APIs.
- RFC7540 Hypertext Transfer Protocol Version 2.
- QUIC-WG - IETF Working Group, die gechartert ist, um das nächste Transportprotokoll für das Internet zu liefern.
- QUIC-Transport - Ein UDP-basierter Multiplex- und sicherer Transport.
- JSON-RPC 2.0 Ein zustandsloses, leichtes Remote Procedure Call (RPC) Protokoll.
- Open RPC Die OpenRPC-Spezifikation definiert eine standardmäßige, programmsprachenunabhängige Schnittstellenbeschreibung für JSON-RPC 2.0 APIs.
Messaging
Abschnitt betitelt „Messaging“- AMQP - Advanced Message Queuing Protocol.
- MQTT MQ Telemetrie Transport.
- STOMP Einfaches textorientiertes messaging-protokoll.
Sicherheit
Abschnitt betitelt „Sicherheit“- GNAP Das Grant Negotiation and Authorization Protocol definiert einen Mechanismus zum Delegieren der Autorisierung an eine Software und zum Übertragen dieser Delegation an die Software. Diese Delegation kann den Zugriff auf eine Reihe von APIs sowie Informationen umfassen, die direkt an die Software weitergeleitet werden.ENTWURF
- OIDCONN OpenID Connect 1.0 ist eine einfache Identitätsschicht auf dem OAuth 2.0-Protokoll. Es ermöglicht Clients, die Identität des Endbenutzers basierend auf der von einem Autorisierungsserver durchgeführten Authentifizierung zu überprüfen und grundlegende Profilinformationen über den Endbenutzer auf interoperable und REST-ähnliche Weise zu erhalten.
- PASETO - Paseto ist alles, was Sie an JOSE (JWT, JWE, JWS) lieben, ohne eines der vielen Designdefizite, die die JOSE-Standards plagen. ENTWURF
- RFC5246 - The Transport Layer Security (TLS) Protocol Version 1.2.
- RFC6066 TLS-Erweiterungen.
- RFC6347 Datagram Transport Layer Security Version 1.2.
- RFC6749 Das OAuth 2.0 Authorization Framework.
- RFC6962 - Transparenz des Zertifikats.
- RFC7515 JSON Web Signature (JWS) stellt Inhalte dar, die mit digitalen Signaturen oder Message Authentication Codes (MACs) unter Verwendung von JSON-basierten Datenstrukturen gesichert sind.
- RFC7519 JSON Web Token (JWT) ist ein kompaktes, URL-sicheres Mittel zur Darstellung von Ansprüchen, die zwischen zwei Parteien übertragen werden.
- RFC7642 - SCIM: Definitionen, Übersicht, Konzepte und Anforderungen.
- RFC7643 - SCIM: Core Schema bietet ein plattformneutrales Schema und Erweiterungsmodell zur Darstellung von Benutzern und Gruppen.
- RFC7644 SCIM: Protokoll, ein REST-Protokoll auf Anwendungsebene zur Bereitstellung und Verwaltung von Identitätsdaten im Web.
Service Discovery
Abschnitt betitelt „Service Discovery“- DNS-SD - Mechanismus für Clients zum Auffinden einer Liste benannter Instanzen eines Dienstes unter Verwendung von Standard-DNS-Abfragen.
- RFC2782 - Eine DNS RR zur Angabe des Standorts von Diensten (DNS SRV).
Datenformate
Abschnitt betitelt „Datenformate“- RFC4627 JavaScript Object Notation (JSON).
- RFC7049 - Concise Binary Object Representation (CBOR).
- BSON Binär JSON (BSON).
- JSON-LD JSON für Linking Data.
- SBE Einfache binäre Kodierung (SBE).
- MSGPACK - MessagePack Spezifikation.
Vokabular
Abschnitt betitelt „Vokabular“- JSON Schema - Vokabular, mit dem Sie JSON-Dokumente kommentieren und validieren können.
- Schema.org - Zusammenarbeitende, gemeinschaftliche Aktivitäten mit der Mission, Schemata für strukturierte Daten im Internet, auf Webseiten, in E-Mail-Nachrichten und darüber hinaus zu erstellen, zu pflegen und zu fördern.
Unicode
Abschnitt betitelt „Unicode“- UNIV8 Das Unicode Consortium. Der Unicode Standard, Version 8.0.0, (Mountain View, CA: The Unicode Consortium, 2015. ISBN 978-1-936213-10-8).
- RFC3629 - UTF-8, ein Transformationsformat von ISO 10646.
Organisationsdesign / Teamdynamik
Abschnitt betitelt „Organisationsdesign / Teamdynamik“- How Do Committees Invent? :small_orange_diamond:PDF - Melvin E. Conway, Datamation Magazin 1968. Der ursprüngliche Artikel, der Conway’s Law definiert.
- Service per Team Jedes Team ist für eine oder mehrere Geschäftsfunktionen (z. B. Geschäftsfunktionen) verantwortlich. Ein Team besitzt eine Codebasis, die aus einem oder mehreren Modulen besteht. Seine Codebasis ist so bemessen, dass sie die kognitive Kapazität des Teams nicht übersteigt. Das Team stellt seinen Code als einen oder mehrere Dienste bereit. Ein Team sollte genau einen Dienst haben, es sei denn, es besteht ein nachgewiesener Bedarf an mehreren Diensten.
- Start with Team Cognitive Load - Team Topologies :small_red_triangle:YT DOES19 London. Die Debatte “Monolithen vs. Microservices” konzentriert sich oft auf technologische Aspekte und ignoriert Strategie und Teamdynamik. Anstelle von Technologie beginnen intelligente Unternehmen mit der kognitiven Belastung des Teams als Leitprinzip für moderne Software. In diesem Vortrag erklären wir wie und warum, veranschaulicht durch reale Fallstudien.
Unternehmen & Vertikale
Abschnitt betitelt „Unternehmen & Vertikale“- Commercetools Headless Handelsplattform.
- Equinox Infosys Equinox ist eine menschenzentrierte Handels- und Marketingplattform, die reichhaltige, hyperpersonalisierte Erlebnisse über alle Kanäle und Touchpoints hinweg unterstützt.
- Flamingo Framework zum Aufbau flexibler und moderner E-Commerce-Anwendungen.
- Medusa Headless Open-Source-Commerce-Plattform.
Theorie
Abschnitt betitelt „Theorie“Artikel & Papiere
Abschnitt betitelt „Artikel & Papiere“- Autonomy, Hyperconnectivity, and Residual Causality - Philosophische Einführung in das Design von adaptiven hyperliminalen Systemen durch Theorien der Komplexitätswissenschaft.
- Awesome Scalability :star: Eine aktualisierte und organisierte Leseliste zur Veranschaulichung der Muster skalierbarer, zuverlässiger und leistungsfähiger Großsysteme. Konzepte werden in den Artikeln prominenter Ingenieure und glaubwürdigen Referenzen erklärt. Fallstudien werden von kampferprobten Systemen genommen, die Millionen bis Milliarden von Benutzern dienen.
- AKF Scale Cube - Modell zur Darstellung der Dimensionen zur Skalierung eines Dienstes.
- CALM :small_orange_diamond:PDF Konsistenz als logische Monotonie.
- Canary Release - Technik, um das Risiko der Einführung einer neuen Softwareversion in der Produktion zu reduzieren, indem die Änderung langsam an eine kleine Teilmenge von Benutzern ausgerollt wird, bevor sie auf die gesamte Infrastruktur übertragen und für alle verfügbar gemacht wird.
- CAP Theorem - besagt, dass es für ein verteiltes Computersystem unmöglich ist, gleichzeitig alle drei der folgenden Garantien zu bieten: Konsistenz, Verfügbarkeit und Partitionstoleranz.
- Formal Foundations of Serverless Computing :small_orange_diamond:PDF Die serverlose Computerabstraktion zeigt mehrere Betriebsdetails auf niedriger Ebene, die es Programmierern schwer machen, ihren Code zu schreiben und zu begründen. Dieser Artikel beleuchtet dieses Problem, indem er λ, eine operative Semantik der Essenz von Serverless Computing, präsentiert.
- Microservice Architecture - Besondere Art, Softwareanwendungen als Suiten von unabhängig einsetzbaren Diensten zu entwerfen.
- Microservices - From Design to Deployment :small_orange_diamond:PDF - Die siebenteilige Serie von F5 zu Microservices.
- Microservices – Please, don’t - Kritische Ratschläge zu einigen Problemen in Bezug auf einen Microservices-Ansatz.
- Microservices Trade-Offs - Leitfaden zum Nachdenken über Kosten und Vorteile des Architekturstils von mircoservices.
- Reactive Manifesto - Definition reaktiver Systeme.
- Reactive Streams - Initiative zur Bereitstellung eines Standards für die asynchrone Stromverarbeitung mit nicht blockierendem Gegendruck.
- ROCAS :small_orange_diamond:PDF Ressourcenorientiertes Computing für adaptive Systeme.
- SECO :small_orange_diamond:PDF Software-Ökosysteme verstehen: Ein strategischer Modellierungsansatz.
- Testing Strategies in a Microservice Architecture - Ansätze zur Verwaltung der zusätzlichen Testkomplexität mehrerer unabhängig einsetzbarer Komponenten.
- Your Server as a Function :small_orange_diamond:PDF Beschreibt drei Abstraktionen, die ein leistungsfähiges Programmiermodell für den Aufbau einer sicheren, modularen und effizienten Serversoftware darstellen: Composable Futures, Services und Filter.
Websites und Organisationen
Abschnitt betitelt „Websites und Organisationen“- Cloud Native Computing Foundation Die Cloud Native Computing Foundation baut nachhaltige Ökosysteme auf und fördert eine Community rund um eine Konstellation hochwertiger Projekte, die Container als Teil einer Microservices-Architektur orchestrieren.
- CNCF Cloud Native Interactive Landscape - Interaktive Landschaft von Cloud Native Technologien.
- Microservices Resource Guide - Martin Fowlers Auswahl an Artikeln, Videos, Büchern und Podcasts, die Ihnen mehr über den Architekturstil von Microservices beibringen können.
- Microservice Patterns Microservice-Architekturmuster und Best Practices.
- Microservice Antipatterns and Pitfalls - Microservice meist bekannte Anti-Muster und Fallstricke.
Beitrag
Abschnitt betitelt „Beitrag“Bitte lesen Sie die Contribution Guidelines Bevor Sie Ihren Vorschlag einreichen.
Fühlen Sie sich frei open an issue oder create a pull request Mit deinen Ergänzungen.
:star2: Vielen Dank!
HagiCode
HagiCode ist ein agentischer Coding-Arbeitsplatz. Vielseitige, komfortable Interaktionen in der Benutzeroberfläche machen Planung, Agent-Ausführung und Projektarbeit zugänglich und leicht nachvollziehbar – für ein ansprechendes Entwicklungserlebnis.
Entdecken Sie ein ansprechendes Entwicklungserlebnis mit vielseitigen, komfortablen Interaktionen in der Benutzeroberfläche.
- IntelligentOpenSpec-Workflows machen aus einer Absicht einen umsetzbaren Weg vom Vorschlag über Design und Aufgaben bis zur Auslieferung.
- EffizientMulti-Agent-Ausführung führt Recherche, Umsetzung und Prüfung parallel aus, über mehrere Repositories und die Agent CLIs, die Sie bereits nutzen.
- InteressantVielseitige, komfortable Interaktionen in der Benutzeroberfläche machen Planung, Agent-Ausführung und Projektarbeit zugänglich und leicht nachvollziehbar.
Für Windows herunterladen
HagiCode teilen
Aus Ideen wird ausgelieferte Software.
HagiCode ist ein agentischer Coding-Arbeitsplatz: OpenSpec-Workflows planen die Änderung, Multi-Agent-Ausführung setzt sie um, und Hero Scenario macht den langen Weg sichtbar, bis aus der Idee ausgelieferte Software wird.
- Intelligent
- OpenSpec-Workflows machen aus einer Absicht einen Weg vom Vorschlag bis zur Auslieferung.
- Effizient
- Multi-Agent-Ausführung treibt Recherche, Umsetzung und Prüfung parallel voran.
- Unterhaltsam
- UI-Interaktionen erleichtern Planung, Agent-Ausführung und Projektarbeit.
© 2026 HagiCode | Powered By hagilight-starlight@0.21.0 | Branch: main | Commit: 745b50b | Built:


