コンテンツにスキップ

言語の選択

現在の言語: 日本語

Microservices

Source: https://github.com/mfornos/awesome-microservices at 417c83dc4de7
License: CC0-1.0
Read the English original

This edition is an AI-assisted translation.

マイクロサービス関連リソースの厳選集 Awesome

Section titled “マイクロサービス関連リソースの厳選集 ”

マイクロサービスアーキテクチャ関連の原則と技術に関するキュレーションリスト。

コンテンツの表

  • 1Backend - AIネイティブマイクロサービスプラットフォーム。
  • Jolie - オープンソースのmicroservice指向プログラミング言語。
  • OpenWhisk - サーバーレス、オープンソースクラウドプラットフォームは、あらゆる規模でイベントに対応する機能を実行します。
  • Pulumi - クラウドネイティブインフラ向けSDK お気に入りの言語を使用して、アプリやインフラの更新をプレビューして管理し、任意のクラウド(YAMLは必要ありません)に継続的にデプロイします。
  • Triton - 次世代、コンテナベース、サービス指向のインフラを1つまたは複数のデータセンターに配信するオープンソースクラウド管理プラットフォーム。
  • Akka - JVM上でのメッセージドリブンなアプリケーションを高度に同時、分散、および弾力性を高めるためのツールキットとランタイム。
  • Axon (c) - JVM上の任意のDDD、CQRSおよびイベントソーシングアプリケーションを簡単に開発および実行するためのエンドツーエンドの開発とインフラプラットフォーム。
  • Ballerina - クラウドネイティブプログラミング言語
  • Bun - オールインワンJavaScriptランタイムを高速化。
  • Dapr - 任意のプログラミング言語を使用して、非常に実行可能なマイクロサービスを書くためのオープンソースのランタイム。
  • Deno - JavaScript、TypeScript、WebAssemblyランタイム、安全なデフォルトと優れた開発者体験。
  • Eclipse Microprofile - 企業Javaを最適化するためのオープンフォーラムは、複数の実装を革新し、標準化の目標と共通の分野に協力することによって、マイクロサービスアーキテクチャを最適化します。
  • Erlang/OTP - 大規模なソフトリアルタイムシステムを構築するために使用されるプログラミング言語は、高可用性の要件で使用されます。
  • Finagle - JVM 用の拡張可能な RPC システムで、高通貨サーバーの構築に使用されます。
  • Gleam - タイプ安全、スケーラブルなシステムを構築するためのフレンドリーな言語。
  • GraalVM - マイクロサービスにとって理想的なアプリケーションの性能および効率の重要な改善を提供する高性能のランタイム。
  • Helidon - Nettyの高速Webコア上で実行するmicroservicesを書くためのJavaライブラリのコレクション。
  • Ice - C++、C#、Java、JavaScript、Pythonなどのサポートを備えた包括的なRPCフレームワーク。
  • Light-4j - 高スループット、低レイテンシー、小さなメモリフットプリント、より生産的なマイクロサービスプラットフォーム。
  • Micronaut - モジュラー、簡単にテスト可能なマイクロサービスアプリケーションを構築するための近代的、JVMベース、フルスタックフレームワーク。
  • Moleculer - Node.js、Java、Go、Ruby用の高速かつ強力なマイクロサービスフレームワーク。
  • Open Liberty - 迅速かつ効率的なクラウドネイティブJavaマイクロサービスを構築するための軽量オープンフレームワーク。
  • Pears - ピアツーピアランタイム、開発、展開。
  • SmallRye - Eclipse MicroProfile を含むクラウド開発に適した API と実装。
  • Spin - WebAssemblyで高速でセキュアなクラウドサービスを構築し、実行するためのオープンソースフレームワーク。
  • ScaleCube - JVMの反応マイクロサービスを構築するツールキット:低レイテンシー、高スループット、スケーラブル、弾力性。
  • Vert.X - JVM上での反応アプリケーションを構築するツールキット。
  • Vert.X Toolbox - アクティブマイクロサービスアプリケーションを構築するためのVert.xコンポーネントのセット。
  • Wangle - 一貫した、モジュール式で構築するサービスの共通クライアント/サーバー抽象化のセットを提供するフレームワーク。
  • GRPC - モバイルとHTTP/2を最初に置いた高性能、オープンソース、一般的なRPCフレームワーク。 C、C++、Java、Go、Node.js、Python、Ruby、Objective-C、PHP、C#のライブラリ。
  • Lwan - 高性能でスケーラブルなWebサーバー。
  • uSockets - 非同期アプリケーション用のミニセルクロスプラットフォームイベント、ネットワーキング、および暗号化。
  • Cap’n Proto RPC - Cap’n Proto C++ RPCの実装。
  • C++ Micro Services - OSGi のような C++ 動的モジュール システムおよびサービス レジストリ。
  • Enduro/X - GNU/Linux用のXATMIベースのサービスフレームワーク。
  • Pistache - C++で書かれた高性能RESTツールキット。
  • Poco - ネットワークベースのアプリケーションとサーバーを構築するためのC++クラスライブラリ。
  • Sogou Workflow - バックエンド開発要件のほとんどを満たすことを目的としたエンタープライズグレードのプログラミングエンジン。
  • uWebSockets - 最も要求される適用のための簡単で、安全及び標準の迎合的な網サーバー。
  • Awesome Microservices .NET Core :star: - .NETコアのマイクロサービスのための素晴らしいトレーニングシリーズ、記事、ビデオ、書籍、コース、サンプルプロジェクト、およびツールのコレクション。
  • Vibe.d - D で書かれているあなたの方法で取得しない非同期 I/O。
  • Phoenix - HTML5アプリ、APIバックエンド、分散システムの構築のためのフレームワーク。
  • Plug - ウェブアプリケーション間の互換性のあるモジュールの仕様と利便性。
  • Cowboy - Erlang で書かれた小型で高速なモジュラー HTTP サーバ。
  • Mochiweb - 軽量なHTTPサーバを構築するためのErlangライブラリ。
  • Chi - Go HTTP サービスをビルドするための軽量で慣用的で、互換性のあるルーター。
  • Echo - Go の HTTP サーバフレームワークを高速かつアンファンシーにします。残りよりも 10x まで高速です。
  • Fiber - Express は Fasthttp の上に構築された Web フレームワークを触発しました。Go の最速の HTTP エンジンです。メモリ割り当てやパフォーマンスをゼロにすることで、素早く開発できるように設計しました。
  • Gin - GinはGo(Golang)で書かれているHTTP Webフレームワークです。 マティーニのような API は、パフォーマンスが向上し、最大 40 倍の高速化を実現します。
  • Goa - Go の HTTP マイクロサービスの設計に基づく。
  • GoFr ・スケーラビリティと堅牢性を強調する、見解されたマイクロサービス開発フレームワーク。 マイクロサービスの開発を簡素化する設計。
  • Go Chassis - クラウドエコシステムとの統合が容易であるGoのmicroservicesの急速な発展のためのフレームワーク。
  • Go-micro - 分散システム開発フレームワーク。
  • Go-zero - ウェブとrpc分散システム開発フレームワーク。
  • Gorilla - Goプログラミング言語用のWebツールキット。
  • Iris - 迅速かつシンプルで効率的なマイクロWebフレームワークでGo.
  • Lura - ミドルウェアで超高速APIゲートウェイを構築するためのフレームワーク。
  • RPCX - Alibaba DubboおよびWeibo MotanのようなNET/RPCに基づく分散RPCサービスフレームワーク。
  • Scotty - RubyのSinatraに触発されたマイクロWebフレームワークは、WAIとWarpを使っています。
  • Servant - タイプレベルのWeb DSL。
  • Yesod - Haskell RESTful Webフレームワーク。
  • Compojure - Ring/Clojureの簡潔なルーティングライブラリ。
  • Duct - Clojureのサーバー側のフレームワーク。
  • System - Stuart Sierraのコンポーネントライブラリの上に構築され、既製のコンポーネントのセットを提供しています。
  • Tesla - Otto.deのClojureのmicroservicesのいくつかのための共通の基礎。
  • ActiveJ - 複雑な高負荷分散アプリケーションとMemcachedのようなソリューションのための軽量で高速なライブラリ。
  • Airlift - JavaでRESTサービスを構築するフレームワーク。
  • Armeria - オープンソースの非同期 HTTP/2 RPC/REST クライアント/サーバーライブラリは、Java 8, Netty, Thrift, gRPC の上に構築されています。
  • Disruptor - 高性能インタースレッドメッセージングライブラリ。
  • Dropwizard - 不適切で高性能なWebサービスを開発するためのJavaフレームワーク。
  • Dubbo - Alibabaによってオープンソース化された高性能のJavaベースのRPCフレームワーク。
  • Conjure - クライアントとしてFeignまたはRetrofitに基づいてRESTish/RPCサーバーとクライアントを定義し、作成するためのライブラリのopinionatedセットと、JAX-RSサービス定義をサーバーとしてDropwizard/Jersey。
  • Jersey - JavaのRESTfulサービス。JAX-RSリファレンス実装。
  • Quarkus - A Kubernetes OpenJDK HotSpot と GraalVM 用に設計されたネイティブ Java スタックは、品種の Java ライブラリと標準の最高のものから作られています。
  • Ratpack - 迅速で効率的な、進化し、よくテストされた HTTP アプリケーションを容易にする Java ライブラリのセット。 Groovy言語の特定のサポートが提供されます。
  • Spring Boot - スタンドアローン、生産グレードのスプリングベースのアプリケーションを簡単に作成できます。
  • Http4k - 機能的かつ一貫した方法でHTTPサービスのサービングと消費を可能にする純粋なコトリンで書かれた軽量で十分に機能するHTTPツールキット。
  • Ktor - Kotlinプログラミング言語を使用して、非同期サーバーとクライアントを接続システムに構築するためのフレームワーク。
  • Finatra - Twitter-ServerとFinagle上に構築された、高速でテスト可能な Scala HTTP サービス。
  • Http4s - HTTP 用の最小限の慣用 Scala インターフェイス
  • Play - JavaとScalaの高速Webフレームワーク。
  • Actionhero - 統合クラスタ機能と遅延タスクを備えたマルチトランスポートNode.js APIサーバー。
  • Express - Node.js の Web フレームワークの高速、非最適化、最小化
  • Fastify - Node.js 用の Fastify および Fast および Low の Web フレームワーク。
  • FeathersJS - 現代のアプリケーション用のオープンソースRESTおよびリアルタイムAPIレイヤー。
  • Hono - Edge 用の小規模でシンプルで超高速な Web フレームワーク。 JavaScript のランタイムで動作します。
  • Koa - Node.jsの次世代Webフレームワーク
  • Loopback - API を作成するための Node.js フレームワークで、データをバックエンドに簡単に接続できます。
  • NestJS - Node.jsフレームワークは、組み込みのmicroservicesサポートを使用して、効率的でスケーラブルなサーバーサイドアプリケーションを構築します。
  • Seneca - Node.js用のmicroservicesツールキット
  • Serverless - AWS Lambda および API Gateway で実行されている Web、モバイル、IoT アプリケーションの構築と維持(JAWS として以前)。
  • tRPC - エンドツーエンド型安全API。
  • Cro - Perl 6を使用して、反応分散システムを作成するライブラリ。
  • Mojolicious - Perlの次世代Webフレームワーク。
  • API Platform - JSON-LD、Schema.org、HydraのサポートでSymfonyのトップにあるAPIファーストWebフレームワーク。
  • Ecotone - 建物ブロックを提供するDDD、CQRSおよびイベントソーシングの建築原則に基づいてフレームワークは、スケーラブルで拡張可能なアプリケーションを作成する。
  • Hyperf - Hyperf は、Swoole 4.5+ に基づく非常に実行可能で柔軟な PHP CLI フレームワークで、最先端のコルウチンサーバーと多数の戦闘テストコンポーネントが搭載されています。
  • Lumen - 驚くほど高速マイクロフレームワーク。
  • Slim - シンプルでパワフルなWebアプリケーションやAPIを素早く書き出すことができるマイクロフレームワーク。
  • Spiral - 長期にわたる適用の使用のために設計されているフレームワーク RoadRunner. それはとの統合のような高度の特徴を提供します Temporal ワークフローエンジンと Centrifugo websocket サーバー マイクロサービスアーキテクチャには特に効果的で、REST API および gRPC サービスの堅牢なサポートを提供します。
  • Swoft - 高性能なWebシステム、API、ミドルウェア、基本サービスの構築のためのPHPマイクロサービスコルテインフレームワーク。
  • Symfony - Symfony コンポーネントに基づくマイクロフレームワーク
  • Aiohttp - asyncio 用の HTTP クライアント/サーバー。
  • Bottle - Python用の高速でシンプルで軽量なWSGIマイクロWebフレームワーク。
  • Connexion - 自動エンドポイント検証とOAuth2サポートでフラスコの上にPython用のSwagger/OpenAPIフレームワーク。
  • Falcon - 非常に高速なアプリのバックエンドとマイクロサービスを構築するためのベアメタルPython Web APIフレームワーク。
  • FastAPI - モダンで高速な(高性能)、標準のPythonタイプヒントに基づいて、Python 3.6+でAPIをビルドするためのWebフレームワーク。
  • Flask - WerkzeugとJinja 2に基づくマイクロサービスのPythonフレームワーク
  • Nameko - マイクロサービスを構築するPythonフレームワーク。
  • Sanic - Sanicは高速に行くために書かれているフラスコのようなPython + Webサーバーです。
  • Tornado - Webフレームワークと非同期ネットワークライブラリ。
  • Twisted - イベント主導のネットワークプログラミングエンジン。
  • Web.py - Python用のミニマリストWebフレームワーク。
  • Grape - REST のような API を作成するための意見付きのフレームワーク
  • Hanami - Rubyの近代的なWebフレームワーク。
  • Praxis - APIの設計と実装のためのフレームワーク。
  • Scorched - Ruby用の軽量Webフレームワーク。
  • Sinatra - Sinatraは、RubyでWebアプリケーションを素早く作成するためのDSLです。
  • Are we web yet? :star: - RustのWebプログラミングの現在の状態の概要。
  • Actix - Rustの強力で実用的で、非常に速いWebフレームワーク。
  • Tarpc - RPCフレームワーク Rustは、使いやすさに重点を置いています。
  • Tokio - ネットワークアプリケーションを書くための非同期ランタイム。
  • Tower - 堅牢なネットワーククライアントとサーバーを構築するためのモジュラーおよび再利用可能なコンポーネントのライブラリ。
  • Wtx - HTTP/2クライアント/サーバーフレームワーク。
  • Awesome Micro Frontends :star: - マイクロフロントエンドに関するリソースのキュレーションリスト。
  • Electrode - ユニバーサルReact/Node.jsアプリケーションプラットフォーム。
  • Micro Frontends - microserviceのアイデアをフロントエンド開発に拡張します。
  • MiniApp White Paper - MiniAppの標準化の白いペーパー。

APIゲートウェイ/エッジサービス

Section titled “APIゲートウェイ/エッジサービス”
  • Ambassador (c) - - - KubernetesEnvoy 上に構築されたマイクロサービス用の -native API ゲートウェイ。
  • Apache APISIX - NGINXおよびetcdで造られる高性能、実時間APIの入り口およびAIのゲートウェイは熱荷を積まれたルーティングおよび100+のプラグインと。
  • APIcast - APIcastはNGINXの上に構築されたAPIゲートウェイです。 Red Hat 3scale API Management Platformの一部です。
  • Bunker Web - Webアプリのホスティングと逆プロキシはデフォルトで安全です。
  • Caddy - 自動HTTPSで拡張可能なHTTP / 2 Webサーバー。
  • Camel - Java ベースのフルエント API や Spring や Blueprint XML の設定ファイル、 Scala DSL など、さまざまなドメイン固有の言語でルーティングとメディアのルールを定義するエンパワフル。
  • Envoy - オープンソースのエッジとサービスプロキシ、開発者からLyft。
  • HAProxy - 信頼できる、高性能TCP/HTTPの負荷バランサ。
  • Istio - マイクロサービスを接続し、管理し、そして保障する開いたプラットホーム。
  • Keepalived - LinuxシステムおよびLinuxベースのインフラストラクチャへの負荷分散と高可用性のためのシンプルで堅牢な施設。
  • Kong - API のソース管理レイヤーを開きます。
  • KrakenD - オープンソースの超高速APIゲートウェイ。
  • Kuma - サービス網およびmicroservicesのためのプラットホームのgnosticの開いた源制御平面。
  • Linkerd - クラウドネイティブアプリ用のレジリエントサービスメッシュ。
  • Neutrino - 拡張可能なソフトウェアロードバランサ。
  • OpenResty - Nginxの上に構築された高速Webアプリケーションサーバー。
  • Open Service Mesh - 軽量で拡張可能なクラウドネイティブサービスメッシュ。
  • Otoroshi - 軽量のAPI管理の現代HTTPの逆のプロキシ。
  • Pingora - 迅速かつ信頼性が高く、進化するネットワークサービスを構築するライブラリ。
  • Skipper - サービスロジックからルーティングをデカップリングするのに役立つHTTPルーター。
  • Spring Cloud Gateway - Spring MVC の上にある API Gateway です。 API にルーティングするシンプルで効果的な方法を提供することを目指しています。
  • Tengine - 高度な機能を備えたNginxの配布。
  • Træfɪk - マイクロサービスを簡単にデプロイするために作られた現代のHTTPリバースプロキシとロードバランサー。
  • Traffic Server - クラウドサービスのための高性能ビルディングブロック。
  • Tyk - オープンソース、高速かつスケーラブルなAPIゲートウェイ、ポータル、API管理プラットフォーム。
  • Vulcand - プログラマティックロードバランサーは、etcd によってバックアップ。
  • Zuul - 動的ルーティング、監視、レジリエンス、セキュリティなどを提供するエッジサービス。
  • Central Dogma - Git、ZooKeeper、HTTP/2に基づいて、オープンソースの高度に利用できるバージョン管理サービス構成リポジトリ。
  • Consul - サービスの発見および構成は容易にしました。 分散型、高機能、データセンターアウェア。
  • Etcd - 共有構成およびサービスの発見のための高度に利用できるキー価値の店。
  • Eureka - 主にAWSクラウドで使用されているRESTベースのサービスで、ロードバランシングとミドルティアサーバのフェイルオーバーの目的でサービスを配置します。
  • Microconfig - マイクロサービスの構成管理の現代そして簡単な方法。
  • Nacos - 使いやすい動的サービスの発見、構成およびサービス管理のプラットホーム。
  • SkyDNS - エッチングの上に構築されたサービスの発表と発見のための分散サービス。 利用可能なサービスを発見するためにDNSクエリを利用します。
  • Spring Cloud Config - 分散システム内の外部設定のためのサーバーとクライアント側のサポートを提供します。
  • ZooKeeper - 信頼できる分散調整を可能にするオープンソースサーバー。

ワークフローのオーケストレーション

Section titled “ワークフローのオーケストレーション”
  • AWS Step Functions (c) - ビジュアルワークフローを使用して、分散型アプリケーションとマイクロサービスのコンポーネントを調整します。
  • Cadence - 故障明らかなステートフルなコードプラットフォーム。
  • Conductor - マイクロサービスオーケストレーションエンジン。
  • Inngest - バックグラウンドジョブから複雑なワークフローまで、信頼性の高いバックグラウンドロジックのための耐久性のある機能。
  • Kestra - オープンソースのマイクロサービスイベント主導、言語アグノスティックオーケストレーション、スケジューリングプラットフォーム。
  • Temporal - ミッションの重要なコードをあらゆる規模で実行するためのオープンソースのマイクロサービスオーケストレーションプラットフォーム。
  • Zeebe - 業務プロセスの定義、オーケスト、監視
  • Hazelcast - オープンソースのメモリ内データグリッド。 サーバー、クラスター、地理学を横断してデータと計算を配布し、非常に大きなデータセットやデータインジェストレートを管理することができます。 成熟した技術.
  • Helix - ノードのクラスターでホストされているパーティション、複製、分散リソースの自動管理に使用される一般的なクラスター管理フレームワーク。
  • Ignite - 大規模なデータセットをリアルタイムで計算し、変換するための高性能、統合および分散型インメモリープラットフォーム、従来のディスクベースまたはフラッシュ技術でより迅速にの大きさの注文。
  • Libp2p - ピアツーピアネットワークアプリケーションを構築するためのプロトコルのフレームワークとスイート。
  • Mesos - CPU、メモリ、ストレージ、およびマシン(物理または仮想)から離れた他の計算リソースを抽象化し、障害耐性と弾性分散システムを容易に構築し、効果的に実行できるようにします。
  • Nomad - 分散、高度に利用できる、datacenter-awareのスケジューラ。
  • Redisson - Redisサーバーの上部に分散およびスケーラブルなJavaデータ構造。
  • Serf - クラスターのメンバーシップ、失敗の検出およびオーケストレーションのための分散された解決。
  • Valkey - 以前のオープンソースのRedisプロジェクトで開発を再開するための新しいプロジェクト。
  • Zenoh - パブ/サブ/クエリ プロトコルは、データをモーション、残りと計算で統一します。 伝統的なパブ/サブを地分散ストレージ、クエリ、コンピューティングで効率的にブレンドします。

ジョブスケジューラ/ワークロードオートメーション

Section titled “ジョブスケジューラ/ワークロードオートメーション”
  • Celery - 分散メッセージの渡るに基づいて非同期タスクキュー/ジョブキュー。 リアルタイム操作に焦点を合わせ、スケジューリングをサポートします。
  • Dkron - 分散された、欠陥の許容の仕事のスケジューリング システム。
  • Faktory - 言語agnostic永続的な背景の仕事サーバー。
  • Rundeck (c) - ジョブスケジューラとランブックの自動化。 既存のスクリプトやツールへのセルフサービスアクセスを有効にします。
  • Schedulix - オープンソースのエンタープライズジョブスケジューリングシステムは、高度なシステム環境でITプロセスのプロフェッショナルな自動化のための画期的な基準を敷設します。
  • mirrord - リモートでポッドだったらローカルコードを実行します Kubernetes クラスター。
  • Fluentd - 統一されたロギング層のためのオープンソースのデータ収集装置。
  • Graylog - 完全に統合されたオープンソースログ管理プラットフォーム。
  • Kibana - 柔軟な分析と可視化プラットフォーム。
  • LogDNA (c) - 集中ログ管理ソフトウェア。 任意のプラットフォームからリアルタイムでログを即座に収集、一元化、分析します。
  • Logstash - イベントやログを管理するためのツール。
  • Loki - Prometheusのように、しかしログのために。
  • ØMQ - 無機理性的な輸送の層。
  • ActiveMQ - 強力なオープンソースメッセージングと統合パターンサーバー。
  • Aeron - 効率的な信頼性の高いUDPユニキャスト、UDPマルチキャスト、およびIPCメッセージ輸送。
  • Beanstalk - シンプルで高速な作業キュー。
  • Bull - ノードの高速かつ信頼性の高いRedisベースのキュー。
  • Crossbar - 分散およびマイクロサービスの適用のためのオープンソースのネットワーキングのプラットホーム。 これは、オープンWebアプリケーションメッセージングプロトコル(WAMP)を実行します。
  • Kafka - Publish-subscribeメッセージングは、分散コミットログとして求めた。
  • Malamute - ZeroMQエンタープライズメッセージングブローカー。
  • Mosquitto - MQTTプロトコルを実装するオープンソースメッセージブローカーを開きます。
  • NATS - オープンソース、高性能、軽量クラウドメッセージングシステム。
  • NSQ - リアルタイムの分散メッセージングプラットフォーム。
  • Pulsar - 分散パブサブメッセージングシステム。
  • RabbitMQ - オープンソースのErlangベースのメッセージブローカーが機能するだけです。
  • Redpanda - 開発者向けデータプラットフォームのストリーミング: Kafka API 互換、10倍高速、ZooKeeper なし、JVM なし。
  • RocketMQ - alibabaの大規模なメッセージングビジネスから生まれたメッセージ指向のミドルウェアを使用して、低レイテンシー、信頼性、スケーラブル、簡単に。
  • Beats - Elasticsearch および Logstash のための軽量の荷役。
  • Elastalert - Elasticsearch の容易な及び適用範囲が広い警告。
  • Ganglia - クラスターやグリッドなどの高性能コンピューティングシステム向けのスケーラブルな分散監視システム。
  • Grafana - オープンソースで、グラナイト、InfluxDB、OpenTSDB用の豊富なメトリックダッシュボードとグラフエディタを備えています。
  • Graphite - スケーラブルなリアルタイムグラフ。
  • IOpipe (c) - Amazon Lambdaのアプリケーション性能監視。
  • Jaeger - オープンソース、エンドツーエンドの分散トレース
  • OpenTelemetry - 良質、ubiquitousおよび有効な観察性を可能にする携帯用テレメトリー。
  • Prometheus - オープンソースサービス監視システムとタイムシリーズデータベース。
  • Riemann - 分散システムを監視します。
  • Sensu - 今日のインフラの監視
  • SkyWalking - 分散システムのための応用性能のモニター ツール、特にマイクロサービス、雲のネイティブおよび容器ベースの(Docker、 K8s、Mesos)の建築。
  • Zabbix - オープンソースのエンタープライズクラスの監視ソリューション。
  • Zipkin - 分散トレースシステム。
  • Arroyo - ストリーム処理エンジンを分散させ、SQLを書くことでデータストリームを変換、フィルタ、集計、結合します。
  • Reactor.io - Reactive Streams 仕様に基づいて、JVM 上で非ブロッキングアプリケーションを構築するための2世代のReactiveライブラリ。
  • Reactive Kafka - Apache Kafka の API をリアクティブストリームします。
  • ReactiveX - 保存可能なストリームで非同期プログラミングのためのAPI。 慣用的なJava、 Scala、C#、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++、C++
  • RSocket - 反応ストリームのセマティクスを提供するアプリケーションプロトコル。
  • Awesome Chaos Engineering :star: - 素晴らしいChaosエンジニアリングリソースのキュレーションリスト。
  • Raft Consensus - 理解しやすいように設計されたコンセンサスアルゴリズム。 障害耐性と性能のPaxosと同等です。
  • Resilience4j - Java8と機能プログラミング用に設計されたフォールト許容ライブラリ。
  • Svix - Webhooksサービスは、すべてのリトライスケジュール、指数関数的なバックオフ、シグネチャ検証、イベントタイプでユーザーにWebhooksを送信するサービスです。
  • Cerbos Hub - アクセスポリシーの承認、テスト、および展開のための認可管理システム。 マイクロサービスアーキテクチャでスケーラブルで、微細なグラインドされた認可を築きました。
  • Dex - プラグ可能なコネクターが付いているopinionated auth/directoryサービス。 OpenID Connect プロバイダーとサードパーティの OAuth 2.0 の委任
  • JWT - JSON Web トークンは、2 つのパーティ間でクレームを安全に表すためのオープンで業界標準の RFC 7519 メソッドです。
  • Keycloak - フル機能と拡張可能なオースサービス。 OpenID Connect プロバイダーとサードパーティの OAuth 2.0 の委任
  • OAuth - Webアプリケーション、デスクトップアプリケーション、携帯電話、リビングルームデバイス用の特定の承認フローを提供します。 多くの実装。
  • OpenID Connect - 現在のOpenID仕様と関連仕様を実装するライブラリ、製品、およびツール。
  • Open Ziti - 純粋なオープンソースソフトウェアとしてゼロ信頼のセキュリティとオーバーレイネットワーク。
  • ORY - オープンソースのアイデンティティインフラとサービスを開きます。
  • OWASP Agent Memory Guard — AIエージェントのメモリ中毒(OWASP ASI06)のランタイム防衛層。 改ざんされたメモリエントリ、メモリパスのプロンプト注入、およびシークレット漏れを検出します。 YAMLポリシー、マイクロ秒レイテンシー、ゼロ外部依存関係。
  • SCIM - クロスドメインのアイデンティティ管理のためのシステム。
  • Vault - トークン、パスワード、証明書、API キー、および現代のコンピューティングの他の秘密へのアクセスを堅固に管理します。
  • Avro - 密集した、速く、バイナリ データ フォーマットで豊富なデータ構造を提供するApacheのデータ シリアライズ システム。
  • Bond - 大規模サービスのマイクロソフトで広く利用された回路図データを扱うためのクロスプラットフォームフレームワーク。
  • BooPickle - 効率的なネットワーク通信のためのバイナリシリアライズライブラリ。 Scala と Scala.js の
  • Cap’n Proto - 非常に速いデータ交換のフォーマットおよび機能ベースのRPCシステム。
  • CBOR - 多くの言語でCBOR標準(RFC 7049)の実装。
  • Cereal - シリアル化のためのC++11ライブラリ。
  • Cheshire - Clojure JSON と JSON SMILE のエンコーディング/デコード。
  • Etch - ネットワークサービスの構築と消費のためのクロスプラットフォーム、言語および輸送独立したフレームワーク。
  • Fastjson - 速いJSONプロセッサ。
  • Ffjson - より速いJSONのシリアライズのためのGo。
  • FST - 速いJavaのシリアライズの低下の取り替え。
  • Jackson - JSONデータフォーマットを処理するための多目的Javaライブラリ。
  • Jackson Afterburner - バイトコード生成を使用するジャクソンモジュールは、データ結合(シリアル化、デシリアライゼーションのための+30-40%スループット)を高速化します。
  • Kryo - Javaのシリアライズとクローニング:高速、効率的、自動。
  • Lite³ - JSON 互換のゼロコピーのシリアライズのフォーマット。
  • MessagePack - 効率的なバイナリシリアライズフォーマット。
  • Protostuff - 前方互換性(schema evolution)と検証のための組み込みサポートを備えたシリアライズライブラリ。
  • SBinary - Scala タイプのバイナリフォーマットを記述するためのライブラリ。
  • Thrift - 拡張可能なクロス言語サービス開発のためのApache Thriftソフトウェアフレームワーク。
  • yyjson - Cで最も速いJSONライブラリ。
  • Apache Cassandra - コラム指向、失敗の単一のポイントと高い可用性を提供する。
  • Aerospike (c) - スケールで速度を提供する高性能のNoSQLデータベース。
  • ArangoDB - 文書、グラフ、およびキー値の柔軟なデータモデルを備えた分散型フリーかつオープンソースデータベース。
  • Citus - PostgreSQLを拡張子に分散させる。
  • CockroachDB (c) - Google Spannerの後にモデル化されたクラウドネイティブSQLデータベース。
  • Couchbase - パフォーマンス、スケーラビリティ、および単純化された管理のために設計された分散されたデータベース。
  • Crate (c) - NoSQL に Scalable SQL データベースを格納します。
  • Druid - 速いコラム指向の分散データ店。
  • Elasticsearch - オープンソースの配布、スケーラブル、および利用可能な検索サーバー。
  • Geode - スケールアウトアプリケーション用のオープンソース、分散、メモリ内データベース。
  • Infinispan - キャッシュに使用される高同時キー/値のデータストア。
  • InfluxDB - メトリック、イベント、リアルタイム分析のためのスケーラブルなデータストア。
  • RethinkDB - オープンソース、リアルタイムアプリの構築を容易にするスケーラブルなデータベース。
  • TiKV - トランザクションキー値データベースの配布
  • TimescaleDB - Postgres拡張としてパッケージ化された高性能リアルタイム分析のための時間系列データベース。
  • Trino - データユニバースを探索するのに役立つビッグデータ分析用の高速分散SQLクエリエンジン。
  • Goreplay - ライブHTTPトラフィックをテスト環境にキャプチャして再生するためのツール。
  • Keploy - 実際のトラフィックをキャプチャし、それをテストケースやスタブに変換することにより、APIのテストとモックのためのオープンソースツールは、信頼性の高いマイクロサービスのテストを可能にします。
  • Mitmproxy - トラフィックフローが傍受、検査、修正、再生されるようにするインタラクティブなコンソールプログラム。
  • MockServer - 複数のプロトコル(HTTP、gRPC、GraphQL、LLM、MCP、Kafka、TCPなど)のプロキシとチャオスエンジニアリングのモック、デバッギング、デバッギング、およびマルチプロトコル(HTTP、gRPC、GraphQL、LLM、MCP、Kafka、TCPなど)。 mock依存関係、レコード/リプレイトラフィック、リクエストの確認、統合およびレジリエンステストの障害の注入。
  • Mountebank - 十字プラットホーム、ワイヤー上の複数のプロトコル テスト倍。
  • Pact - HTTP APIと非HTTP非同期メッセージングシステム用の受託テストフレームワーク。
  • RestQA - クラス開発者の経験で最高のローカルでmicroservicesのモック、単位および性能のテストを管理するためのツール。
  • Specmatic - APIの仕様(OpenAPI、AsyncAPI、GraphQL、gRPCなど)を自動テスト、サービス仮想化、および書き込みコードなしで後方互換性検証のための実行可能契約に変換します。
  • VCR - テストスイートのHTTPインタラクションを録画し、将来のテストが速く、決定的、正確なテストを実行したときに再生します。 他の言語での実装のためのポートのリストを参照してください。
  • Wilma - HTTP/HTTPSサービススタブと透明プロキシソリューションを組み合わせました。
  • WireMock - ウェブサービスのスタブとモックのための柔軟なライブラリ。 実際の HTTP サーバを作成することで動作する一般的な目的のモックツールとは異なり、テスト中のコードは実際の Web サービスとして接続できます。
  • Hoverfly - 開発者およびテスターのための軽量サービス仮想化/APIのシミュレーション用具。
  • Awesome CI/CD DevOps :star: - 継続的な統合、継続的な配信およびDevOpsのための素晴らしいツールのキュレーションリスト。

Web API モデリングとドキュメント

Section titled “Web API モデリングとドキュメント”
  • AsyncAPI - AsyncAPI仕様、非同期APIを定義するための業界標準。
  • GraphQL - データ要件と相互作用を記述するための直感的で柔軟な構文とシステムを提供することで、クライアントアプリケーションを構築するために設計されたクエリ言語。
  • JSON:API - クライアントの要求が、リソースが取得または変更されるべきかどうか、およびサーバーがそれらの要求にどのように反応すべきかの仕様。
  • API Blueprint - API ライフサイクル全体のためのツール 他の人とAPIを議論するために使用します。 ドキュメントを自動的に生成します。 またはテスト スイート。 または、いくつかのコード。
  • OpenAPI - OpenAPI 仕様(OAS)は、API ライフサイクルの各段階で情報を運ぶための一貫した手段を提供します。
  • RAML - RESTful API モデリング言語、実用的にRESTful API を記述するシンプルで簡単な方法。
  • ReDoc - OpenAPI/Swagger-generated API ドキュメント。
  • Scalar - オープンソース API プラットフォーム: 美しい API リファレンスと 1 クラスの OpenAPI/Swagger サポート。
  • Slate - API の静的ドキュメントを美しくします。
  • Spring REST Docs - Spring MVC Testで生成された自動生成スニペットと手書き文書を組み合わせて、ドキュメントRESTfulサービス。
  • Swagger - RESTful API のシンプルでパワフルな表現。
  • W3C.REC-Webarch - 世界ワイドウェブ、ボリュームワンのアーキテクチャ。
  • RFC3986 - 均一リソース識別子(URI):ジェネリックシンタックス。
  • RFC6570 - URIテンプレート。
  • RFC7320 - URIの設計と所有権。

セルフ・スペシャリゼーションと分散

Section titled “セルフ・スペシャリゼーションと分散”
  • DID - 分散型識別子(DID)のW3C仕様:検証可能な分散型デジタルアイデンティティを可能にする新しいタイプの識別子。
  • DIDComm - プライベートなコミュニケーション方法論は、DIDの分散型設計を上回りました。
  • DIDComm Protocols - DIDComm 上に構築されたプロトコルのレジストリは、あらゆる輸送上の高信頼、自主的な相互作用のために。
  • IDSA - 国際データスペース協会(IDSA)は、国際データスペース(IDS)と、すべての参加者がデータの完全な価値を実現することができるデータの共有の安全な、 sovereign システムで、グローバル、デジタル経済の未来を作成するミッションです。
  • RFC7230 - メッセージの同期とルーティング。
  • RFC7231 - Semanticsとコンテンツ。
  • RFC7232 - 条件付き要求。
  • RFC7233 - 範囲の要求。
  • RFC7234 - キャッシュ。
  • RFC7235 - 認証
  • RFC7807 - HTTP API の問題の詳細。
  • RFC7540 - ハイパーテキスト転送プロトコルバージョン2.
  • QUIC-WG - IETFワーキンググループは、インターネットの次の輸送プロトコルを届けるためにチャーターされています。
  • QUIC-Transport - UDPベースのマルチプレックスおよび安全な輸送。
  • JSON-RPC 2.0 - 無状態、軽量のリモート・プロシージャ呼出し(RPC)の議定書。
  • Open RPC - OpenRPC仕様は、JSON-RPC 2.0 API の標準的なプログラミング言語アグノスティックインターフェースの説明を定義しています。
  • AMQP - 高度なメッセージキューイングプロトコル。
  • MQTT - MQテレメトリー輸送。
  • STOMP - 簡単なテキスト指向のメッセージングプロトコル。
  • GNAP - 助成金交渉と承認プロトコルは、ソフトウェアの部分に承認を委任するためのメカニズムを定義し、その委任をソフトウェアに伝えます。 このデリゲーションには、APIのセットへのアクセスや、ソフトウェアに直接渡された情報が含まれます。ドラフト
  • OIDCONN - OpenID Connect 1.0 は、OAuth 2.0 プロトコルの上部にあるシンプルなアイデンティティレイヤーです。 クライアントは、Authorization Server が実行する認証に基づいてエンドユーザーの ID を検証し、相互運用可能な REST のような方法でエンドユーザーに関する基本的なプロファイル情報を取得することを可能にします。
  • PASETO - Paseto は、JOSE (JWT、JWE、JWS) について、JOSE 規格を盗む多くの設計上の欠陥なしに愛するすべてです。 ドラフト
  • RFC5246 - トランスポート層セキュリティ(TLS)プロトコルバージョン1.2。
  • RFC6066 - TLSエクステンション。
  • RFC6347 - データグラムの輸送の層の保証版1.2。
  • RFC6749 - OAuth 2.0 認可フレームワーク。
  • RFC6962 - 証明書の透明性。
  • RFC7515 - JSON Web Signature (JWS) は、JSON ベースのデータ構造を使用して、デジタル署名またはメッセージ認証コード(MAC)で保護されたコンテンツを表しています。
  • RFC7519 - JSON Web トークン (JWT) は、2 つのパーティ間で送金されるクレームを表す、コンパクトで URL 安全な手段です。
  • RFC7642 - SCIM:定義、概要、概念および条件。
  • RFC7643 - SCIM:Core Schemaは、ユーザーとグループを表すプラットフォームニュートラルスキーマと拡張モデルを提供します。
  • RFC7644 - SCIM:Web上でIDデータをプロビジョニングおよび管理するためのアプリケーションレベルのプロトコル。
  • DNS-SD - クライアントがサービスの名前付きインスタンスのリストを発見するためのメカニズム、標準のDNSクエリを使用して。
  • RFC2782 - サービスの場所(DNS SRV)を指定するDNS RR。
  • RFC4627 - JavaScript オブジェクト表記 (JSON)
  • RFC7049 - バイナリオブジェクト表現(CBOR)の簡潔化。
  • BSON - バイナリJSON(BSON)。
  • JSON-LD - データをリンクするためのJSON。
  • SBE - シンプルなバイナリエンコーディング(SBE)。
  • MSGPACK - MessagePackの指定。
  • JSON Schema - JSON 文書をアノテートおよび検証できる語彙。
  • Schema.org - 共同で、インターネット上の構造化されたデータをスキーマを作成、維持し、促進する使命を持つコミュニティ活動、Webページ、電子メールメッセージ、およびそれを超えて。
  • UNIV8 - ユニコードコンソーシアム Unicode標準、バージョン 8.0.0、(Mountain View、CA:Unicodeコンソーシアム、2015。 ISBN 978-1-936213-10-8)。
  • RFC3629 - ISO 10646の変換フォーマットであるUTF-8。

組織設計・チームダイナミクス

Section titled “組織設計・チームダイナミクス”
  • How Do Committees Invent? :small_orange_diamond:サイトマップ - Melvin E. Conway、データメーション雑誌 1968。 「Conway’s Law」のオリジナル記事
  • Service per Team - 各チームは1つ以上のビジネス機能(ビジネス機能など)を担当しています。 1つ以上のモジュールで構成されるコードベースを所有しています。 そのコードベースは、チームの認知能力を上回らないため大きさで分類されます。 チームは、コードを1つ以上のサービスとしてデプロイします。 複数のサービスを持っていることが証明された必要性がなければ、チームが正確に1つのサービスを持っている必要があります。
  • Start with Team Cognitive Load - Team Topologies :small_red_triangle:お問い合わせ - DOES19 ロンドン 「モノリス対マイクロサービス」議論は、多くの場合、技術的な側面に焦点を当て、戦略とチームのダイナミクスを無視します。 技術の代わりに、スマート思考組織は、現代のソフトウェアのための指導原則として、チーム認知負荷から始まります。 本講演では、実際のケーススタディで説明した方法と理由について説明しています。
  • Commercetools - ヘッドレスコマースプラットフォーム。
  • Equinox - Infosys Equinoxは、あらゆるチャネルとタッチポイントで豊かでハイパーパーソナライズされたエクスペリエンスをサポートする、人間中心のコマースおよびマーケティングプラットフォームです。
  • Flamingo - 柔軟でモダンなeコマースアプリケーションを構築するフレームワーク。
  • Medusa - ヘッドレスオープンソースコマースプラットフォーム。
  • Autonomy, Hyperconnectivity, and Residual Causality - 複雑性科学理論による適応型ハイパーリムジンシステムの設計への哲学的な導入。
  • Awesome Scalability :star: - 拡張性、信頼性、および実行能力の大規模システムのパターンを照らすための更新および整理された読書リスト。 コンセプトは、著名なエンジニアや信頼できるリファレンスの記事で説明しています。 数千億~数億人のユーザーが抱える戦闘テスト済みシステムから導入された事例です。
  • AKF Scale Cube - 寸法を図ってサービスをスケールアップするモデル。
  • CALM :small_orange_diamond:サイトマップ - 論理的な単調性としての一貫性。
  • Canary Release - インフラストラクチャ全体に展開し、誰もが利用できるようにするために、ユーザーの小さなサブセットへの変更をゆっくりとロールアウトすることにより、生産中の新しいソフトウェアバージョンを導入するリスクを減らす技術。
  • CAP Theorem - 配布されたコンピュータシステムが、一貫性、可用性、およびパーティションの許容範囲の3つを同時に提供することができない状態。
  • Formal Foundations of Serverless Computing :small_orange_diamond:サイトマップ - サーバレス・コンピューティングの抽象化は、プログラマが自分のコードについて書き、理由を難しくなるいくつかの低レベルの運用詳細を公開しています。 この論文は、サーバーレスコンピューティングの本質の運用管理である λ を提示することで、この問題に光を当てます。
  • Microservice Architecture - 独自に展開するサービスのスイートとしてソフトウェアアプリケーションの設計の特定の方法。
  • Microservices - From Design to Deployment :small_orange_diamond:サイトマップ - マイクロサービスのF5の7部分シリーズ。
  • Microservices – Please, don’t - マイクロサービスのアプローチに関するいくつかの問題に関する重要なアドバイス。
  • Microservices Trade-Offs - ミラーコサービス建築様式のポンダーの費用そして利点へのガイド。
  • Reactive Manifesto - 反応システム定義。
  • Reactive Streams - 非ブロッキングバック圧力で非同期ストリーム処理のための標準を提供する取り組み。
  • ROCAS :small_orange_diamond:サイトマップ - 適応システムのためのリソース指向コンピューティング。
  • SECO :small_orange_diamond:サイトマップ - ソフトウェアエコシステムを理解する:戦略的モデリングアプローチ。
  • Testing Strategies in a Microservice Architecture - 複数の独立した配置可能なコンポーネントの追加テストの複雑性を管理するためのアプローチ。
  • Your Server as a Function :small_orange_diamond:サイトマップ - 安全な、モジュラー、および効率的なサーバーソフトウェアを構築する強力なプログラミングモデルを提示するために結合する3つの抽象を記述します: 妥協可能な未来、サービスおよびフィルター。
  • Cloud Native Computing Foundation - クラウドネイティブコンピューティング財団は、持続可能なエコシステムを構築し、マイクロサービスアーキテクチャの一環としてコンテナをオーケストする高品質のプロジェクトを構成するコミュニティを育成します。
  • CNCF Cloud Native Interactive Landscape - クラウドネイティブ技術のインタラクティブな風景。
  • Microservices Resource Guide - マーティン・フローラーはmicroservicesの建築様式についての詳細を教えることができる記事、ビデオ、本およびポッドキャストの選択を好みます。
  • Microservice Patterns - マイクロサービスアーキテクチャパターンとベストプラクティス。
  • Microservice Antipatterns and Pitfalls - マイクロサービスはほとんど知られていた反パターンおよび下落。

CC0

お問い合わせ Contribution Guidelines 提案を提出する前に。

お問い合わせ open an issue または create a pull request あなたの追加で。

:star2: お問い合わせ

HagiCode

HagiCode はエージェント型コーディングワークスペースです。豊富で便利な UI インタラクションにより、計画・エージェント実行・プロジェクト作業を始めやすく、進めやすくし、開発をより魅力的な体験にします。

豊富で便利な UI インタラクションで、計画からプロジェクト作業までを分かりやすく進められます。

HagiCode を見るドキュメントを読む
  • スマートOpenSpec ワークフローが意図を、提案・設計・タスクから変更のリリースまで実行可能な道筋にします。
  • 効率的マルチエージェント実行で調査・実装・レビューを並行して進め、複数リポジトリや使い慣れた Agent CLI にも対応します。
  • 興味深い豊富で便利な UI インタラクションにより、計画・エージェント実行・プロジェクト作業を始めやすく、進めやすくします。

Windows 版をダウンロード

Microsoft Store で入手すべてのダウンロード

アイデアを、出荷できるソフトウェアへ。

HagiCode はエージェント型コーディングワークスペースです。OpenSpec ワークフローで変更を計画し、マルチエージェント実行で進め、Hero Scenario で長い作業の進み具合を見える化して、アイデアを出荷できるソフトウェアにします。

スマート
OpenSpec ワークフローが、意図を提案からリリースまでの実行可能な道筋にします。
効率的
マルチエージェント実行で、調査・実装・レビューを並行して進めます。
楽しい
使いやすい UI で、計画・Agent 実行・プロジェクト作業を進めやすくします。

Awesome Site を離れますか?

外部のウェブサイトに移動しようとしています。そのサイトのコンテンツやプライバシーの取り扱いは管理していません。

移動先

ウェブサイトに進む