Skip to content

Select language

目前語言: 繁體中文

Microservices

Source: https://github.com/mfornos/awesome-microservices at 417c83dc4de7
License: CC0-1.0
Read the English original

This edition is an AI-assisted translation.

Micro service Architecture 相關原則與技術,

表格

  • 1Backend - 人工智能微服務平台
  • Jolie - 開源微服務导向的程式語言。
  • OpenWhisk - 無伺服器的開源雲平台, 以應付任何规模的事件。
  • Pulumi - 云原生基建的SDK是代碼 使用您最愛的語言來預覽和管理您的應用程式和基础设施的更新, 並繼續部署到任何雲( 不需要YAML) 。
  • Triton 開源雲管理平台 提供下一代 以容器為基礎 以服務為主的基础设施 跨越一個或更多的數據中心
  • Akka 在JVM上建立高度同步、分布式和回應性訊息的應用程式。
  • Axon (c) - 一個端到端的發展與基建平台,
  • Ballerina - 云土程式語言
  • Bun - 快速全在JavaScript运行時間。
  • Dapr - 使用任何程式語言寫作高性能微服務的開放源程 。
  • Deno - JavaScript, TypeScript, 和WebAssembly 的运行時間, 都有安全的預設, 而且有很好的開發經驗 。
  • Eclipse Microprofile 透過多項實施的創新, 在共同關注的領域上合作,
  • Erlang/OTP - 編程語言,用于建立大量可伸縮的軟體实时系統,要求高可用性。
  • Finagle - JVM的廣泛RPC系統 用于建構高通量伺服器
  • Gleam - 一种友好的語言,用于建立安全型,可伸展的系統。
  • GraalVM - 高性能的跑步時間,能大大提高應用性能和效率,這是微服務的理想。
  • Helidon - Java 圖書館的收藏 寫作微信服務,
  • Ice - 支持C++、C#、Java、JavaScript、Python等的全面RPC框架。
  • Light-4j - 高吞吐量,低耐用度,小的記憶腳印 以及更有成效的微服務平台。
  • Micronaut - 以JVM為基礎的現代全裝框架,
  • Moleculer - 節點、Java、Go和Ruby的快速和強大的微服務框架。
  • Open Liberty - 建立快速高效云母Java微服務的輕量级開放框架。
  • Pears - 相對跑步、發展和部署
  • SmallRye 包括Eclipse MicroProfile。
  • Spin 用WebAssembly建設與運作的開源框架,
  • ScaleCube - 为JVM建立反應性微服務工具箱:低纬度、高通量、可伸展性和弹性。
  • Vert.X - 在JVM上建立反應應用工具箱。
  • Vert.X Toolbox - 一套Vert.x元件來建立反應性微服務應用程式。
  • Wangle 提供一套共同的客戶端/伺服器抽象,
  • GRPC - 高性能,開源,一般的RPC框架,把手機和HTTP/2放在首位。 C、C++、Java、Go、Node.js、Python、Ruby、Object-C、PHP和C#的圖書館。
  • Lwan - 高性能和可伸縮的網路伺服器。
  • uSockets - 小型跨平台事件, 建立網路與加密,
  • Cap’n Proto RPC - Capn Proto C++ RPC 實施。
  • C++ Micro Services - OSGi 類型 C++ 动态模組系統與服務登記 。
  • Enduro/X - GNU/Linux 基于 XATMI 的服務框架。
  • Pistache - 用C++寫作的高性能 REST工具箱。
  • Poco - C++ 建置基于網路的應用程式和伺服器的類型文庫。
  • Sogou Workflow - 企業級編程引擎 旨在满足大部分後端發展要求
  • uWebSockets - 簡易、安全、符合標準的網路伺服器,
  • Phoenix - 构建 HTML5 應用程式、 API 后端和分布式系統的框架 。
  • Plug - 網絡應用程式之間可混凝土模組的规格和方便性。
  • Cowboy 用 Erlang 寫成的小型、快速、模块化的 HTTP 伺服器。
  • Mochiweb - Erlang 圖書館,用于建立輕量级的 HTTP 伺服器。
  • Chi 建立Go HTTP服務的輕量级、平庸和可混凝土路由器。
  • Echo - Go 的快速且不靈敏的 HTTP 伺服器框架。 最高比其它的快 10x 。
  • Fiber Express 啟發的網絡框架建在 Fasthttp 之上, 是 Go 最快的 HTTP 引擎。 其設計旨在減輕快速發展的問題, 預計到零內存分配和性能 。
  • Gin - Gin 是用 Go (Golang) 寫成的 HTTP 網頁框架 。 它的特徵是馬提尼式的API 性能要好得多 速度要快40倍
  • Goa - Go的HTTP微服務
  • GoFr 有觀點的微服務發展框架, 旨在简化微服務的發展.
  • Go Chassis - Go的微型服務快速發展框架,
  • Go-micro - 分布式系统开发框架。
  • Go-zero - 网络和 rpc 分布式系統發展框架。
  • Gorilla - Go程式語言的Web工具箱。
  • Iris - Go的快速、簡單和高效的微網路框架。
  • Lura - 搭建超性能 API Gateways的框架 中間軟件。
  • RPCX Alibaba Dubbo和微博Motan等,
  • Scotty 使用WAI和Warp。
  • Servant - 類型的網路 DSL。
  • Yesod -哈斯克爾的網路框架
  • Compojure - Ring/Clojure的簡便路線圖書館。
  • Duct Clojure的伺服器邊框
  • System - 建在斯圖爾特·塞拉的元件圖書館上面 提供一套現成的元件
  • Tesla Otto.de的一些Clojure微服務的通用基礎
  • ActiveJ - 輕量级和快速的函式庫, 用于複雜的高负荷分配應用程式和類似Memcached的溶液。
  • Airlift - 在Java建立REST服務框架。
  • Armeria - 開源 HTTP/2 RPC/REST 用戶端/伺服器文庫,建在 Java 8, Netty, Thrift 和 gRPC 上面 。
  • Disruptor - 高性能的間接信箱
  • Dropwizard - Java框架 發展Ops友好,高性能,RESTful的網絡服務。
  • Dubbo - 一個高性能的、基于Java的RPC框架,由阿里巴巴開源。
  • Conjure Dropwizard/Jersey與JAX-RS服務定義為伺服器。
  • Jersey JAX -RS的參考服務
  • Quarkus - A Kubernetes OpenJDK HotSpot和GraalVM的原生Java堆栈,
  • Ratpack - 一套 Java 文庫, 方便快速、 高效、 可轉動和經驗良好的 HTTP 應用程式。 提供格魯維語的具体支持。
  • Spring Boot - 很容易建立獨立的 產品級的 Spring 應用程式
  • Http4k - 輕而易舉但完全適合的 HTTP 工具箱,用純的 Kotlin 寫成, 使 HTTP 服務的服務和消耗以功能和一致的方式。
  • Ktor - 使用 Kotlin 編程語言建立連接系統同步伺服器和客戶端的框架。
  • Finatra Scala HTTP服務建在Twitter-Server和Finagle上。
  • Http4s - HTTP 的最小、平凡的 Scala 介面
  • Play - Java和Scala的高速網路框架。
  • Actionhero - 多運輸節點Js API伺服器,具有集成群組能力和延遲工作.
  • Express - 快速、無意識、最小化的Node.js網頁框架
  • Fastify - 快速和低水平的網頁框架,供Node.js使用。
  • FeathersJS - 用于現代應用程式的開源 REST 與实时 API 層。
  • Hono - 邊緣小、簡單、超快的網絡框架 它在任何 JavaScript 執行時效應 。
  • Koa - Node.js 的下一代網路框架
  • Loopback - 建立 API 的節點. js 框架, 很容易連接到後端資料來源 。
  • NestJS - 建設高效且可縮放的伺服器端應用程式的節點(Node.js)框架,
  • Seneca - 用于Node.js的微服務工具箱
  • Serverless - 在AWS Lambda和API Gateway(前稱JAWS)上建立和维护網路、手機和IOT應用程式。
  • tRPC - 端到端型安全API。
  • Cro - 使用 Perl 6 建立反應分配系統的圖書館
  • Mojolicious - Perl的下一代網絡框架。
  • API Platform - API第一網絡框架,
  • Ecotone 以 DDD 、 CQRS 和 Event Surcing 的建築原理为基础的框架,
  • Hyperf - Hyperf是一個極具性能且灵活的PHP CLI框架,以Swoole 4.5+为基础,由最先进的coroutine伺服器和大量的戰鬥測試元件提供动力.
  • Lumen - 超快的微架子
  • Slim 幫助你快速寫入簡單而強大的網路應用程式和API的微架构。
  • Spiral - 使用 RoadRunner它提供先进的特征,如与 Temporal 工作流程引擎及 Centrifugo Websocket 伺服器 。 它對微服務架构尤其有效,
  • Swoft 建立高性能網路系統的PHP微服務框架、API、中件和基本服務。
  • Symfony - 基于Symfony元件的微型框架。
  • Aiohttp - HTTP 用戶端/伺服器的Ayncio。
  • Bottle - Python的快速、簡單和輕巧的WSGI微網框。
  • Connexion - Swagger/ OpenAPI 弗拉斯克上方的 Python 框架, 有自動端點驗證和 OAuth2 支援 。
  • Falcon - 建立非常快的app后端和微服務的 裸金屬 Python 網頁 API 框架
  • FastAPI - 現代、快速( 高性能) 、 基于標準的 Python 型態提示建立 API 的網頁框架 。
  • Flask - 基于Werkzeug和Jinja 2的 Python 微服務框架
  • Nameko -建微服務的Python框架。
  • Sanic - Sanic是弗拉斯克式的Python 3.5+網頁伺服器,寫的快
  • Tornado - 網絡框架和同步網路文庫。
  • Twisted - 事件驱动的網路程式引擎。
  • Web.py - Python的最小網路框架。
  • Grape - 建立 REST 類似 API 的觀點框架
  • Hanami -魯比的現代網絡框架
  • Praxis - 设计和实施API的框架。
  • Scorched 露比的輕量級網絡框架
  • Sinatra Sinatra是一款DSL,
  • Are we web yet? :star: - Rust的網絡編程狀態概述。
  • Actix 強大、务实、快速的Rust網絡框架。
  • Tarpc - RPC Rust框架,侧重于易用性。
  • Tokio - 寫作網路應用程式的同步运行時間。
  • Tower - 建立牢固的網路客戶端和伺服器的模块化和可重用元件库。
  • Wtx - HTTP/2 客戶端/伺服器框架。
  • Ambassador (c) - – Kubernetes- 以特使為基礎的微型服務的內生API网關
  • Apache APISIX - 高性能、实时API网关和AI网关建在NGINX等上,有熱重載路由和100+插件。
  • APIcast - APIcast是建在NGINX上面的API网关. 它是紅帽3級API管理平台的一部分.
  • Bunker Web - 網絡應用程式主機和逆向代理安全
  • Caddy - 廣泛的 HTTP/2 網路伺服器,有自動的 HTTPS 。
  • Camel - 授权您用不同網域特有語言來定義路由與介面規則, 包括一個基于 Java 的流動 API, Spring 或 Bluint XML 設定檔, 以及 Scala DSL 。
  • Envoy -開源邊緣和服务代理商 來自Lyft的開源邊緣
  • HAProxy - 可靠、高性能的TCP/HTTP负荷平衡器。
  • Istio - 一個開放的平台 連接,管理,以及安全的微服務。
  • Keepalived Linux 系統和 Linux 基礎基礎建設的裝載平衡和高可用性。
  • Kong - API的開源管理層。
  • KrakenD - 開源超強性能 API Gateway.
  • Kuma - 平台不可知的開源控制平面 服務網格和微服務。
  • Linkerd 云母應用程式的耐力服務網格
  • Neutrino - 廣泛的軟體負載平衡器
  • OpenResty - 在Nginx上建的快速網路應用伺服器。
  • Open Service Mesh - 輕量级和可延伸的云母服務网
  • Otoroshi - 現代HTTP反轉代理 配有輕量级API管理.
  • Pingora - 建立快速、可靠和可動的網路服務的圖書館。
  • Skipper - HTTP 路由器 有用於把路由與服務邏輯分離
  • Spring Cloud Gateway - API Gateway 在春季MVC的上面。 目的是提供通向API的簡單而有效的方式.
  • Tengine - 配送Nginx 有一些先进的功能。
  • Træfɪk - 現代的HTTP反轉代碼和負载平衡器 以輕易地部署微服務。
  • Traffic Server - 云服務的高性能构件
  • Tyk - 開源、快速可伸展的API网关、门户网站和API管理平台。
  • Vulcand - 由 Etcd 支持的程序載重平衡器
  • Zuul 提供动态路線、監控、耐力、安全等等的邊緣服務。
  • Central Dogma - 基于 Git, Zookeeper 和 HTTP/2 的開源高版本控制服務設定主目錄。
  • Consul - 服務的發現和設型就容易了 分布, 高度可用, 和數據中心 - 知識。
  • Etcd - 供共享配置和服务發現的金鑰價值商店。
  • Eureka - 基于 REST 的服務,主要在 AWS 雲中用于定位服務,以平衡中端伺服器的載入和失效。
  • Microconfig - 現代和簡單的微服務配置管理方式。
  • Nacos ——易用动态服務發現,配置和服务管理平台.
  • SkyDNS - 分布式服務, 它利用 DNS 查詢來發現可用的服務 。
  • Spring Cloud Config - 提供伺服器和客戶端對分布式系統外化設定的支持。
  • ZooKeeper - 開源伺服器,可以高度可靠的分布式协调。
  • AWS Step Functions (c) - 利用視覺工作流程协调分布式應用程式和微服務的元件。
  • Cadence - 錯誤 - 不可思議的代碼平台
  • Conductor - 微型服務管弦機
  • Inngest - 可靠背景邏輯的持久函數, 從背景工作到複雜的工作流程。
  • Kestra 開放源碼微服務由事件導引 語言不可知的管弦和排程平台。
  • Temporal -開源微服務 管弦樂平台 以執行任何大小的任務關鍵碼
  • Zeebe - 界定、安排和監控微型服務的經營流程。
  • Hazelcast - 開源內存資料網 允許您在伺服器、群組與地圖中分配數據與計算, 並管理大數據集或高數據摄入率。 成熟科技.
  • Helix - 通用群組管理框架,用于自動管理集團節點所主控的分割、复制和分配的資源。
  • Ignite - 高性能、集成和分布式的內存平台,
  • Libp2p - 建立對等網路應用程式的框架和套件。
  • Mesos - 抽象 CPU 、 內存、 儲存、 以及從機器( 物理或虛擬) 中移動其他計算資源,
  • Nomad - 分布, 高度可用, 數據中心 - 知識排程器。
  • Redisson - 在 Redis 伺服器上方分布和可縮放的 Java 資料結構 。
  • Serf - 集團成員、故障偵測和編號的分散解决方案。
  • Valkey 重新開源的Redis計畫。
  • Zenoh - Pub/sub/query 協議將數據整合在動中,數據在休息和計算中。 高效地將傳統的酒吧/潛艇與地理分布式儲存、查詢和計算相融合。
  • Celery - 以分发信件傳送為基礎的同步工作排隊/工作排队 。 注重实时操作,支持排程.
  • Dkron - 分配,錯誤容忍的工作排程系統。
  • Faktory -語言不可知的持續背景工作伺服器。
  • Rundeck (c) - 工作排程和跑本自動。 開啟對已有文稿和工具的自我服務存取 。
  • Schedulix - 開源企業工作表系統 规定了在先进系統环境中 IT 流程專業自动化的突破性標準
  • mirrord - 執行本地代碼 仿佛是遙控器的艙 Kubernetes 群組。
  • Fluentd - 用于統一伐木層的開源數據收集器。
  • Graylog - 完全一体化的開源日志管理平台。
  • Kibana - 灵活的分析與視覺化平台
  • LogDNA (c) - 集中的日志管理軟體。 即時收集、集中和分析任何平台的日志,
  • Logstash - 管理事件和日志的工具。
  • Loki - 像普羅米修斯,但為了木頭。
  • ØMQ -無经纪智能交通層
  • ActiveMQ - 強大的開源訊息和整合模式伺服器。
  • Aeron - 高效可靠的 UDP unicast, UDP 多播, 以及 IPC 訊息傳送 。
  • Beanstalk - 簡單,快速的工作排隊。
  • Bull - 快速可靠的 Redis 節點排隊 。
  • Crossbar - 分布式和微服務的開源網路平台。 它執行開啟的Web應用程式訊息协议(WAMP).
  • Kafka - 發佈訂閱訊息,
  • Malamute -ZeroMQ公司訊息經紀人
  • Mosquitto - 執行 MQTT 協議的開源訊息代理商 。
  • NATS 開源,高性能,輕量级云訊系統
  • NSQ - 实时的發布訊息平台
  • Pulsar - 分散的酒吧子訊息系統
  • RabbitMQ - 開放源 Erlang 的訊息經紀人,只是工作。
  • Redpanda - 流動數據平台供開發者使用: Kafka API 兼容, 10x 速度更快, 沒有 Zookeeper 和 JVM 。
  • RocketMQ - 低空、可靠、可伸展、易用 ALibaba 大型訊息業生產的、面向訊息的中間器件。
  • Beats - Elasticsearch & Logstash 的輕量级運輸商。
  • Elastalert - Elasticsearch 的易用和灵活的警示 。
  • Ganglia - 高性能計算系統的可伸展分布式監控系統,如群組和网格。
  • Grafana - 一個開放的來源,
  • Graphite -可伸縮的实时圖片
  • IOpipe (c) - Amazon Lambda的應用性能監控
  • Jaeger - 開放源碼,端到端的分布式追蹤
  • OpenTelemetry - 高质量、無所不在和便携式的遥测,以便有效可觀性。
  • Prometheus -開源服務監控系統和時序數據庫
  • Riemann - 監控發布系統
  • Sensu - 監控今天的基建
  • SkyWalking - 分布式系統的應用性能監控工具,尤其是為微服務、云母和容器而設計的(Docker, K8s梅索斯的建筑
  • Zabbix 開源企業級監控方案
  • Zipkin 分布式追蹤系統
  • Arroyo - 分佈流處理引擎,以轉換,過滤,聚合,并通过寫入 SQL 加入數據流。
  • Reactor.io - 第二代反應函數庫,
  • Reactive Kafka - Apache Kafka的反應流 API
  • ReactiveX - API 用于與可觀察流同步編程 。 可用于平庸的Java, Scala, C#, C++, Clojure, JavaScript, Python, Groovy, JRuby等.
  • RSocket - 應用程式提供反應流語言。
  • Awesome Chaos Engineering :star: - 一個很棒的混亂工程資源列表
  • Raft Consensus - 协商一致算法是設計成易懂的 這和帕克索斯的錯誤容忍和表演是一樣的
  • Resilience4j - 為Java8和功能程式設計的錯誤容力圖書館。
  • Svix - Webhooks 服務, 將webhooks發送給您的使用者, 包含完整的重試排程, 成倍反轉, 簽署檢查, 以及事件類型 。
  • Cerbos Hub - 授權管理系統,用于寫作、測試和部署存取政策。 在微服務架构中建立可伸展的,精美的授權.
  • Dex - 有可插入連接器的見證/指令服務。 OpenID 連接提供者和第三方 OAuth 2.0 代表团 。
  • JWT JSON Web Tokens是一種開放的,工業標準的RFC 7519方法,在兩方之間安全地代表索赔.
  • Keycloak - 全面且可延伸的认证服務。 OpenID 連接提供者和第三方 OAuth 2.0 代表团 。
  • OAuth 提供網路應用程式、桌面應用程式、手機及客廳設備的具体授權流。 多次实施。
  • OpenID Connect - 圖書館、產品和工具,
  • Open Ziti - 零信任安全 和覆蓋網絡 作为純開源軟體。
  • ORY - 開源身份基建和服務。
  • OWASP Agent Memory Guard ——AI代理記憶體中毒的runtime防禦層(OWASP ASI06). 偵測器篡改了記憶體的項目 迅速注入記憶體的路徑 以及秘密的漏水 YAML 政策, 微秒空間, 無外部依賴性 。
  • SCIM - 跨域身份管理系统。
  • Vault - 安全 商店 嚴格控制 信使 密碼 憑證 API 鑰匙
  • Avro - Apache 資料序列化系統, 以緊密、 快速、 二進制的資料格式提供丰富的資料結構 。
  • Bond - 跨平台框架,
  • BooPickle - 二進制序列化文库,以高效的網路通信。 斯卡拉和斯卡拉
  • Cap’n Proto - 异常快速的數據交換格式和基于能力的RPC系統。
  • CBOR - 多种語言的CBOR標準(RFC 7049)的實施。
  • Cereal - C++11 序列化文库。
  • Cheshire - Clojure JSON和JSON SMILE編碼/解碼。
  • Etch - 跨平台、語言和交通獨立框架
  • Fastjson -快JSON處理器
  • Ffjson - 更快的JSON系列化的Go。
  • FST - 快速Java序列化下降的替代。
  • Jackson - 用于處理 JSON 資料格式的多用途 Java 文庫。
  • Jackson Afterburner - Jackson模組,使用字節碼產生來进一步加速數據捆綁(+30-40%的吞吐量用于串行化,去串行化).
  • Kryo - Java序列化和克隆:快速、高效、自動。
  • Lite³ - JSON相容的零拷贝系列化格式。
  • MessagePack - 高效的二進制序列化格式。
  • Protostuff - 串行化文庫, 內置支持前向相容性( schema 演化) 和驗證 。
  • SBinary - 描述斯卡拉類型的二進制格式的圖書館。
  • Thrift Apache Thrift軟體框架,
  • yyjson - 最快的JSON圖書館
  • Apache Cassandra - 以列為方向,提供高可用性而無任何故障點。
  • Aerospike (c) - 高性能 NoSQL 數據庫 傳送速度
  • ArangoDB - 分布式自由開源數據庫,有灵活的文件、圖和金鑰數據模型。
  • Citus - 分配的 PostgreSQL 作為延伸 。
  • CockroachDB (c) 仿照Google Spanner的 云母 SQL 資料庫
  • Couchbase - 一個為性能、可伸縮性和簡化管理而設計的分布式數據庫。
  • Crate (c) - 可調整的 SQL 數據庫和 NoSQL 的好。
  • Druid - 快速專欄分布式數據庫。
  • Elasticsearch - 開放源碼、可縮放、以及大量可用的搜尋伺服器。
  • Geode - 開放源碼, 分布式, 用于擴散應用程式的內存資料庫 。
  • Infinispan - 用于缓存的高度并行的金鑰/值數據庫。
  • InfluxDB -可調整的數據庫 指標、事件和实时分析
  • RethinkDB - 開放源碼,可縮放的數據庫 讓建立实时應用程式更容易。
  • TiKV - 分散的金鑰數據庫。
  • TimescaleDB - 高性能实时分析的時序數據庫 包裝成 Postgres 延伸
  • Trino - 快速分布的 SQL 查詢引擎,用于大數據分析,幫助您探索您的數據宇宙。
  • Goreplay - 用來捕捉和重播 HTTP 流量的實驗環境的工具。
  • Keploy - API測試與嘲笑的開源工具,
  • Mitmproxy - 互動控制台程序,
  • MockServer - 多重協議(HTTP、gRPC、GraphQL、LLM、MCP、Kafka、TCP等)的混亂工程;
  • Mountebank -跨平台,多模具測試雙倍超過線
  • Pact HTTP API 和非 HTTP 同步訊息系統的合同測試框架 。
  • RestQA - 管理嘲笑的微服務的工具,
  • Specmatic 將 API 的规格( OpenAPI 、 AsyncAPI 、 GraphQL 、 gRPC 等) 轉換成可執行的自動測試、 服務虛擬化 、 以及 反向兼容驗證而不寫入碼 。
  • VCR - 錄制你的測試套件的 HTTP 相互作用 并在未來的測試中重放 以便快速的 決定性的 准确的測試 參考其他語言的執行端口列表 。
  • Wilma HTTP/ HTTPS 服務的結構和透明代理溶液。
  • WireMock - 軟體文庫, 不同於一般目的嘲弄工具, 它的工作原理是建立一個實際的 HTTP 伺服器, 您的代碼在測試中可以連接到, 因為它會是一個真正的網路服務 。
  • Hoverfly - 開發者和測試者的輕量級服務虛擬化/API仿真工具。
  • Awesome CI/CD DevOps :star: - 一個高級工具列表 供繼續整合 繼續提供和DevOps使用
  • AsyncAPI - AsyncAPI规格, 用于定义同步API的業務標準 。
  • JSON:API - 說明客戶端如何要求取取或修改資源, 以及伺服器如何應答這些要求 。
  • API Blueprint -你的API生命周期的工具 用它與其他人討論你的API。 自動產生文件 。 或者一個測試套房 甚至一些密碼。
  • OpenAPI - OpenAPI规格(OAS)提供了連接方式,
  • RAML 簡易簡易地描述實際上的 API。
  • ReDoc - OpenAPI/ Swagger 產生的 API 文件 。
  • Scalar - 開源 API 平台: 美麗的 API 參考和 1 等級 OpenAPI/ Swagger 支援 。
  • Slate - 你的API的漂亮靜態文件
  • Spring REST Docs 由Spring MVC Test製作的自動片段。
  • Swagger - 一個簡單而有力的代表你的API。
  • DID - 分散式标识符(DID)的 W3C 规格:一种新型标识符,它能提供可核查的分散式數位身份。
  • DIDComm - 私人的通訊方法 建立於分散式的DIDs的設計。
  • DIDComm Protocols - 在DIDComm上建立的协议的登記, 高度信任的,自我主權的相互作用 任何運輸。
  • IDSA - 國際數據空間協會(IDSA)的任務是創造全球數位經濟未來,
  • RFC7540 - 超文本传输协议版本 2 。
  • QUIC-WG - IETF工作室被包租來提供下一個網路運輸協議。
  • QUIC-Transport - 以UDP为基础的多路交通和安全交通。
  • JSON-RPC 2.0 - 無國性、輕量级的遠程程序程序程序
  • Open RPC - OpenRPC Specification 定义了 JSON-RPC 2.0 APIs 的標準,程式化語言不可知介面描述.
  • AMQP 高级訊息排隊協議 。
  • MQTT -MQ遥測傳送
  • STOMP - 簡單的文字定向訊息协议。
  • GNAP - 授權談判與授權協議 規定了一個机制 授予一個軟體的授權 并傳達給軟體 包括存取一套API,草案
  • OIDCONN OpenID Connect 1.0 是 OAuth 2.0 协议之上的一個簡單的身份層. 它能讓客戶端基于授權伺服器的認證來驗證最终用户的身份,以及以互動和REST類似的方式取得最终用户的基本配置信息.
  • PASETO Paseto是關於JOSE(JWT, JWE, JWS)的一切, 草案
  • RFC5246 - 运输層安全协议1.2版。
  • RFC6066 - TLS延伸
  • RFC6347 - Datagram 傳送層安全1.2版。
  • RFC6749 - OAuth 2.0批准框架。
  • RFC6962 - 憑證透明
  • RFC7515 - JSON Web Signment(JWS) 代表使用基于 JSON 的數位簽章或訊息認證代碼(MAC)來保障內容 。
  • RFC7519 JSON Web Token(JWT)是代表兩方交接的债权的緊密、安全網址的手段。
  • RFC7642 定義、概述、概念和要求。
  • RFC7643 - SCIM: Core Schema,提供代表使用者和群組的平台中性方案和推广模型。
  • RFC7644 - SCIM: 協議,一個應用層面,REST協議,供應和管理網路上的身份資料。
  • DNS-SD - 用標準的 DNS 查詢, 供客戶查詢某服務的指定实例清單的機制 。
  • RFC2782 - 指定服務位置的DNS RR(DNS SRV)。
  • RFC4627 - JavaScript 物件標注( JSON) 。
  • RFC7049 - 简明二元物件表示。
  • BSON - 二等兵JSON (BSON).
  • JSON-LD - JSON的連結資料。
  • SBE - 簡單的二進制編碼( SBE) 。
  • MSGPACK - 信息包规格。
  • JSON Schema - 字典,讓你能對JSON文件做註解和驗證
  • Schema.org 在網路、網頁、電子郵件等網站上,
  • UNIV8 -Unicode集團 Unicode Standard, version 8.0.0, (Mountain View, CA: The Unicode Consortium, 2015. ISBN 978-1-936213-10-8).
  • RFC3629 - UTF-8,ISO 10646的轉換格式.
  • How Do Committees Invent? :small_orange_diamond:PDF 檔案 - Melvin E. Conway 1968年的數據雜誌 最初的描述康威律法的文章.
  • Service per Team – 每支隊伍都負責一項或多項企業功能(例如企業能力). 一個團隊擁有一個包含一個或多個模組的碼基底. 它的碼基是大小的,以不超出團隊的认知能力. 團隊把密碼部署成一個或一個以上的服務 除非證明有必要提供多种服務,
  • Start with Team Cognitive Load - Team Topologies :small_red_triangle:YT -倫敦19區 也忽略策略與團隊動力。 而不是科技, 我們用實際的案例研究來解釋原因,
  • Commercetools -無頭商業平台
  • Equinox Infosys Equinox是一個以人为中心的商業和銷售平台,
  • Flamingo - 建立灵活和现代电子商务应用的框架。
  • Medusa 無頭開源商業平台

CC0

請讀讀 Contribution Guidelines 在你提議之前

隨你便 open an issue 或 create a pull request 加上你的增加。

:star2: 謝謝你!

HagiCode

HagiCode 是面向專案開發的 AI 編碼工作台:豐富、便利的介面互動讓規劃、Agent 執行與專案工作更容易上手和跟進,帶來更投入的開發體驗。

透過豐富、便利的介面互動,讓規劃、Agent 執行與專案工作更容易上手和跟進。

造訪 HagiCode閱讀文件
  • 智慧OpenSpec 工作流程將意圖轉化為從提案、設計、任務到交付的可執行路徑。
  • 高效多 Agent 並行推進研究、實作與審查,並支援多儲存庫變更與你熟悉的 Agent CLI。
  • 有趣豐富、便利的介面互動讓規劃、Agent 執行與專案工作更容易上手和跟進,帶來更投入的開發體驗。

下載 Windows 版

從 Microsoft Store 取得所有下載

讓想法化為交付成果。

HagiCode 是面向專案開發的 AI 編碼工作台:以 OpenSpec 工作流程規劃變更,多 Agent 並行執行,再由 Hero Scenario 讓進度一目了然,將想法化為交付成果。

智慧
OpenSpec 工作流程將意圖轉化為從提案到交付的可執行路徑。
高效
多 Agent 並行推進研究、實作與審查。
有趣
豐富、便利的介面互動,讓規劃、Agent 執行與專案工作更容易跟進。

要離開 Awesome Site 嗎?

您即將前往外部網站。我們無法控制其內容或隱私慣例。

目的地

繼續前往網站