Ir al contenido

Seleccionar idioma

Idioma actual: Español (España)

Microservices

Source: https://github.com/mfornos/awesome-microservices at 417c83dc4de7
License: CC0-1.0
Read the English original

This edition is an AI-assisted translation.

Selección de recursos sobre microservicios Awesome

Sección titulada «Selección de recursos sobre microservicios »

Una lista curada de principios y tecnologías relacionados con Microservice Architecture.

Cuadro de contenidos

  • 1Backend - Plataforma de microservicios nativos de AI.
  • Jolie - Lenguaje de programación con microservicio de código abierto.
  • OpenWhisk - Plataforma de nube de código abierto sin servidor que ejecuta funciones en respuesta a eventos a cualquier escala.
  • Pulumi - SDK para infraestructura nativa en la nube como código. Utilice su idioma favorito para previsualizar y administrar las actualizaciones de sus aplicaciones e infraestructura, y despliegue continuamente a cualquier nube (no se requiere YAML).
  • Triton - Plataforma de gestión de nube de código abierto que ofrece infraestructura basada en contenedores, orientada a servicios en uno o más centros de datos.
  • Akka - Herramienta y tiempo de ejecución para construir aplicaciones altamente concurrentes, distribuidas y resistentes basadas en mensajes en el JVM.
  • Axon (c) - Una plataforma de desarrollo e infraestructura de fin a fin de fácil desarrollo y funcionamiento de cualquier aplicación DDD, CQRS y Event Sourcing en JVM.
  • Ballerina - Lenguaje de programación nativa en la nube.
  • Bun - Fast all-in-one JavaScript runtime.
  • Dapr - Tiempo libre para escribir microservicios altamente performantes usando cualquier lenguaje de programación.
  • Deno - JavaScript, TypeScript y WebAssembly runtime con predeterminados seguros y una gran experiencia de desarrollador.
  • Eclipse Microprofile - Un foro abierto para optimizar Enterprise Java para una arquitectura de microservicios innovando en múltiples implementaciones y colaborando en áreas comunes de interés con un objetivo de estandarización.
  • Erlang/OTP - Lenguaje de programación utilizado para construir sistemas blandos masivamente escalables en tiempo real con requisitos en alta disponibilidad.
  • Finagle - Sistema RPC extensible para el JVM, utilizado para construir servidores de alta concurrencia.
  • Gleam - Un lenguaje amistoso para construir sistemas tipo seguro, escalables.
  • GraalVM - Tiempo de ejecución de alto rendimiento que proporciona mejoras significativas en el rendimiento de la aplicación y la eficiencia que es ideal para microservicios.
  • Helidon - Colección de bibliotecas Java para escribir microservicios que funcionan en un núcleo web rápido alimentado por Netty.
  • Ice - Marco RPC completo con soporte para C++, C#, Java, JavaScript, Python y más.
  • Light-4j - Un alto rendimiento, baja latencia, pequeña huella de memoria y una plataforma de microservicios más productiva.
  • Micronaut - Un marco moderno, basado en JVM, completo para la construcción de aplicaciones modulares y de microservicios fácilmente probables.
  • Moleculer - Marco de microservicio rápido y potente para Node.js, Java, Go y Ruby.
  • Open Liberty - Un marco abierto ligero para la construcción de microservicios Java dinámicos y eficientes.
  • Pears - Tiempo de ejecución, desarrollo y despliegue.
  • SmallRye - APIs e implementaciones adaptadas para el desarrollo de la nube, incluyendo Eclipse MicroProfile.
  • Spin - Un marco de código abierto para construir y ejecutar microservicios de nube rápidos, seguros y composables con WebAssembly.
  • ScaleCube - Herramienta para la construcción de microservicios reactivas para el JVM: baja latencia, alto rendimiento, escalable y resistente.
  • Vert.X - Herramienta para construir aplicaciones reactivas en el JVM.
  • Vert.X Toolbox - Un conjunto de componentes Vert.x para construir aplicaciones reactivas de microservicio.
  • Wangle - Un marco que proporciona un conjunto de abstracciones comunes de cliente/servidor para los servicios de construcción de una manera consistente, modular y composible.
  • GRPC - Un alto rendimiento, código abierto, marco general RPC que pone en primer lugar móvil y HTTP/2. Bibliotecas en C, C++, Java, Go, Node.js, Python, Ruby, Objective-C, PHP y C#.
  • Lwan - Servidor web de alto rendimiento y escalable.
  • uSockets - Miniscule evento multiplataforma, networking & cripto para aplicaciones asinc.
  • Cap’n Proto RPC - La implementación del Cap’n Proto C++ RPC.
  • C++ Micro Services - Sistema de módulos dinámicos OSGi-like C++ y registro de servicios.
  • Enduro/X - Marco de servicio basado en XATMI para GNU/Linux.
  • Pistache - Un kit de herramientas REST de alto rendimiento escrito en C++.
  • Poco - Bibliotecas C++ para construir aplicaciones y servidores basados en red.
  • Sogou Workflow - Motor de programación de nivel empresarial destinado a satisfacer la mayoría de los requisitos de desarrollo de backend.
  • uWebSockets - Servidor web sencillo y seguro para las aplicaciones más exigentes.
  • Awesome Microservices .NET Core :star: - Una colección de impresionantes series de entrenamiento, artículos, videos, libros, cursos, proyectos de muestra y herramientas para microservicios en .NET Core.
  • Vibe.d - I/O asincrónico que no se interpone en su camino, escrito en D.
  • Phoenix - Marco para la creación de aplicaciones HTML5, API backends y sistemas distribuidos.
  • Plug - Una especificación y conveniencias para módulos composables entre aplicaciones web.
  • Cowboy - Servidor HTTP pequeño, rápido y modular escrito en Erlang.
  • Mochiweb - Biblioteca Erlang para construir servidores HTTP ligeros.
  • Chi - Enrutador ligero, idiomático y composable para construir servicios Go HTTP.
  • Echo - Marco de servidor HTTP rápido y desfavorable para Go. Hasta 10 veces más rápido que el resto.
  • Fiber - Express inspirado marco web construido sobre Fasthttp, el motor HTTP más rápido para Go. Diseñado para facilitar las cosas para un desarrollo rápido con cero asignación de memoria y rendimiento en mente.
  • Gin - Gin es un marco web HTTP escrito en Go (Golang). Cuenta con una API tipo Martini con un rendimiento mucho mejor, hasta 40 veces más rápido.
  • Goa - Microservicios HTTP basados en diseño en Go.
  • GoFr - Un marco de desarrollo de microservicios de opinión que hace hincapié en la escalabilidad y la robustez. Diseñado para simplificar el desarrollo de microservicios.
  • Go Chassis - Un marco para el rápido desarrollo de microservicios en Go que es fácil de integrar con algunos ecosistemas de nubes.
  • Go-micro - Un marco de desarrollo de sistemas distribuidos.
  • Go-zero - Un marco de desarrollo del sistema de distribución web y rpc.
  • Gorilla - Herramienta web para el lenguaje de programación Go.
  • Iris - Marco de micro web rápido, sencillo y eficiente para Go.
  • Lura - Marco para construir ultra rendimiento API Gateways con middlewares.
  • RPCX - Un marco de servicio RPC distribuido basado en NET/RPC como Alibaba Dubbo y Weibo Motan.
  • Scotty - Marco web micro inspirado en el Sinatra de Ruby, usando WAI y Warp.
  • Servant - DSL de nivel de tipo.
  • Yesod - El marco web Haskell RESTful.
  • Compojure - Una biblioteca concisa para Ring/Clojure.
  • Duct - Un marco de servidor para Clojure.
  • System - Construido sobre la biblioteca de componentes de Stuart Sierra, ofrece un conjunto de componentes listos.
  • Tesla Base común para algunos de los microservicios Clojure de Otto.de.
  • ActiveJ - Biblioteca ligera y rápida para aplicaciones complejas de alta carga distribuidas y soluciones similares a Memcached.
  • Airlift - Marco para la construcción de servicios REST en Java.
  • Armeria - Biblioteca de código abierto HTTP/2 RPC/REST cliente/servidor construido sobre Java 8, Netty, Thrift y gRPC.
  • Disruptor - Biblioteca de mensajería de alto rendimiento.
  • Dropwizard - Marco Java para el desarrollo de servicios web adaptados a las operaciones, de alto rendimiento.
  • Dubbo - Un marco RPC basado en java de alto rendimiento y con código abierto de Alibaba.
  • Conjure - Conjunto de bibliotecas para definir y crear servidores RESTish/RPC y clientes basados en Feign o Retrofit como cliente y Dropwizard/Jersey con definiciones de servicio JAX-RS como servidor.
  • Jersey - Servicios RESTful en Java. Implementación de referencia JAX-RS.
  • Quarkus - A Kubernetes Native Java stack tailored for OpenJDK HotSpot and GraalVM, elaborado a partir de las mejores bibliotecas y estándares de Java de raza.
  • Ratpack - Conjunto de bibliotecas Java que facilitan aplicaciones HTTP rápidas, eficientes y bien probadas. se proporciona apoyo específico para el idioma Groovy.
  • Spring Boot - Hace que sea fácil crear aplicaciones independientes y de calidad de producción basadas en primavera.
  • Http4k - Herramienta HTTP ligera pero totalmente caracterizada escrita en puro Kotlin que permite el servicio y consumo de servicios HTTP de una manera funcional y consistente.
  • Ktor - Marco para construir servidores y clientes asincrónicos en sistemas conectados usando el lenguaje de programación Kotlin.
  • Finatra - Servicios rápidos, probables, Scala HTTP construidos en Twitter-Server y Finagle.
  • Http4s - Una interfaz Scala mínima y idiomática para HTTP
  • Play - El marco web de alta velocidad para Java y Scala.
  • Actionhero - Multi-transporto Node.js API servidor con capacidades integradas de racimo y tareas retrasadas.
  • Express - Marco web rápido, sin pintar, minimalista para Node.js
  • Fastify - Rápido, rápido y bajo marco web, para Node.js.
  • FeathersJS - Una capa de código abierto REST y API en tiempo real para aplicaciones modernas.
  • Hono - Marco web pequeño, sencillo y ultrarrápido para los Edges. Funciona en cualquier momento de ejecución de JavaScript.
  • Koa - Marco web de próxima generación para Node.js
  • Loopback - Node.js framework for creating APIs and easily connecting to backend data sources.
  • NestJS - Marco Node.js para la construcción de aplicaciones eficientes y escalables con soporte integrado de microservicios.
  • Seneca - Un kit de herramientas de microservicio para Node.js
  • Serverless - Construir y mantener aplicaciones web, móviles e IoT que se ejecutan en AWS Lambda y API Gateway (antes conocidas como JAWS).
  • tRPC - API de tipo a extremo.
  • Cro - Bibliotecas para crear sistemas reactivos distribuidos utilizando Perl 6.
  • Mojolicious - Marco web de próxima generación para Perl.
  • API Platform - Marco web API-primer en Symfony con soporte JSON-LD, Schema.org y Hydra.
  • Ecotone - Marco basado en principios arquitectónicos de DDD, CQRS y Event Sourcing que proporciona bloques de construcción para crear aplicaciones escalables y extensibles.
  • Hyperf - Hyperf es un marco CLI PHP extremadamente performant y flexible basado en Swoole 4.5+, alimentado por el servidor coroutino de última generación y un gran número de componentes de prueba de batalla.
  • Lumen - Impresionantemente rápido microframework.
  • Slim - Micro-framework que le ayuda a escribir rápidamente aplicaciones web simples pero potentes y APIs.
  • Spiral - Marco diseñado para aplicaciones de larga duración utilizando RoadRunner. Ofrece características avanzadas como la integración con Temporal motor de flujo de trabajo y Centrifugo servidor websocket. Es particularmente eficaz para la arquitectura de microservicios, proporcionando un soporte robusto para APIs REST y servicios de GRPC.
  • Swoft - Marco de coroutina de microservicios PHP para la construcción de sistemas web de alto rendimiento, API, middleware y servicios básicos.
  • Symfony - Microframework basado en los componentes Symfony.
  • Aiohttp - HTTP cliente/servidor para asyncio.
  • Bottle - Marco rápido, sencillo y ligero WSGI micro web para Python.
  • Connexion - Marco Swagger/OpenAPI para Python en la parte superior de Flask con validación automática de punto final y soporte OAuth2.
  • Falcon - Bare-metal Python web API framework for building very fast app backends and microservices.
  • FastAPI - Moderno, rápido (alto rendimiento), marco web para la construcción de APIs con Python 3.6+ basado en sugerencias tipo Python estándar.
  • Flask - Marco de pitón para microservicios basados en Werkzeug y Jinja 2.
  • Nameko - Marco de pitón para la construcción de microservicios.
  • Sanic - Sanic es un servidor web tipo Flask Python 3.5+ que está escrito para ir rápido.
  • Tornado - Marco web y biblioteca de redes asincrónica.
  • Twisted - Motor de programación de red impulsado por eventos.
  • Web.py - Marco web minimalista para Python.
  • Grape - Un marco opinado para crear API tipo REST
  • Hanami - Un marco web moderno para Ruby.
  • Praxis - Marco para diseñar e implementar APIs.
  • Scorched - Marco web ligero para Ruby.
  • Sinatra - Sinatra es un DSL para crear rápidamente aplicaciones web en Ruby con mínimo esfuerzo.
  • Are we web yet? :star: - Un resumen del estado actual de programación web en Rust.
  • Actix - Marco web potente, pragmático y extremadamente rápido para Rust.
  • Tarpc - Marco RPC para Rust con enfoque en facilidad de uso.
  • Tokio - Tiempo de ejecución asincrónico para escribir aplicaciones de red.
  • Tower - Biblioteca de componentes modulares y reutilizables para la construcción de robustos clientes y servidores de redes.
  • Wtx - Marco cliente/servidor HTTP/2.
  • Ambassador (c) - Kubernetes- Puerta de API nativa para microservicios construidos en Envoy.
  • Apache APISIX - Puerta de API de alto rendimiento, en tiempo real y puerta de entrada AI construida en NGINX y etcd, con enrutamiento de carga caliente y plugins 100+.
  • APIcast - APIcast es una pasarela API construida en la parte superior de NGINX. Es parte de la Red Hat 3scale API Management Platform.
  • Bunker Web - Web app hosting y proxy inverso seguro por defecto.
  • Caddy - Extensible servidor web HTTP/2 con HTTPS automático.
  • Camel - Permite definir reglas de enrutamiento y mediación en una variedad de idiomas específicos de dominio, incluyendo una API fluida basada en Java, archivos de configuración de Spring o Blueprint XML y un Scala DSL.
  • Envoy - Borde de código abierto y proxy de servicio, de los desarrolladores en Lyft.
  • HAProxy - Fiable, balanceador de carga TCP/HTTP de alto rendimiento.
  • Istio - Una plataforma abierta para conectar, gestionar y asegurar microservicios.
  • Keepalived - Instalaciones sencillas y robustas para el balance de carga y alta disponibilidad para el sistema Linux y las infraestructuras basadas en Linux.
  • Kong - Capa de gestión de código abierto para APIs.
  • KrakenD - Open source ultra performance API Gateway.
  • Kuma - Plan de control de código abierto agnóstico para malla de servicio y microservicios.
  • Linkerd - Malla de servicio resistente para aplicaciones nativas en la nube.
  • Neutrino - Equilibrio de carga de software extensible.
  • OpenResty - Servidor de aplicación web rápido construido sobre Nginx.
  • Open Service Mesh - Malla de servicio nativo de nube ligera y extensible.
  • Otoroshi - Proxy inverso HTTP moderno con gestión de API ligera.
  • Pingora - Una biblioteca para construir servicios de red rápidos, fiables y evolvibles.
  • Skipper - HTTP router útil para decoupling routing de la lógica del servicio.
  • Spring Cloud Gateway - API Gateway en la parte superior de Spring MVC. Objetivos para proporcionar una manera sencilla, pero eficaz de llegar a las API.
  • Tengine - Una distribución de Nginx con algunas características avanzadas.
  • Træfɪk - Un moderno HTTP inverso proxy y balanceador de carga hechos para desplegar microservicios con facilidad.
  • Traffic Server - Bloque de construcción de alto rendimiento para servicios en la nube.
  • Tyk - Abrir fuente, pasarela de API rápida y escalable, portal y plataforma de gestión API.
  • Vulcand - Equilibrio de carga programático respaldado por Etcd.
  • Zuul - Un servicio de bordes que proporciona enrutamiento dinámico, monitoreo, resiliencia, seguridad y más.
  • Central Dogma - Repositorio de configuración de servicio altamente disponible de código abierto basado en Git, ZooKeeper y HTTP/2.
  • Consul - El descubrimiento y la configuración del servicio se hicieron fáciles. Distribuido, altamente disponible, y datoscenter-aware.
  • Etcd - Tienda de valor clave altamente disponible para la configuración compartida y el descubrimiento de servicios.
  • Eureka - Servicio basado en REST que se utiliza principalmente en la nube de AWS para localizar servicios con el fin de equilibrar la carga y la falla de servidores de nivel medio.
  • Microconfig - Forma moderna y sencilla de gestión de configuración de microservicio.
  • Nacos - Plataforma de descubrimiento, configuración y gestión de servicios dinámicos de fácil uso.
  • SkyDNS - Servicio distribuido para el anuncio y el descubrimiento de servicios construidos en la parte superior del etcd. Utiliza consultas DNS para descubrir los servicios disponibles.
  • Spring Cloud Config - Proporciona soporte servidor y cliente para configuración externalizada en un sistema distribuido.
  • ZooKeeper - Servidor de código abierto que permite una coordinación distribuida altamente fiable.
  • AWS Step Functions (c) - Coordinar los componentes de aplicaciones distribuidas y microservicios utilizando flujos de trabajo visuales.
  • Cadence - Plataforma de código estatal predeterminada.
  • Conductor - Un motor de orquestación de microservicios.
  • Inngest - Funciones duraderas para la lógica de fondo fiable, desde trabajos de fondo hasta flujos de trabajo complejos.
  • Kestra - Microservicios de código abierto de eventos, orquestación agnóstica y plataforma de programación.
  • Temporal - Plataforma de orquestación de microservicios de código abierto para ejecutar código crítico de misión en cualquier escala.
  • Zeebe - Definir, orquestar y monitorear procesos de negocio a través de microservicios.
  • Hazelcast - Fuente abierta en memoria. Le permite distribuir datos y computación a través de servidores, clusters y geografías, y gestionar conjuntos de datos muy grandes o altas tasas de ingestión de datos. Tecnología madura.
  • Helix - Marco genérico de gestión de agrupaciones utilizado para la gestión automática de los recursos distribuidos, replicados y distribuidos alojados en un grupo de nodos.
  • Ignite - Plataforma de alto rendimiento, integrada y distribuida en memoria para computar y realizar transacciones en conjuntos de datos a gran escala en tiempo real, órdenes de magnitud más rápido que posible con tecnologías tradicionales basadas en disco o flash.
  • Libp2p - Marco y conjunto de protocolos para la construcción de aplicaciones de red entre pares.
  • Mesos - Extractos CPU, memoria, almacenamiento y otros recursos informáticos lejos de las máquinas (físicas o virtuales), permitiendo que los sistemas de distribución tolerante a fallas y elásticos se construyan y ejecuten con facilidad.
  • Nomad - Distribuido, altamente disponible, datacenter-aware scheduler.
  • Redisson - Estructuras de datos Java distribuidas y escalables en la parte superior del servidor Redis.
  • Serf - Solución descentralizada para membresía, detección de fallos y orquestación.
  • Valkey - Un nuevo proyecto para reanudar el desarrollo en el proyecto Redis de antiguo código abierto.
  • Zenoh - El protocolo Pub/sub/query unifica datos en movimiento, datos en reposo y computaciones. Combina eficientemente pub/sub tradicional con almacenamiento geo distribuido, consultas y computaciones.

Programadores de empleo / Automatización de carga de trabajo

Sección titulada «Programadores de empleo / Automatización de carga de trabajo»
  • Celery - Asynchronous task queue/job queue based on distributed message passing. Centrado en operaciones en tiempo real y soporta la programación.
  • Dkron - Distribuido, sistema de programación de trabajo tolerante a fallas.
  • Faktory - Servidor de trabajo de fondo persistente de lenguaje-agnóstico.
  • Rundeck (c) - Programador de trabajo y automatización de runbook. Permitir el acceso a los scripts y herramientas existentes.
  • Schedulix - El sistema de programación de empleos de código abierto establece normas innovadoras para la automatización profesional de los procesos informáticos en entornos avanzados del sistema.
  • mirrord - Ejecutar código local como si fuera un pod en un remoto Kubernetes cluster.
  • Fluentd - Coleccionista de datos de código abierto para capa de registro unificada.
  • Graylog - Plataforma de gestión integrada de registros de código abierto.
  • Kibana - Plataforma de análisis y visualización flexible.
  • LogDNA (c) - Software centralizado de gestión de registros. Recopilar instantáneamente, centralizar y analizar registros en tiempo real desde cualquier plataforma, en cualquier volumen.
  • Logstash - Herramienta para gestionar eventos y registros.
  • Loki - Como Prometeo, pero para registros.
  • ØMQ - Una capa de transporte inteligente.
  • ActiveMQ - Powerful open source messaging and integration patterns server.
  • Aeron - Unicast UDP confiable eficiente, multicast UDP y transporte de mensajes IPC.
  • Beanstalk - Una cola de trabajo simple y rápida.
  • Bull - Una cola rápida y fiable de Redis para Node.
  • Crossbar - Plataforma de redes de código abierto para aplicaciones distribuidas y microservicio. Implementa el protocolo de mensajería de aplicaciones web abierta (WAMP).
  • Kafka - Publish-subscribe messaging rethought as a distributed commit log.
  • Malamute - Interventor de mensajería empresarial ZeroMQ.
  • Mosquitto - Interventor de mensajes de código abierto que implementa el protocolo MQTT.
  • NATS - Sistema de mensajería de nube de alto rendimiento y peso ligero.
  • NSQ - Una plataforma de mensajería distribuida en tiempo real.
  • Pulsar - Sistema de mensajería pub-sub distribuido.
  • RabbitMQ - Agente de mensaje basado en Erlang de código abierto que sólo funciona.
  • Redpanda - Streaming data platform for developers: Kafka API compatible, 10x más rápido, no ZooKeeper y no JVM.
  • RocketMQ - Una baja latencia, confiable, escalable, fácil de usar el middleware orientado al mensaje nacido de un negocio de mensajería masiva de alibaba.
  • Beats - Transportadores ligeros para Elasticsearch ” Logstash.
  • Elastalert - Alerta fácil y flexible para Elasticsearch.
  • Ganglia - Un sistema de monitoreo distribuido escalable para sistemas de computación de alto rendimiento, como racimos y cuadrículas.
  • Grafana - Una fuente abierta, cuenta con ricas métricas dashboard y editor de gráficos para Graphite, InfluxDB & OpenTSDB.
  • Graphite - Gráficos escalables en tiempo real.
  • IOpipe (c) - Seguimiento de la aplicación para Amazon Lambda.
  • Jaeger - Una fuente abierta, localización distribuida de extremo a extremo
  • OpenTelemetry - Telemetría de alta calidad, ubicua y portátil para permitir una observabilidad efectiva.
  • Prometheus - Un sistema de monitoreo de servicios de código abierto y una base de datos de series temporales.
  • Riemann - Monitores sistemas distribuidos.
  • Sensu - Vigilancia de la infraestructura de hoy.
  • SkyWalking - Herramienta de monitorización de aplicaciones para sistemas distribuidos, especialmente diseñados para microservicios, nativos en la nube y con base en contenedores (Docker, K8sarquitecturas.
  • Zabbix - Solución de monitoreo de clase empresarial de código abierto.
  • Zipkin - Sistema de rastreo distribuido.
  • Arroyo - Motor de procesamiento de flujo distribuido para transformar, filtrar, agregar y unir secuencias de datos escribiendo SQL.
  • Reactor.io - Una biblioteca reactiva de segunda generación para la construcción de aplicaciones no de bloqueo en el JVM basado en la especificación Reactive Streams.
  • Reactive Kafka - API Reactive Streams para Apache Kafka.
  • ReactiveX - API para programación asincrónica con secuencias observables. Disponible para Java idiomática, Scala, C#, C++, Clojure, JavaScript, Python, Groovy, JRuby y otros.
  • RSocket - Protocolo de aplicación que proporciona secuencias reactivas semántica.
  • Awesome Chaos Engineering :star: - Una lista curada de recursos increíbles de ingeniería del caos.
  • Raft Consensus - algoritmo de consenso diseñado para ser fácil de entender. Es equivalente a Paxos en tolerancia a fallas y rendimiento.
  • Resilience4j - Biblioteca de tolerancia predeterminada diseñada para Java8 y programación funcional.
  • Svix - Servicio Webhooks que envía webhooks a sus usuarios con horarios completos de reingreso, retroceso exponencial, verificación de firmas y tipos de eventos.
  • Cerbos Hub - Sistema de gestión de autorizaciones para autorizar, probar e implementar políticas de acceso. Construido una autorización escalable y fina en una arquitectura de microservicio.
  • Dex - Servicio de auth/directory con conectores enchufables. OpenID Connect proveedor y delegación de terceros OAuth 2.0.
  • JWT - JSON Web Tokens es un método RFC 7519 estándar de la industria abierto para representar reclamaciones de forma segura entre dos partes.
  • Keycloak - Servicio de auth completo y extensible. OpenID Connect proveedor y delegación de terceros OAuth 2.0.
  • OAuth - Proporciona flujos de autorización específicos para aplicaciones web, aplicaciones de escritorio, teléfonos móviles y dispositivos de sala de estar. Muchas implementaciones.
  • OpenID Connect - Bibliotecas, productos y herramientas que implementan las especificaciones actuales de OpenID y especificaciones relacionadas.
  • Open Ziti - Cero seguridad de confianza y superposición de redes como software de código abierto puro.
  • ORY - Infraestructura y servicios de identidad de código abierto.
  • OWASP Agent Memory Guard — capa de defensa del tiempo de ejecución para el envenenamiento de memoria del agente AI (OWASP ASI06). Detecta entradas de memoria manipuladas, inyección rápida en caminos de memoria y fuga secreta. Políticas de YAML, microsegundo latencia, cero dependencias externas.
  • SCIM - Sistema de Gestión de Identidad Trans-dominio.
  • Vault - Garantiza, almacena y controla firmemente el acceso a fichas, contraseñas, certificados, claves de API y otros secretos en la informática moderna.
  • Avro - Sistema de serialización de datos Apache que proporciona estructuras de datos ricas en un formato de datos compacto, rápido y binario.
  • Bond - Marco multiplataforma para trabajar con datos esquematizados, ampliamente utilizado en Microsoft en servicios de alta escala.
  • BooPickle - Biblioteca de serialización binaria para una comunicación de red eficiente. Para Scala y Scala.js
  • Cap’n Proto - Insanely fast data interchange format and capacity-based RPC system.
  • CBOR - Implementaciones de la norma CBOR (RFC 7049) en muchos idiomas.
  • Cereal - Biblioteca C++11 para serialización.
  • Cheshire - Clojure JSON y JSON SMILE encoding/decoding.
  • Etch - Marco interplataforma, lenguaje e independiente del transporte para la construcción y consumo de servicios de red.
  • Fastjson - Procesador JSON rápido.
  • Ffjson - Más rápido JSON serialización para Go.
  • FST - Una rápida serie de java caer en el lugar.
  • Jackson - Una biblioteca multipropósito Java para procesar el formato de datos JSON.
  • Jackson Afterburner - Módulo Jackson que utiliza generación de códigos bytecode para acelerar aún más la unión de datos (+30-40% de rendimiento para serialización, deserialización).
  • Kryo - serialización y clonación Java: rápido, eficiente, automático.
  • Lite³ - Formato de serialización compatible con JSON.
  • MessagePack - Formato de serialización binaria eficiente.
  • Protostuff - Una biblioteca de serialización con soporte incorporado para compatibilidad hacia adelante (evolución del esquema) y validación.
  • SBinary - Biblioteca para describir formatos binarios para tipos Scala.
  • Thrift - El marco de software Apache Thrift, para el desarrollo de servicios multilingües escalables.
  • yyjson - La biblioteca JSON más rápida de C.
  • Apache Cassandra - Columna orientada y proporcionando alta disponibilidad sin un solo punto de fracaso.
  • Aerospike (c) - Base de datos NoSQL de alto rendimiento que proporciona velocidad a escala.
  • ArangoDB - Una base de datos de código libre distribuida con un modelo de datos flexible para documentos, gráficos y valores clave.
  • Citus - PostgreSQL distribuido como extensión.
  • CockroachDB (c) - Una base de datos SQL nativa de la nube modelada después de Google Spanner.
  • Couchbase - Una base de datos distribuida diseñada para rendimiento, escalabilidad y administración simplificada.
  • Crate (c) - Base de datos SQL escalable con los productos NoSQL.
  • Druid - Tienda de datos distribuida rápida orientada a la columna.
  • Elasticsearch - Fuente abierta distribuida, escalable y servidor de búsqueda altamente disponible.
  • Geode - Base de datos de código abierto, distribuido, en memoria para aplicaciones de escalada.
  • Infinispan - Datastore clave/valor altamente concurrente utilizado para caché.
  • InfluxDB - Tienda de datos escalable para métricas, eventos y análisis en tiempo real.
  • RethinkDB - Fuente abierta, base de datos escalable que facilita la creación de aplicaciones en tiempo real.
  • TiKV - Base de datos de valor clave de transacción distribuida.
  • TimescaleDB - Una base de datos de series temporales para análisis de alto rendimiento en tiempo real empaquetados como extensión Postgres.
  • Trino - Motor de consulta SQL distribuido rápido para análisis de datos grandes que te ayuda a explorar tu universo de datos.
  • Goreplay - Una herramienta para capturar y reproducir el tráfico HTTP en vivo en un ambiente de prueba.
  • Keploy - Herramienta de código abierto para la prueba y la burla de API capturando tráfico real y convirtiéndola en casos de prueba y problemas, permitiendo pruebas fiables de microservicio.
  • Mitmproxy - Un programa interactivo de consola que permite interceptar, inspeccionar, modificar y reproducir flujos de tráfico.
  • MockServer - Mocking, debugging proxy y el caos de ingeniería para múltiples protocolos (HTTP, gRPC, GraphQL, LLM, MCP, Kafka, TCP y más); dependencia de mock, tráfico de registro/replay, verificar solicitudes y errores de inyección para pruebas de integración y resiliencia.
  • Mountebank - La prueba multiprotocolo se dobla sobre el alambre.
  • Pact - Marco de prueba de contratos para API HTTP y sistemas de mensajería asincrónica no HTTP.
  • RestQA - Una herramienta para gestionar microservicios simulando, pruebas de unidad y rendimiento localmente con mejor experiencia en el desarrollador de clase.
  • Specmatic - Convierte las especificaciones de API (OpenAPI, AsyncAPI, GraphQL, gRPC etc) en contratos ejecutables para pruebas automatizadas, virtualización de servicios y validación de compatibilidad atrasada sin código de escritura.
  • VCR - Registre las interacciones HTTP de su suite de prueba y vuelva a reproducirlas durante futuras pruebas para pruebas rápidas, deterministas y precisas. Vea la lista de puertos para implementaciones en otros idiomas.
  • Wilma - Combinado HTTP/HTTPS stub y solución proxy transparente.
  • WireMock - Biblioteca flexible para atracar y burlar servicios web. A diferencia de las herramientas de simulación de propósito general funciona creando un servidor HTTP real que su código bajo prueba puede conectarse a como sería un servicio web real.
  • Hoverfly - Virtualización de servicio ligero / herramienta de simulación API para desarrolladores y probadores.
  • Awesome CI/CD DevOps :star: - Una lista curada de herramientas impresionantes para la integración continua, entrega continua y DevOps.
  • AsyncAPI - Especificación AsyncAPI, el estándar de la industria para definir APIs asincrónicas.
  • GraphQL - Lenguaje de consulta diseñado para construir aplicaciones cliente proporcionando una sintaxis y sistema intuitivo y flexible para describir sus requisitos de datos e interacciones.
  • JSON:API - Una especificación para cómo un cliente debe solicitar que los recursos sean capturados o modificados, y cómo un servidor debe responder a esas solicitudes.
  • API Blueprint - Herramientas para todo el ciclo de vida de API. Úsalo para discutir tu API con otros. Generar documentación automáticamente. O una suite de pruebas. O incluso un código.
  • OpenAPI - La especificación OpenAPI (OAS) proporciona un medio consistente para llevar información a través de cada etapa del ciclo de vida de API.
  • RAML - RESTful API Modeling Language, una forma sencilla y sucinta de describir APIs prácticamente incompletas.
  • ReDoc - Documentación de API generada por OpenAPI/Swagger.
  • Scalar - Plataforma API de código abierto: hermosas referencias de API y soporte OpenAPI/Swagger de primera clase.
  • Slate - Hermoso documentación estática para su API.
  • Spring REST Docs - Documentos Servicios RESTful combinando documentación escrita a mano con fragmentos autogenerados producidos con Spring MVC Test.
  • Swagger - Una representación sencilla pero poderosa de su API RESTful.
  • W3C.REC-Webarch - Arquitectura de la World Wide Web, Volumen Uno.
  • RFC3986 - Uniform Resource Identifier (URI): Generic Syntax.
  • RFC6570 - Plantilla URI.
  • RFC7320 - Diseño y Propiedad URI.
  • DID - Especificación W3C de identificadores descentralizados (DIDs): un nuevo tipo de identificador que permite la identidad digital verificable y descentralizada.
  • DIDComm - La metodología de comunicación privada construyó sobre el diseño descentralizado de los DID.
  • DIDComm Protocols - Registro de protocolos construidos en DIDComm, para interacciones de alta confianza y auto-soberbia sobre cualquier transporte.
  • IDSA - La Asociación Internacional de Espacios de Datos (IDSA) está en misión de crear el futuro de la economía mundial y digital con los Espacios Internacionales de Datos (IDS), un sistema seguro y soberano de intercambio de datos en el que todos los participantes puedan realizar el valor total de sus datos.
  • RFC7540 - Versión del Protocolo de Transferencia de Hipertextos 2.
  • QUIC-WG - Grupo de Trabajo de la IETF que se flete para entregar el próximo protocolo de transporte para Internet.
  • QUIC-Transport - Un transporte multixed y seguro basado en UDP.
  • JSON-RPC 2.0 - Un protocolo de llamada de procedimiento remoto apátrida y ligero.
  • Open RPC - La especificación OpenRPC define una descripción estándar de interfaz agnóstica de programación para las API JSON-RPC 2.0.
  • AMQP - Protocolo de búsqueda de mensajes avanzados.
  • MQTT - Transporte de Telemetría MQ.
  • STOMP - Protocolo de mensajería orientado a texto simple.
  • GNAP - El Protocolo de Negociación y Autorización de Grant define un mecanismo para delegar la autorización a una pieza de software y transmitir esa delegación al software. Esta delegación puede incluir el acceso a un conjunto de API, así como la información transmitida directamente al software.DRAFT
  • OIDCONN - OpenID Connect 1.0 es una simple capa de identidad en la parte superior del protocolo OAuth 2.0. Permite a los clientes verificar la identidad del usuario final basada en la autenticación realizada por un servidor de autorización, así como obtener información básica sobre el usuario final de una manera interoperable y similar a REST.
  • PASETO - Paseto es todo lo que te gusta de JOSE (JWT, JWE, JWS) sin ninguno de los muchos déficits de diseño que plagan los estándares JOSE. DRAFT
  • RFC5246 - La versión 1.2 del Protocolo de Seguridad de la Capa de Transporte.
  • RFC6066 - TLS Extensiones.
  • RFC6347 - Datagram Transport Layer Security Version 1.2.
  • RFC6749 - El marco de autorización OAuth 2.0.
  • RFC6962 - Transparencia de certificados.
  • RFC7515 - JSON Web Signature (JWS) representa contenido asegurado con firmas digitales o Códigos de autenticación de mensajes (MACs) utilizando estructuras de datos basadas en JSON.
  • RFC7519 - JSON Web Token (JWT) es un medio compacto y seguro de URL para representar reclamaciones que se transferirán entre dos partes.
  • RFC7642 - SCIM: Definiciones, visión general, conceptos y requisitos.
  • RFC7643 - SCIM: Core Schema, proporciona un esquema neutro de plataforma y un modelo de extensión para representar a usuarios y grupos.
  • RFC7644 - SCIM: Protocolo, protocolo de aplicación, protocolo REST para facilitar y gestionar datos de identidad en la web.
  • DNS-SD - Mecanismo para que los clientes descubran una lista de casos nombrados de un servicio, utilizando las consultas DNS estándar.
  • RFC2782 - A DNS RR for specifying the location of services (DNS SRV).
  • RFC4627 - Notación de objetos JavaScript (JSON).
  • RFC7049 - Representación de objetos binarios (CBOR).
  • BSON - Binario JSON (BSON).
  • JSON-LD - JSON for Linking Data.
  • SBE - Codificación binaria simple (SBE).
  • MSGPACK - Especificación de MessagePack.
  • JSON Schema - Vocabulario que le permite anotar y validar documentos JSON.
  • Schema.org - Colaborativa, actividad comunitaria con una misión para crear, mantener y promover esquemas para datos estructurados en Internet, en páginas web, en mensajes de correo electrónico, y más allá.
  • UNIV8 - El Consorcio Unicode. El estándar Unicode, versión 8.0.0, (Mountain View, CA: The Unicode Consortium, 2015. ISBN 978-1-936213-10-8).
  • RFC3629 - UTF-8, un formato de transformación de ISO 10646.
  • How Do Committees Invent? :small_orange_diamond:PDF - Melvin E. Conway, revista Datamation 1968. El artículo original que define la Ley de Conway.
  • Service per Team - Cada equipo es responsable de una o más funciones empresariales (por ejemplo, capacidades de negocio). Un equipo posee una base de código que consiste en uno o más módulos. Su base de código es tamaño para no superar la capacidad cognitiva del equipo. El equipo implementa su código como uno o más servicios. Un equipo debe tener exactamente un servicio a menos que haya una necesidad comprobada de tener múltiples servicios.
  • Start with Team Cognitive Load - Team Topologies :small_red_triangle:YT - DOES19 London. El debate “monolitos vs microservicios” a menudo se centra en aspectos tecnológicos, ignorando la estrategia y la dinámica de equipo. En lugar de la tecnología, las organizaciones inteligentes comienzan con la carga cognitiva del equipo como el principio rector del software moderno. En esta charla, explicamos cómo y por qué, ilustrados por estudios de casos reales.
  • Commercetools - Plataforma de comercio sin cabeza.
  • Equinox - Infosys Equinox es una plataforma de comercio y marketing centrada en el ser humano que apoya experiencias ricas y hiperpersonalizadas en cualquier canal y punto de contacto.
  • Flamingo - Marco para construir aplicaciones de comercio electrónico flexibles y modernas.
  • Medusa - Plataforma de comercio sin cabeza.
  • Autonomy, Hyperconnectivity, and Residual Causality - Introducción filosófica al diseño de sistemas hiperliminal adaptativos a través de teorías científicas de complejidad.
  • Awesome Scalability :star: - Una lista de lectura actualizada y organizada para ilustrar los patrones de sistemas escalables, fiables y performant a gran escala. Los conceptos se explican en los artículos de ingenieros prominentes y referencias creíbles. Los estudios de casos son tomados de sistemas de prueba de batalla que sirven millones a miles de millones de usuarios.
  • AKF Scale Cube - Modelo que representa las dimensiones para escalar un servicio.
  • CALM :small_orange_diamond:PDF - Consistencia como monotónica lógica.
  • Canary Release - Técnica para reducir el riesgo de introducir una nueva versión de software en producción mediante la puesta en marcha lenta del cambio a un pequeño subconjunto de usuarios antes de lanzarla a toda la infraestructura y ponerla a disposición de todos.
  • CAP Theorem - Los Estados que es imposible que un sistema informático distribuido proporcione simultáneamente las tres de las siguientes garantías: Consistencia, disponibilidad y tolerancia a la partición.
  • Formal Foundations of Serverless Computing :small_orange_diamond:PDF - La abstracción sin servidor expone varios detalles operativos de bajo nivel que hacen difícil para los programadores escribir y razonar sobre su código. Este artículo arroja luz sobre este problema presentando λ, una semántica operativa de la esencia de la computación sin servidor.
  • Microservice Architecture - Una forma particular de diseñar aplicaciones de software como suites de servicios de despliegue independiente.
  • Microservices - From Design to Deployment :small_orange_diamond:PDF - La serie de siete partes de F5 sobre microservicios.
  • Microservices – Please, don’t - Asesoramiento crítico sobre algunos problemas relacionados con un enfoque de microservicios.
  • Microservices Trade-Offs - Guía para ponderar costos y beneficios del estilo arquitectónico de los mircoservicios.
  • Reactive Manifesto - Definición de sistemas reactiva.
  • Reactive Streams - Iniciativa para proporcionar un estándar para el procesamiento de secuencias asincrónicas con presión de retroceso sin bloqueo.
  • ROCAS :small_orange_diamond:PDF - Computación orientada a los recursos para sistemas de adaptación.
  • SECO :small_orange_diamond:PDF - Comprender los ecosistemas de software: un enfoque de modelado estratégico.
  • Testing Strategies in a Microservice Architecture - Enfoques para la gestión de la complejidad adicional de las pruebas de múltiples componentes independientemente implementables.
  • Your Server as a Function :small_orange_diamond:PDF - Describe tres abstracciones que se combinan para presentar un poderoso modelo de programación para construir software de servidor seguro, modular y eficiente: futuros, servicios y filtros composibles.

CC0

Por favor, lea el Contribution Guidelines antes de presentar su sugerencia.

Siéntete libre de open an issue o create a pull request con tus adiciones.

:star2: ¡Gracias!

HagiCode

HagiCode es un espacio de programación con agentes. Las interacciones de interfaz, ricas y cómodas, hacen que planificar, ejecutar agentes y trabajar en proyectos sea accesible y fácil de seguir, para una experiencia de desarrollo atractiva.

Una experiencia de desarrollo atractiva gracias a interacciones de interfaz ricas y cómodas.

Visitar HagiCodeLeer la documentación
  • InteligenteLos flujos de trabajo de OpenSpec convierten la intención en un itinerario ejecutable, de la propuesta al diseño, las tareas y la entrega.
  • EficienteLa ejecución multiagente avanza en paralelo con la investigación, la implementación y la revisión, en varios repositorios y con los Agent CLI que ya usas.
  • InteresanteLas interacciones de interfaz, ricas y cómodas, hacen que planificar, ejecutar agentes y trabajar en proyectos sea accesible y fácil de seguir.

Descargar para Windows

Obtenerlo en Microsoft StoreTodas las descargas

Convierte ideas en software entregado.

HagiCode es un espacio de trabajo de programación con agentes: los flujos de trabajo de OpenSpec planifican el cambio, la ejecución multiagente lo lleva a cabo y Hero Scenario hace visible el largo recorrido, para convertir ideas en software entregado.

Inteligente
Los flujos de OpenSpec convierten la intención en un camino de la propuesta a la entrega.
Eficiente
La ejecución multiagente avanza en paralelo con investigación, implementación y revisión.
Divertido
Las interacciones de interfaz facilitan la planificación, los agentes y el trabajo en proyectos.

¿Salir de Awesome Site?

Estás a punto de visitar un sitio web externo. No controlamos su contenido ni sus prácticas de privacidad.

Destino

Continuar al sitio web