Перейти к содержимому

Выберите язык

Текущий язык: Русский

Microservices

Source: https://github.com/mfornos/awesome-microservices at 417c83dc4de7
License: CC0-1.0
Read the English original

This edition is an AI-assisted translation.

Список принципов и технологий, связанных с микросервисной архитектурой.

Таблица содержимого

  • 1Backend Платформа микросервисов AI-native.
  • Jolie - Язык программирования, ориентированный на микросервисы с открытым исходным кодом.
  • OpenWhisk Безсерверная облачная платформа с открытым исходным кодом, которая выполняет функции в ответ на события любого масштаба.
  • Pulumi SDK для нативной облачной инфраструктуры в виде кода. Используйте свой любимый язык для предварительного просмотра и управления обновлениями ваших приложений и инфраструктуры, а также для постоянного развертывания в любом облаке.
  • Triton Платформа облачного управления с открытым исходным кодом, которая обеспечивает инфраструктуру следующего поколения на основе контейнеров и услуг в одном или нескольких центрах обработки данных.
  • Akka Инструментарий и время выполнения для создания высококонкурентных, распределенных и устойчивых приложений, управляемых сообщениями, на JVM.
  • Axon (c) Сквозная платформа разработки и инфраструктуры для легкой разработки и запуска любых приложений DDD, CQRS и Event Sourcing на JVM.
  • Ballerina Облачный родной язык программирования.
  • Bun - Быстрое время выполнения JavaScript “все в одном”.
  • Dapr Среда выполнения с открытым исходным кодом для написания высокопроизводительных микросервисов с использованием любого языка программирования.
  • Deno JavaScript, TypeScript и WebAssembly с безопасными по умолчанию и отличным опытом разработчика.
  • Eclipse Microprofile Открытый форум для оптимизации Enterprise Java для архитектуры микросервисов путем внедрения инноваций в нескольких реализациях и сотрудничества в общих областях интересов с целью стандартизации.
  • Erlang/OTP Язык программирования, используемый для построения масштабируемых мягких систем реального времени с требованиями высокой доступности.
  • Finagle Расширяемая система RPC для JVM, используемая для создания высококонкурентных серверов.
  • Gleam Дружелюбный язык для построения безопасных, масштабируемых систем.
  • GraalVM Высокопроизводительное время выполнения, которое обеспечивает значительное улучшение производительности и эффективности приложений, что идеально подходит для микросервисов.
  • Helidon Коллекция библиотек Java для написания микросервисов, которые работают на быстром веб-ядре, работающем на Netty.
  • Ice - Комплексный RPC фреймворк с поддержкой C++, C#, Java, JavaScript, Python и многое другое.
  • Light-4j Высокая пропускная способность, низкая задержка, небольшой объем памяти и более продуктивная платформа микросервисов.
  • Micronaut - Современный, основанный на JVM, полнотекстовый фреймворк для создания модульных, легко тестируемых приложений микросервисов.
  • Moleculer Быстрые и мощные микросервисы для Node.js, Java, Go и Ruby.
  • Open Liberty Легкий открытый фреймворк для создания быстрых и эффективных облачных микросервисов Java.
  • Pears - Одноранговое время выполнения, разработка и развертывание.
  • SmallRye API и реализации, адаптированные для облачной разработки, включая Eclipse MicroProfile.
  • Spin - фреймворк с открытым исходным кодом для создания и запуска быстрых, безопасных и композитных облачных микросервисов с помощью WebAssembly.
  • ScaleCube - Инструментарий для создания реактивных микросервисов для СПМ: малозадержка, высокая пропускная способность, масштабируемость и устойчивость.
  • Vert.X - Инструментарий для создания реактивных приложений на СПМ.
  • Vert.X Toolbox Набор компонентов Vert.x для создания реактивных приложений микросервисов.
  • Wangle - фреймворк, обеспечивающий набор общих абстракций клиента/сервера для построения услуг последовательным, модульным и композитным способом.
  • GRPC Высокая производительность, открытый исходный код, общий RPC фреймворк, который ставит на первое место мобильный и HTTP/2. Библиотеки на C, C++, Java, Go, Node.js, Python, Ruby, Objective-C, PHP и C#.
  • Lwan Высокопроизводительный и масштабируемый веб-сервер.
  • uSockets - Скромное кросс-платформенное событие, сеть и криптография для приложений асинхронизации.
  • Cap’n Proto RPC - Реализация Cap’n Proto C++ RPC.
  • C++ Micro Services OSGi-подобная система динамических модулей C++ и реестр служб.
  • Enduro/X - Основы XATMI для GNU/Linux.
  • Pistache Высокопроизводительный инструментарий REST, написанный на C++.
  • Poco Библиотеки классов C++ для создания сетевых приложений и серверов.
  • Sogou Workflow - Программный движок корпоративного уровня, предназначенный для удовлетворения большинства требований к разработке бэкэнда.
  • uWebSockets Простой, безопасный и соответствующий стандартам веб-сервер для самых требовательных приложений.
  • Awesome Microservices .NET Core :star: Коллекция удивительных учебных серий, статей, видео, книг, курсов, образцовых проектов и инструментов для микросервисов в .NET Core.
  • Vibe.d - Асинхронный I/O, который не мешает вам, написанный на D.
  • Phoenix - Framework для создания приложений HTML5, бэкэндов API и распределенных систем.
  • Plug Спецификация и удобства для композитных модулей между веб-приложениями.
  • Cowboy Небольшой, быстрый, модульный HTTP-сервер, написанный на Erlang.
  • Mochiweb Библиотека Erlang для создания легких HTTP-серверов.
  • Chi Легкий, идиоматический и композитный маршрутизатор для создания сервисов Go HTTP.
  • Echo Быстрый и непривлекательный фреймворк HTTP-сервера для Go. До 10 раз быстрее остальных.
  • Fiber - Вдохновленный Express веб-фреймворк, построенный поверх Fasthttp, самого быстрого HTTP-движка для Go. Разработан, чтобы облегчить работу для быстрой разработки с нулевым распределением памяти и производительностью.
  • Gin Gin - это веб-фреймворк HTTP, написанный на Go (Golang). Он оснащен API, похожим на Martini, с гораздо лучшей производительностью, до 40 раз быстрее.
  • Goa Дизайнерские HTTP-микросервисы в Go.
  • GoFr - Модели разработки микросервисов с акцентом на масштабируемость и надежность. Предназначен для упрощения разработки микросервисов.
  • Go Chassis Рамки для быстрого развития микросервисов в Go, которые легко интегрировать с некоторыми облачными экосистемами.
  • Go-micro - Рамки разработки распределенных систем.
  • Go-zero - фреймворк разработки распределенных систем Web и rpc.
  • Gorilla Веб-инструментарий для языка программирования Go.
  • Iris Быстрый, простой и эффективный микро-фреймворк для Go.
  • Lura - Framework для создания ультрапроизводительных API Gateways с промежуточной программой.
  • RPCX Распределенная платформа RPC, основанная на NET/RPC, таких как Alibaba Dubbo и Weibo Motan.
  • Scotty Микро-фреймворк, вдохновленный Sinatra от Ruby, с использованием WAI и Warp.
  • Servant - Web DSL на уровне типов.
  • Yesod Haskell RESTful Web Framework.
  • Compojure - Краткая библиотека маршрутизации для Ring/Clojure.
  • Duct - фреймворк на стороне сервера для Clojure.
  • System Построенный поверх библиотеки компонентов Стюарта Сьерры, предлагает набор готовых компонентов.
  • Tesla - Общая основа для некоторых микросервисов Otto.de Clojure.
  • ActiveJ Легкая и быстрая библиотека для сложных высоконагруженных распределенных приложений и решений, подобных Memcached.
  • Airlift Рамки для построения REST-сервисов на Java.
  • Armeria - Асинхронная библиотека HTTP/2 RPC/REST клиент/сервер с открытым исходным кодом, построенная поверх Java 8, Netty, Thrift и gRPC.
  • Disruptor Высокопроизводительная межпоточная библиотека сообщений.
  • Dropwizard Java Framework для разработки ops-дружественных, высокопроизводительных, RESTful веб-сервисов.
  • Dubbo Высокопроизводительный, основанный на Java фреймворк RPC с открытым исходным кодом от Alibaba.
  • Conjure - Утвержденный набор библиотек для определения и создания серверов и клиентов RESTish/RPC на основе Feign или Retrofit в качестве клиента и Dropwizard/Jersey с определениями сервиса JAX-RS в качестве сервера.
  • Jersey - RESTful services in Java. JAX-RS reference implementation.
  • Quarkus - А Kubernetes Нативный стек Java, адаптированный для OpenJDK HotSpot и GraalVM, созданный из лучших библиотек и стандартов Java.
  • Ratpack Набор библиотек Java, которые облегчают быстрые, эффективные, эволюционируемые и хорошо протестированные HTTP-приложения. Оказана конкретная поддержка языка Гроовы.
  • Spring Boot - Упрощает создание автономных приложений на основе Spring производственного класса.
  • Http4k Легкий, но полнофункциональный инструментарий HTTP, написанный в чистом Kotlin, который позволяет обслуживать и потреблять HTTP-сервисы функционально и последовательно.
  • Ktor Структура для построения асинхронных серверов и клиентов в подключенных системах с использованием языка программирования Kotlin.
  • Finatra Быстрые, тестируемые, Scala HTTP-сервисы, построенные на Twitter-Server и Finagle.
  • Http4s Минимальный идиоматический интерфейс Scala для HTTP
  • Play Высокоскоростной веб-фреймворк для Java и Scala.
  • Actionhero Многотранспортный API-сервер Node.js с интегрированными кластерными возможностями и отложенными задачами.
  • Express Быстрый, непредвзятый, минималистичный веб-фреймворк для Node.js
  • Fastify Fastify, Fast and Low Overhead Web Framework для Node.js.
  • FeathersJS Открытый уровень REST и API в реальном времени для современных приложений.
  • Hono - Маленький, простой и сверхбыстрый веб-фреймворк для Эджеса. Работает на любом JavaScript Runtime.
  • Koa Веб-фреймворк нового поколения для Node.js
  • Loopback - Node.js фреймворк для создания API и легкого подключения к бэкэнд-источникам данных.
  • NestJS - фреймворк Node.js для создания эффективных и масштабируемых серверных приложений со встроенной поддержкой микросервисов.
  • Seneca Инструментарий микросервисов для Node.js
  • Serverless Создание и поддержка веб-приложений, мобильных приложений и IoT, работающих на AWS Lambda и API Gateway (ранее известный как JAWS).
  • tRPC - Сквозные безопасные API.
  • Cro Библиотеки для создания реактивных распределенных систем с использованием Perl 6.
  • Mojolicious - Веб-фреймворк следующего поколения для Perl.
  • API Platform - API-интерфейс поверх Symfony с поддержкой JSON-LD, Schema.org и Hydra.
  • Ecotone Структура, основанная на архитектурных принципах DDD, CQRS и Event Sourcing, которая обеспечивает строительные блоки для создания масштабируемых и расширяемых приложений.
  • Hyperf Hyperf - чрезвычайно эффективный и гибкий PHP CLI фреймворк, основанный на Swoole 4.5+, оснащенный самым современным сервером и большим количеством проверенных в бою компонентов.
  • Lumen Потрясающе быстрый микрофреймворк.
  • Slim Микро-фреймворк, который помогает быстро писать простые, но мощные веб-приложения и API.
  • Spiral - фреймворк, предназначенный для долгосрочных приложений, использующих RoadRunnerОн предлагает расширенные функции, такие как интеграция с Temporal двигатель рабочего процесса и Centrifugo Websocket сервер. Он особенно эффективен для архитектуры микросервисов, обеспечивая надежную поддержку REST API и сервисов gRPC.
  • Swoft - PHP microservices coroutine framework для создания высокопроизводительных веб-систем, API, промежуточного ПО и базовых сервисов.
  • Symfony Микро-фреймворк на основе компонентов Symfony.
  • Aiohttp HTTP-клиент/сервер для Asyncio.
  • Bottle Быстрый, простой и легкий WSGI микро-фреймворк для Python.
  • Connexion - фреймворк Swagger/OpenAPI для Python поверх Flask с автоматической валидацией конечных точек и поддержкой OAuth2.
  • Falcon Bare-metal Python Web API Framework для создания очень быстрых бэкэндов приложений и микросервисов.
  • FastAPI Современный, быстрый (высокопроизводительный), веб-фреймворк для создания API с Python 3.6+ на основе стандартных подсказок типа Python.
  • Flask Python Framework для микросервисов на основе Werkzeug и Jinja 2.
  • Nameko Python Framework для создания микросервисов.
  • Sanic Sanic - это веб-сервер Python 3.5 +, похожий на Flask, который написан для быстрого запуска.
  • Tornado - Веб-фреймворк и асинхронная сетевая библиотека.
  • Twisted - движок сетевого программирования, управляемый событиями.
  • Web.py Минималистическая веб-фреймворк для Python.
  • Grape - Мотивированная структура для создания REST-подобных API
  • Hanami Современный веб-фреймворк для Ruby.
  • Praxis - Рамки для проектирования и реализации API.
  • Scorched Легкий веб-фреймворк для Ruby.
  • Sinatra Sinatra - это DSL для быстрого создания веб-приложений в Ruby с минимальными усилиями.
  • Are we web yet? :star: Резюме текущего состояния веб-программирования в Rust.
  • Actix Мощный, прагматичный и чрезвычайно быстрый веб-фреймворк для Rust.
  • Tarpc - Рамки RPC для Rust с акцентом на простоту использования.
  • Tokio - Асинхронное время выполнения для написания сетевых приложений.
  • Tower Библиотека модульных и многоразовых компонентов для создания надежных сетевых клиентов и серверов.
  • Wtx - HTTP/2 клиент/сервер.
  • Awesome Micro Frontends :star: Список ресурсов о Micro Frontends.
  • Electrode - Прикладная платформа Universal React/Node.js.
  • Micro Frontends Расширение идеи микросервиса до фронтенд-разработки.
  • MiniApp White Paper - Белая книга стандартизации MiniApp.
  • Ambassador (c) - KubernetesНативный API шлюз для микросервисов, построенный на Envoy.
  • Apache APISIX Высокопроизводительный шлюз API в реальном времени и шлюз AI, построенный на NGINX и т. Д., С горячей перезагрузкой маршрутизации и 100+ плагинов.
  • APIcast APIcast - это шлюз API, построенный поверх NGINX. Он является частью платформы управления API Red Hat 3scale.
  • Bunker Web Веб-хостинг приложений и обратный прокси по умолчанию.
  • Caddy Расширяемый веб-сервер HTTP/2 с автоматическим HTTPS.
  • Camel - Позволяет вам определять правила маршрутизации и посредничества в различных доменных языках, включая Java-ориентированный API, файлы конфигурации Spring или Blueprint XML и Scala DSL.
  • Envoy - Open Source edge и сервисный прокси от разработчиков Lyft.
  • HAProxy Надежный высокопроизводительный балансировщик нагрузки TCP/HTTP.
  • Istio Открытая платформа для подключения, управления и защиты микросервисов.
  • Keepalived Простые и надежные средства для балансировки нагрузки и высокой доступности систем Linux и инфраструктур на основе Linux.
  • Kong Уровень управления с открытым исходным кодом для API.
  • KrakenD Открытый исходный код Ultra Performance API Gateway.
  • Kuma - Агностическая плоскость управления с открытым исходным кодом платформы для сервисных сеток и микросервисов.
  • Linkerd - Устойчивая сервисная сетка для нативных облачных приложений.
  • Neutrino - Расширяемый программный балансировщик нагрузки.
  • OpenResty Быстрый сервер веб-приложений, построенный поверх Nginx.
  • Open Service Mesh - Легкая и расширяемая облачная нативная сервисная сетка.
  • Otoroshi Современный HTTP-прокси с легким управлением API.
  • Pingora Библиотека для создания быстрых, надежных и эволюционируемых сетевых сервисов.
  • Skipper HTTP-маршрутизатор полезен для отсоединения маршрутизации от логики обслуживания.
  • Spring Cloud Gateway API Gateway на вершине Spring MVC Цель состоит в том, чтобы обеспечить простой, но эффективный способ маршрутизации к API.
  • Tengine Распределение Nginx с некоторыми расширенными функциями.
  • Træfɪk Современный HTTP-прокси-сервер и балансировщик нагрузки, предназначенный для легкого развертывания микросервисов.
  • Traffic Server Высокопроизводительный строительный блок для облачных сервисов.
  • Tyk - Открытый исходный код, быстрый и масштабируемый API шлюз, портал и платформа управления API.
  • Vulcand - Программный балансировщик нагрузки, поддерживаемый Etcd.
  • Zuul - edge сервис, который обеспечивает динамическую маршрутизацию, мониторинг, отказоустойчивость, безопасность и многое другое.
  • Central Dogma - Репозиторий конфигурации служб с открытым исходным кодом, управляемый версиями, основанный на Git, ZooKeeper и HTTP/2.
  • Consul - Обнаружение и конфигурация сервиса упростились. Распределенный, высокодоступный и осведомленный о центрах обработки данных.
  • Etcd Высокодоступный магазин ключей для общей конфигурации и обнаружения сервисов.
  • Eureka Сервис на основе REST, который в основном используется в облаке AWS для поиска сервисов с целью балансировки нагрузки и отказа серверов среднего уровня.
  • Microconfig Современный и простой способ управления конфигурацией микросервиса.
  • Nacos - Удобная в использовании динамическая платформа обнаружения, настройки и управления услугами.
  • SkyDNS Распределенный сервис для объявления и обнаружения сервисов, построенных поверх и т.д. Он использует DNS-запросы для поиска доступных сервисов.
  • Spring Cloud Config Обеспечивает серверную и клиентскую поддержку экстернализованной конфигурации в распределенной системе.
  • ZooKeeper Сервер с открытым исходным кодом, который обеспечивает высоконадежную распределенную координацию.
  • AWS Step Functions (c) Координировать компоненты распределенных приложений и микросервисов с помощью визуальных рабочих процессов.
  • Cadence - Неисправно забытая государственная кодовая платформа.
  • Conductor - Механизм оркестровки микросервисов.
  • Inngest Прочные функции для надежной фоновой логики, от фоновых заданий до сложных рабочих процессов.
  • Kestra - Микросервисы с открытым исходным кодом, ориентированные на события, языковая агностическая оркестровка и платформа планирования.
  • Temporal Платформа оркестровки микросервисов с открытым исходным кодом для запуска критического кода миссии в любом масштабе.
  • Zeebe Определение, организация и мониторинг бизнес-процессов в микросервисах.
  • Hazelcast - Сетка данных с открытым исходным кодом. Позволяет распределять данные и вычисления между серверами, кластерами и географическими регионами, а также управлять очень большими наборами данных или высокими показателями потребления данных. Зрелые технологии.
  • Helix Общие рамки управления кластерами, используемые для автоматического управления разделяемыми, реплицируемыми и распределенными ресурсами, размещенными на кластере узлов.
  • Ignite Высокопроизводительная, интегрированная и распределенная платформа in-memory для вычислений и транзакций на крупномасштабных наборах данных в режиме реального времени, на порядок быстрее, чем это возможно с традиционными дисковыми или флэш-технологиями.
  • Libp2p - фреймворк и набор протоколов для создания одноранговых сетевых приложений.
  • Mesos Абстракты процессора, памяти, хранения и других вычислительных ресурсов от машин (физических или виртуальных), что позволяет легко создавать и эффективно работать отказоустойчивым и эластичным распределенным системам.
  • Nomad Распределенный, высокодоступный, осведомленный о центрах обработки данных планировщик.
  • Redisson Распределенные и масштабируемые структуры данных Java поверх сервера Redis.
  • Serf Децентрализованное решение для членства в кластере, обнаружения отказов и оркестровки.
  • Valkey Новый проект по возобновлению разработки проекта Redis с открытым исходным кодом.
  • Zenoh Протокол Pub/sub/query, объединяющий данные в движении, данные в покое и вычисления. Эффективно смешивает традиционный паб с геораспределенным хранилищем, запросами и вычислениями.

Расписание рабочих мест / Автоматизация рабочей нагрузки

Заголовок раздела «Расписание рабочих мест / Автоматизация рабочей нагрузки»
  • Celery Асинхронная очередь задач / очередь работы на основе распределенной передачи сообщений. Сосредоточен на работе в режиме реального времени и поддерживает планирование.
  • Dkron Распределенная, отказоустойчивая система планирования работы.
  • Faktory Языко-агностический постоянный фоновый сервер.
  • Rundeck (c) - Планировщик работы и автоматизация ручек. Обеспечить доступ к существующим скриптам и инструментам самообслуживания.
  • Schedulix Система планирования рабочих мест с открытым исходным кодом устанавливает новаторские стандарты для профессиональной автоматизации ИТ-процессов в передовых системных средах.
  • mirrord Запускайте локальный код, как если бы он был стручкой в пульте Kubernetes кластер.
  • Fluentd - Сбор данных с открытым исходным кодом для унифицированного слоя регистрации.
  • Graylog Полностью интегрированная платформа управления журналами с открытым исходным кодом.
  • Kibana Гибкая платформа аналитики и визуализации.
  • LogDNA (c) - Централизованное программное обеспечение для управления журналами. Мгновенный сбор, централизация и анализ журналов в режиме реального времени с любой платформы, в любом объеме.
  • Logstash - Инструмент для управления событиями и журналами.
  • Loki - Как Прометей, только для бревен.
  • ØMQ - Без брокеров интеллектуальный транспортный слой.
  • ActiveMQ Мощный сервер с открытым исходным кодом и шаблонами интеграции.
  • Aeron Эффективная надежная передача сообщений UDP unicast, UDP multicast и IPC.
  • Beanstalk - Простая, быстрая очередь.
  • Bull Быстрая и надежная очередь на основе Redis для Node.
  • Crossbar Сетевая платформа с открытым исходным кодом для распределенных и микросервисных приложений. Он реализует открытый протокол обмена сообщениями веб-приложений (WAMP).
  • Kafka - Переосмысление сообщений Publish-subscribe в виде распределенного журнала фиксации.
  • Malamute - Брокер корпоративных сообщений ZeroMQ.
  • Mosquitto Брокер сообщений с открытым исходным кодом, который реализует протокол MQTT.
  • NATS Открытый исходный код, высокопроизводительная, легкая облачная система обмена сообщениями.
  • NSQ Распределенная платформа обмена сообщениями в реальном времени.
  • Pulsar - Распределенная система обмена сообщениями.
  • RabbitMQ - Брокер сообщений на основе Erlang с открытым исходным кодом, который просто работает.
  • Redpanda Платформа потоковых данных для разработчиков: Kafka API совместима, в 10 раз быстрее, без ZooKeeper и без JVM.
  • RocketMQ Низкая задержка, надежное, масштабируемое, простое в использовании промежуточное ПО, ориентированное на сообщения, рожденное в крупном бизнесе обмена сообщениями alibaba.
  • Beats Легкие грузоотправители для Elasticsearch & Logstash.
  • Elastalert Простое и гибкое оповещение для Elasticsearch.
  • Ganglia Масштабируемая распределенная система мониторинга для высокопроизводительных вычислительных систем, таких как кластеры и сетки.
  • Grafana - Открытый исходный код, с богатой метрической панелью приборов и графическим редактором для Graphite, InfluxDB и OpenTSDB.
  • Graphite - Масштабируемый график в реальном времени.
  • IOpipe (c) Контроль производительности приложений для Amazon Lambda.
  • Jaeger - Сквозное распределенное отслеживание с открытым исходным кодом
  • OpenTelemetry Высококачественная, вездесущая и портативная телеметрия для обеспечения эффективной наблюдаемости.
  • Prometheus - Система мониторинга служб с открытым исходным кодом и база данных временных рядов.
  • Riemann Мониторинг распределенных систем.
  • Sensu - Мониторинг современной инфраструктуры.
  • SkyWalking - инструмент мониторинга производительности приложений для распределенных систем, особенно предназначенный для микросервисов, облачных и контейнерных (Docker, K8sМесос) Архитектура.
  • Zabbix - Открытое решение для мониторинга корпоративного класса.
  • Zipkin - Распределенная система отслеживания.
  • Arroyo Распределенный механизм обработки потоков для преобразования, фильтрации, агрегирования и объединения потоков данных путем написания SQL.
  • Reactor.io Реактивная библиотека второго поколения для создания неблокирующих приложений на JVM на основе спецификации реактивных потоков.
  • Reactive Kafka API реактивных потоков для Apache Kafka
  • ReactiveX API для асинхронного программирования с наблюдаемыми потоками. Доступен для идиоматических Java, Scala, C#, C++, Clojure, JavaScript, Python, Groovy, JRuby и других.
  • RSocket Протокол приложения, обеспечивающий семантику реактивных потоков.
  • Awesome Chaos Engineering :star: Список удивительных инженерных ресурсов хаоса.
  • Raft Consensus Алгоритм консенсуса, разработанный, чтобы его было легко понять. Это эквивалентно Paxos в отказоустойчивости и производительности.
  • Resilience4j Библиотека отказоустойчивости, предназначенная для Java8 и функционального программирования.
  • Svix - Сервис Webhooks, который отправляет веб-хуки вашим пользователям с полным графиком повторных попыток, экспоненциальным обратным выключением, проверкой подписи и типами событий.
  • Cerbos Hub Система управления авторизацией для разработки, тестирования и развертывания политик доступа. Построенная масштабируемая, мелкозернистая авторизация в архитектуре микросервиса.
  • Dex - Предполагаемая услуга auth/directory с подключаемыми разъемами. Поставщик OpenID Connect и сторонняя делегация OAuth 2.0.
  • JWT JSON Web Tokens - это открытый отраслевой стандарт RFC 7519 для безопасного представления претензий между двумя сторонами.
  • Keycloak - Полнофункциональный и расширяемый сервис auth. Поставщик OpenID Connect и сторонняя делегация OAuth 2.0.
  • OAuth - Обеспечивает конкретные потоки авторизации для веб-приложений, настольных приложений, мобильных телефонов и устройств гостиной. Много реализаций.
  • OpenID Connect Библиотеки, продукты и инструменты, реализующие текущие спецификации OpenID и соответствующие спецификации.
  • Open Ziti Zero Trust Security и Overlay Networking как чистое программное обеспечение с открытым исходным кодом.
  • ORY Инфраструктура и услуги идентификации с открытым исходным кодом.
  • OWASP Agent Memory Guard Слой защиты от отравления памятью агента ИИ (OWASP ASI06). Обнаруживает подделанные записи памяти, быструю инъекцию в пути памяти и секретную утечку. Политика YAML, микросекундная задержка, нулевая внешняя зависимость.
  • SCIM - Система управления кросс-доменами.
  • Vault Защищает, хранит и жестко контролирует доступ к токенам, паролям, сертификатам, ключам API и другим секретам в современных вычислениях.
  • Avro Система сериализации данных Apache, обеспечивающая богатые структуры данных в компактном, быстром, двоичном формате данных.
  • Bond Кроссплатформенный фреймворк для работы со схематизированными данными, широко используемый в Microsoft в крупномасштабных сервисах.
  • BooPickle Бинарная библиотека сериализации для эффективной сетевой связи. Для Scala и Scala.js
  • Cap’n Proto Безумно быстрый формат обмена данными и система RPC на основе возможностей.
  • CBOR Реализация стандарта CBOR (RFC 7049) на многих языках.
  • Cereal Библиотека C++11 для сериализации.
  • Cheshire Clojure JSON и JSON SMILE кодирование/декодирование.
  • Etch Кроссплатформенная, языковая и транспортно-независимая структура для построения и потребления сетевых услуг.
  • Fastjson - Быстрый процессор JSON.
  • Ffjson Быстрая сериализация JSON для Go.
  • FST - Быстрое снижение серийности Java.
  • Jackson Многоцелевая библиотека Java для обработки формата данных JSON.
  • Jackson Afterburner - модуль Джексона, который использует генерацию байт-кода для дальнейшего ускорения связывания данных (+30-40% пропускной способности для сериализации, десериализации).
  • Kryo Сериализация и клонирование Java: быстро, эффективно, автоматически.
  • Lite³ JSON-совместимый формат сериализации с нулевой копией.
  • MessagePack Эффективный формат бинарной сериализации.
  • Protostuff Библиотека сериализации со встроенной поддержкой обратной совместимости (эволюция схемы) и валидации.
  • SBinary Библиотека для описания двоичных форматов для типов Scala.
  • Thrift - Apache Thrift программный фреймворк для масштабируемой кросс-языковой разработки сервисов.
  • yyjson - Самая быстрая библиотека JSON в Си.
  • Apache Cassandra Колонно-ориентированный и обеспечивающий высокую доступность без единой точки отказа.
  • Aerospike (c) - Высокопроизводительная база данных NoSQL, обеспечивающая скорость в масштабе.
  • ArangoDB Распределенная бесплатная и открытая база данных с гибкой моделью данных для документов, графиков и ключевых значений.
  • Citus Распределенный PostgreSQL как расширение.
  • CockroachDB (c) База данных SQL, созданная по модели Google Spanner.
  • Couchbase Распределенная база данных, спроектированная для производительности, масштабируемости и упрощенного администрирования.
  • Crate (c) Масштабируемая база данных SQL с лакомствами NoSQL.
  • Druid - Быстрый колонно-ориентированный распределенный хранилище данных.
  • Elasticsearch Распределенный, масштабируемый и высокодоступный поисковый сервер с открытым исходным кодом.
  • Geode - Открытый исходный код, распределенная база данных в памяти для масштабируемых приложений.
  • Infinispan - Высокосовременный хранилище данных ключа/значения, используемое для кэширования.
  • InfluxDB Масштабируемое хранилище данных для метрик, событий и аналитики в реальном времени.
  • RethinkDB Открытый исходный код, масштабируемая база данных, которая облегчает создание приложений в реальном времени.
  • TiKV Распределенная транзакционная база данных ключевых значений.
  • TimescaleDB База данных временных рядов для высокопроизводительной аналитики в реальном времени, упакованная в виде расширения Postgres.
  • Trino Быстрый распределенный механизм SQL-запроса для анализа больших данных, который поможет вам исследовать вселенную данных.
  • Goreplay Инструмент для захвата и воспроизведения реального HTTP-трафика в тестовой среде.
  • Keploy Инструмент с открытым исходным кодом для тестирования API и макетирования путем захвата реального трафика и преобразования его в тестовые кейсы и заглушки, что позволяет проводить надежное тестирование микросервисов.
  • Mitmproxy Интерактивная консольная программа, которая позволяет перехватывать, проверять, изменять и воспроизводить потоки трафика.
  • MockServer - Пересматривание, отладка прокси-сервера и инжиниринг хаоса для нескольких протоколов (HTTP, gRPC, GraphQL, LLM, MCP, Kafka, TCP и т. Д.); Имитация зависимостей, запись / воспроизведение трафика, проверка запросов и ввод неисправностей для интеграции и тестирования устойчивости.
  • Mountebank - Кроссплатформенный, многопротокольный тест удваивается по проводу.
  • Pact - Контрактное тестирование для HTTP API и не-HTTP асинхронных систем обмена сообщениями.
  • RestQA Инструмент для управления макетированием микросервисов, тестированием юнитов и производительности локально с лучшим опытом разработчика в классе.
  • Specmatic Преобразует спецификации API (OpenAPI, AsyncAPI, GraphQL, gRPC и т.д.) в исполняемые контракты для автоматизированного тестирования, виртуализации услуг и проверки обратной совместимости без написания кода.
  • VCR Записывайте HTTP-взаимодействия вашего набора тестов и воспроизводите их во время будущих тестов для быстрых, детерминированных и точных тестов. Список портов для реализации на других языках.
  • Wilma Комбинированное решение HTTP/HTTPS и прозрачное прокси-решение.
  • WireMock Гибкая библиотека для перетаскивания и насмешки веб-сервисов. В отличие от инструментов общего назначения, он работает, создавая фактический HTTP-сервер, к которому ваш тестируемый код может подключаться, как к реальному веб-сервису.
  • Hoverfly Легкий сервис виртуализации / инструмент моделирования API для разработчиков и тестеров.
  • Awesome CI/CD DevOps :star: Список удивительных инструментов для непрерывной интеграции, непрерывной доставки и DevOps.
  • AsyncAPI - спецификация AsyncAPI, отраслевой стандарт для определения асинхронных API.
  • GraphQL Язык запросов, предназначенный для создания клиентских приложений, предоставляя интуитивно понятный и гибкий синтаксис и систему для описания требований к данным и взаимодействий.
  • JSON:API Спецификация того, как клиент должен запрашивать, чтобы ресурсы были извлечены или изменены, и как сервер должен отвечать на эти запросы.
  • API Blueprint Инструменты для всего жизненного цикла API. Используйте его, чтобы обсудить свой API с другими. Создавайте документацию автоматически. Или набор для испытаний. Или даже какой-то код.
  • OpenAPI Спецификация OpenAPI (OAS) обеспечивает последовательное средство для передачи информации на каждом этапе жизненного цикла API.
  • RAML Язык моделирования RESTful API, простой и лаконичный способ описания практически RESTful API.
  • ReDoc OpenAPI/Swagger-generated API Документация.
  • Scalar Платформа API с открытым исходным кодом: красивые ссылки на API и поддержка OpenAPI / Swagger 1-го класса.
  • Slate Прекрасная статическая документация для вашего API.
  • Spring REST Docs Документы RESTful услуги путем объединения рукописной документации с автоматически генерируемыми фрагментами, произведенными с Spring MVC Test.
  • Swagger Простое, но мощное представление вашего RESTful API.
  • W3C.REC-Webarch Архитектура Всемирной паутины, том первый.
  • RFC3986 Унифицированный идентификатор ресурса (URI): общий синтаксис.
  • RFC6570 - Шаблон УРИ.
  • RFC7320 URI дизайн и собственность.
  • DID W3C спецификация децентрализованных идентификаторов (DID): новый тип идентификатора, который позволяет проверять децентрализованную цифровую идентификацию.
  • DIDComm - Методология частной коммуникации, построенная на основе децентрализованного дизайна DID.
  • DIDComm Protocols Реестр протоколов, построенных на DIDComm, для высоконадежных, самоуправляющихся взаимодействий на любом транспорте.
  • IDSA Международная Ассоциация Пространств Данных (IDSA) ставит перед собой задачу создать будущее глобальной цифровой экономики с Международными Пространствами Данных (IDS), безопасной, суверенной системой обмена данными, в которой все участники могут реализовать всю ценность своих данных.
  • RFC7230 - Синтаксис сообщений и маршрутизация.
  • RFC7231 Семантика и содержание.
  • RFC7232 - Условные запросы.
  • RFC7233 - Запросы на диапазон.
  • RFC7234 - Кеширование.
  • RFC7235 - Аутентификация.
  • RFC7807 Детали проблемы для HTTP API.
  • RFC7540 Протокол передачи гипертекста версии 2.
  • QUIC-WG Рабочая группа IETF, которая зафрахтована для доставки следующего транспортного протокола для Интернета.
  • QUIC-Transport - мультиплексный и безопасный транспорт на основе UDP.
  • JSON-RPC 2.0 - Протокол дистанционного вызова процедур (RPC) без состояния.
  • Open RPC Спецификация OpenRPC определяет стандартное описание языков программирования для API JSON-RPC 2.0.
  • AMQP - Расширенный протокол очередей сообщений.
  • MQTT - Телеметрический транспорт MQ.
  • STOMP Простой протокол текстовых сообщений.
  • GNAP Протокол о переговорах и разрешении грантов определяет механизм делегирования разрешения части программного обеспечения и передачи этой делегации в программное обеспечение. Эта делегация может включать в себя доступ к набору API, а также информацию, передаваемую непосредственно программному обеспечению.ДРАФТ
  • OIDCONN OpenID Connect 1.0 - это простой уровень идентификации поверх протокола OAuth 2.0. Он позволяет клиентам проверять личность конечного пользователя на основе аутентификации, выполняемой сервером авторизации, а также получать базовую информацию о профиле конечного пользователя в совместимой и REST-подобной манере.
  • PASETO Paseto - это все, что вам нравится в JOSE (JWT, JWE, JWS) без каких-либо недостатков дизайна, которые мешают стандартам JOSE. ДРАФТ
  • RFC5246 Протокол безопасности транспортного уровня (TLS) Версия 1.2.
  • RFC6066 - Расширения TLS.
  • RFC6347 Datagram Transport Layer Security Версия 1.2.
  • RFC6749 Основы авторизации OAuth 2.0.
  • RFC6962 - Прозрачность сертификата.
  • RFC7515 JSON Web Signature (JWS) представляет собой контент, защищенный цифровыми подписями или кодами аутентификации сообщений (MAC) с использованием структур данных на основе JSON.
  • RFC7519 JSON Web Token (JWT) - это компактный, безопасный для URL способ представления претензий, которые передаются между двумя сторонами.
  • RFC7642 SCIM: Определения, обзор, концепции и требования.
  • RFC7643 SCIM: Core Schema, обеспечивает нейтральную схему платформы и модель расширения для представления пользователей и групп.
  • RFC7644 SCIM: Протокол, протокол уровня приложений, REST для предоставления и управления идентификационными данными в Интернете.
  • DNS-SD - Механизм обнаружения клиентами списка именованных экземпляров сервиса с использованием стандартных DNS-запросов.
  • RFC2782 DNS RR для определения местоположения служб (DNS SRV).
  • RFC4627 JavaScript Object Notation (JSON).
  • RFC7049 Краткое представление бинарных объектов (CBOR).
  • BSON Бинарный JSON (BSON).
  • JSON-LD JSON для связывания данных.
  • SBE Простое двоичное кодирование (SBE).
  • MSGPACK Спецификация MessagePack.
  • JSON Schema Словарь, который позволяет аннотировать и проверять документы JSON.
  • Schema.org Совместная деятельность сообщества с миссией по созданию, поддержанию и продвижению схем структурированных данных в Интернете, на веб-страницах, в сообщениях электронной почты и за ее пределами.
  • UNIV8 - Консорциум Unicode. Unicode Standard, Version 8.0.0, (Mountain View, CA: The Unicode Consortium, 2015. ISBN 978-1-936213-10-8).
  • RFC3629 - UTF-8, формат преобразования ISO 10646.
  • How Do Committees Invent? :small_orange_diamond:PDF Мелвин Э. Конвей, журнал Datamation 1968. Оригинальное название: Conway’s Law.
  • Service per Team Каждая команда отвечает за одну или несколько бизнес-функций (например, бизнес-возможности). Команда владеет кодовой базой, состоящей из одного или нескольких модулей. Его кодовая база имеет размер, не превышающий когнитивные способности команды. Команда использует свой код в качестве одной или нескольких служб. Команда должна иметь ровно одну услугу, если нет доказанной необходимости иметь несколько услуг.
  • Start with Team Cognitive Load - Team Topologies :small_red_triangle:YT - В Лондоне 19. Дискуссия «Монолит против микросервисов» часто фокусируется на технологических аспектах, игнорируя стратегию и командную динамику. Вместо технологий умные организации начинают с командной когнитивной нагрузки в качестве руководящего принципа для современного программного обеспечения. В этом выступлении мы объясним, как и почему, на примере реальных тематических исследований.
  • Commercetools - Торговая платформа без головы.
  • Equinox Infosys Equinox - это ориентированная на человека торговая и маркетинговая платформа, которая поддерживает богатый, гиперперсонализированный опыт по любому каналу и точке соприкосновения.
  • Flamingo Рамки для создания гибких и современных приложений электронной коммерции.
  • Medusa - Безголовая торговая платформа с открытым исходным кодом.
  • Autonomy, Hyperconnectivity, and Residual Causality Философское введение в проектирование адаптивных гиперлиминальных систем с помощью научных теорий сложности.
  • Awesome Scalability :star: Обновленный и организованный список чтения для иллюстрации моделей масштабируемых, надежных и эффективных крупномасштабных систем. Концепции объясняются в статьях выдающихся инженеров и достоверных ссылках. Тематические исследования взяты из проверенных в бою систем, которые обслуживают миллионы и миллиарды пользователей.
  • AKF Scale Cube - Модель, изображающая размеры для масштабирования услуги.
  • CALM :small_orange_diamond:PDF Последовательность как логическая монотонность.
  • Canary Release Техника снижения риска внедрения новой версии программного обеспечения в производство путем медленного развертывания изменения для небольшого подмножества пользователей, прежде чем развернуть его на всю инфраструктуру и сделать его доступным для всех.
  • CAP Theorem - заявляет, что распределенная компьютерная система не может одновременно предоставлять все три из следующих гарантий: согласованность, доступность и допуск разделов.
  • Formal Foundations of Serverless Computing :small_orange_diamond:PDF Абстракция безсерверных вычислений раскрывает несколько низкоуровневых рабочих деталей, которые затрудняют для программистов написание и рассуждение о своем коде. Эта статья проливает свет на эту проблему, представляя λ, оперативную семантику сущности бессерверных вычислений.
  • Microservice Architecture - Конкретный способ проектирования программных приложений как наборов независимо развертываемых сервисов.
  • Microservices - From Design to Deployment :small_orange_diamond:PDF Серия из семи частей F5 по микросервисам.
  • Microservices – Please, don’t Критические советы о некоторых проблемах, связанных с микросервисами.
  • Microservices Trade-Offs - Руководство по оценке затрат и преимуществ архитектурного стиля mircoservices.
  • Reactive Manifesto - Определение реактивных систем.
  • Reactive Streams - Инициатива по обеспечению стандарта асинхронной обработки потока с неблокирующим обратным давлением.
  • ROCAS :small_orange_diamond:PDF Ресурсно-ориентированные вычисления для адаптивных систем.
  • SECO :small_orange_diamond:PDF Понимание программных экосистем: стратегический подход к моделированию.
  • Testing Strategies in a Microservice Architecture Подходы для управления дополнительной сложностью тестирования нескольких независимо развертываемых компонентов.
  • Your Server as a Function :small_orange_diamond:PDF Описаны три абстракции, которые объединяются, чтобы представить мощную модель программирования для создания безопасного, модульного и эффективного серверного программного обеспечения: Композитные фьючерсы, услуги и фильтры.
  • Cloud Native Computing Foundation Cloud Native Computing Foundation строит устойчивые экосистемы и поддерживает сообщество вокруг группы высококачественных проектов, которые организуют контейнеры в рамках архитектуры микросервисов.
  • CNCF Cloud Native Interactive Landscape Интерактивный ландшафт облачных нативных технологий.
  • Microservices Resource Guide Выбор Мартина Фаулера статей, видео, книг и подкастов, которые могут рассказать вам больше об архитектурном стиле микросервисов.
  • Microservice Patterns - Архитектура микросервисов и лучшие практики.
  • Microservice Antipatterns and Pitfalls Микросервис в основном известен антипаттернами и подводными камнями.

CC0

Пожалуйста, читайте Contribution Guidelines Перед тем, как подать свое предложение.

Не стесняйся open an issue или create a pull request со своими дополнениями.

:star2: Спасибо!

HagiCode

HagiCode — агентная среда разработки. Насыщенные и удобные взаимодействия с интерфейсом делают планирование, работу агентов и проектные задачи понятными и доступными, превращая разработку в увлекательный процесс.

Насыщенные и удобные взаимодействия с интерфейсом помогают легче планировать, запускать агентов и вести проектную работу.

Перейти на HagiCodeЧитать документацию
  • УмныйРабочие процессы OpenSpec превращают намерение в исполнимый путь от предложения через дизайн и задачи до готового изменения.
  • ЭффективныйМультиагентное выполнение параллельно продвигает исследование, реализацию и проверку в нескольких репозиториях и с привычными Agent CLI.
  • ИнтересныйНасыщенные и удобные взаимодействия с интерфейсом делают планирование, работу агентов и проектные задачи понятными и доступными.

Скачать для Windows

Получить в Microsoft StoreВсе загрузки

Превращайте идеи в готовое ПО.

HagiCode — агентная среда разработки: рабочие процессы OpenSpec планируют изменение, мультиагентное выполнение его реализует, а Hero Scenario делает долгий путь наглядным, так что идеи становятся готовым ПО.

Умный
Рабочие процессы OpenSpec превращают намерение в путь от предложения до готового изменения.
Эффективный
Мультиагентное выполнение ведёт исследование, реализацию и проверку параллельно.
Увлекательный
Удобный интерфейс упрощает планирование, работу агентов и проектные задачи.

Покинуть Awesome Site?

Вы собираетесь перейти на внешний сайт. Мы не контролируем его содержимое и правила конфиденциальности.

Адрес назначения

Перейти на сайт