Microservices
Source: https://github.com/mfornos/awesome-microservices at
417c83dc4de7
License: CC0-1.0
Read the English original
This edition is an AI-assisted translation.
Seleção de recursos sobre microsserviços 
Seção intitulada “Seleção de recursos sobre microsserviços ”Uma lista com curadoria de princípios e tecnologias relacionados à arquitetura Microservice.
Sumário
- Plataformas
- Frameworks / Tempos de execução
- Kits de Ferramentas de Serviço
- Frontend / UI
- Capacidades
- Integração e entrega contínuas
- Modelação e Documentação da API Web
- Normas / Recomendações
- Design de Organização / Dinâmica de Equipe
- Enterprise & Vertical
- Teoria
- Licença
- Contribuir
Plataformas
Seção intitulada “Plataformas”- 1Backend - Plataforma de microserviços IA-Native.
- Jolie - Linguagem de programação orientada para microserviço de código aberto.
- OpenWhisk - Plataforma de nuvem de código aberto sem servidor que executa funções em resposta a eventos em qualquer escala.
- Pulumi - SDK para infraestrutura nativa de nuvem como código. Use seu idioma favorito para visualizar e gerenciar atualizações para seus aplicativos e infraestrutura e implemente continuamente em qualquer nuvem (sem necessidade de YAML).
- Triton - Plataforma de gerenciamento de nuvem de código aberto que oferece infraestrutura de próxima geração, baseada em containers e orientada para serviços em um ou mais data centers.
Frameworks / Tempos de execução
Seção intitulada “Frameworks / Tempos de execução”- Akka - Toolkit e tempo de execução para a construção de aplicações altamente simultâneas, distribuídas e resilientes à mensagem no JVM.
- Axon (c) - Uma plataforma de desenvolvimento e infraestrutura de ponta a ponta para fácil desenvolvimento e execução de quaisquer aplicações DDD, CQRS e Event Sourcing na JVM.
- Ballerina - Linguagem de programação nativa em nuvem.
- Bun - Rápido tempo de execução JavaScript tudo-em-um.
- Dapr - Tempo de execução de código aberto para escrever microservices altamente performantes usando qualquer linguagem de programação.
- Deno - JavaScript, TypeScript e WebAssembly runtime com padrões seguros e uma ótima experiência de desenvolvedor.
- Eclipse Microprofile - Um fórum aberto para otimizar o Enterprise Java para uma arquitetura de microservices, inovando em múltiplas implementações e colaborando em áreas comuns de interesse com um objetivo de padronização.
- Erlang/OTP - Linguagem de programação usada para construir sistemas de grande escala em tempo real macios com requisitos em alta disponibilidade.
- Finagle - Sistema RPC extensível para a JVM, usado para construir servidores de alta concorrência.
- Gleam - Uma linguagem amigável para a construção de sistemas type-safe, escaláveis.
- GraalVM - Tempo de execução de alto desempenho que proporciona melhorias significativas no desempenho e eficiência da aplicação que é ideal para microserviços.
- Helidon - Coleção de bibliotecas Java para escrever microservices que funcionam em um núcleo web rápido alimentado por Netty.
- Ice - Framework RPC abrangente com suporte para C++, C#, Java, JavaScript, Python e muito mais.
- Light-4j - Um alto rendimento, baixa latência, pequena pegada de memória e plataforma de microserviços mais produtiva.
- Micronaut - Uma estrutura moderna, baseada em JVM, full-stack para a construção de aplicações modulares e facilmente testáveis de microserviço.
- Moleculer - Framework rápido e poderoso de microservices para Node.js, Java, Go e Ruby.
- Open Liberty - Um framework aberto leve para construir microservices Java rápidos e eficientes.
- Pears - Tempo de execução, desenvolvimento e implantação.
- SmallRye - APIs e implementações adaptadas para o desenvolvimento em nuvem, incluindo o Eclipse MicroProfile.
- Spin - Um framework de código aberto para construir e executar microserviços de nuvem rápidos, seguros e composíveis com WebAssembly.
- ScaleCube - Kit de ferramentas para construção de microserviços reativos para a JVM: baixa latência, alta produtividade, escalável e resistente.
- Vert.X - Kit de ferramentas para a construção de aplicações reativas na JVM.
- Vert.X Toolbox - Um conjunto de componentes Vert.x para construir aplicações de microserviço reativas.
- Wangle - Um framework que fornece um conjunto de abstrações comuns cliente/servidor para construção de serviços de forma consistente, modular e composível.
Kits de Ferramentas de Serviço
Seção intitulada “Kits de Ferramentas de Serviço”Poliglota
Seção intitulada “Poliglota”- GRPC - Um alto desempenho, código aberto, framework RPC geral que coloca o celular e HTTP/2 em primeiro lugar. Bibliotecas em C, C++, Java, Go, Node.js, Python, Ruby, Objective-C, PHP e C#.
- Lwan - Servidor web de alto desempenho e escalável.
- uSockets - Miniscule cross-platform eventing, rede e criptografia para aplicações async.
- Cap’n Proto RPC - A implementação do Cap’n Proto C++ RPC.
- C++ Micro Services - Um sistema de módulo dinâmico OSGi-like C++ e registro de serviço.
- Enduro/X - Framework de serviço baseado em XATMI para GNU/Linux.
- Pistache - Um kit de ferramentas REST de alto desempenho escrito em C++.
- Poco - Bibliotecas de classe C++ para a construção de aplicativos e servidores baseados em rede.
- Sogou Workflow - Motor de programação de nível empresarial destinado a satisfazer a maioria dos requisitos de desenvolvimento de infra-estrutura.
- uWebSockets - Servidor web simples, seguro e compatível com padrões para as aplicações mais exigentes.
- Awesome Microservices .NET Core :star: - Uma coleção de séries de treinamento impressionantes, artigos, vídeos, livros, cursos, projetos de amostra e ferramentas para microservices em .NET Core.
- Vibe.d - I/O assíncrono que não fica no seu caminho, escrito em D.
Erlang VM
Seção intitulada “Erlang VM”- Phoenix - Framework para a construção de aplicativos HTML5, backends de API e sistemas distribuídos.
- Plug - Uma especificação e conveniência para módulos composíveis entre aplicações web.
- Cowboy - Servidor HTTP pequeno, rápido e modular escrito em Erlang.
- Mochiweb - Biblioteca Erlang para a construção de servidores HTTP leves.
- Chi - Roteador leve, idiomático e composível para construção de serviços da Go HTTP.
- Echo - Framework de servidor HTTP rápido e desfalque para Ir. Até 10x mais rápido do que o resto.
- Fiber - Framework web inspirado expresso construído em cima do Fasthttp, o motor HTTP mais rápido para Go. Projetado para facilitar as coisas para o desenvolvimento rápido com zero alocação de memória e desempenho em mente.
- Gin - Gin é um framework web HTTP escrito em Go (Golang). Ele possui uma API tipo Martini com desempenho muito melhor, até 40 vezes mais rápido.
- Goa - Microservices HTTP baseados em design em Go.
- GoFr - Um quadro de desenvolvimento de microservices opinado enfatizando escalabilidade e robustez. Projetado para simplificar o desenvolvimento de microserviços.
- Go Chassis - Um quadro para o rápido desenvolvimento de microserviços em Go que é fácil de integrar com alguns ecossistemas de nuvem.
- Go-micro - Um quadro de desenvolvimento de sistemas distribuído.
- Go-zero - Um framework de desenvolvimento de sistemas distribuído web e rpc.
- Gorilla - Kit de ferramentas para a linguagem de programação Go.
- Iris - Framework micro web rápido, simples e eficiente para Go.
- Lura - Framework para construir gateways API de ultra desempenho com middlewares.
- RPCX - Um framework de serviço RCP distribuído baseado em NET/RPC como Alibaba Dubbo e Weibo Motan.
Haskell
Seção intitulada “Haskell”- Scotty - Micro web framework inspirado no Sinatra de Ruby, usando WAI e Warp.
- Servant - DSL de nível de tipo.
- Yesod - A estrutura web Haskell RESTful.
Java VM
Seção intitulada “Java VM”Clojure
Seção intitulada “Clojure”- Compojure - Uma biblioteca concisa para Ring/Clojure.
- Duct - Uma estrutura de servidor para o Clojure.
- System - Construído em cima da biblioteca de componentes Stuart Sierra, oferece um conjunto de componentes prontos.
- Tesla - Base comum para alguns dos microserviços de Clojure de Otto.de.
- ActiveJ - Biblioteca leve e rápida para aplicações complexas distribuídas de alta carga e soluções tipo Memcached.
- Airlift - Framework para construção de serviços REST em Java.
- Armeria - Biblioteca cliente/servidor HTTP/2 assíncrona de código aberto com base no Java 8, Netty, Thrift e gRPC.
- Disruptor - Biblioteca de mensagens inter-thread de alto desempenho.
- Dropwizard - Framework Java para o desenvolvimento de serviços web RESTful, ops-friendly e de alto desempenho.
- Dubbo - Um framework RPC baseado em java de alto desempenho de código aberto pela Alibaba.
- Conjure - Conjunto opinado de bibliotecas para definir e criar servidores e clientes RESTish/RPC baseados em Feign ou Retrofit como cliente e Dropwizard/Jersey com definições de serviço JAX-RS como servidor.
- Jersey - Serviços RESTful em Java. Implementação de referência JAX-RS.
- Quarkus - A Kubernetes Pilha Java nativa adaptada para OpenJDK HotSpot e GraalVM, criada a partir das melhores bibliotecas e padrões Java da raça.
- Ratpack - Conjunto de bibliotecas Java que facilitam aplicações HTTP rápidas, eficientes, evoluíveis e bem testadas. apoio específico para a língua Groovy é fornecido.
- Spring Boot - Facilita a criação de aplicações independentes baseadas em Primavera.
- Http4k - Kit de ferramentas HTTP leve, mas completo, escrito em Kotlin puro que permite servir e consumir serviços HTTP de forma funcional e consistente.
- Ktor - Framework para a construção de servidores assíncronos e clientes em sistemas conectados usando a linguagem de programação Kotlin.
- Finatra - Rápido, testável, serviços Scala HTTP construídos no Twitter-Server e Finagle.
- Http4s - Uma interface Scala mínima e idiomática para HTTP
- Play - O framework web de alta velocidade para Java e Scala.
Node.js
Seção intitulada “Node.js”- Actionhero - Multi-transport Node.js servidor API com recursos de cluster integrados e tarefas atrasadas.
- Express - Framework web rápido, não-opinionado e minimalista para Node.js
- Fastify - Fastify, Framework web rápido e baixo, para Node.js.
- FeathersJS - Uma camada REST de código aberto e API em tempo real para aplicações modernas.
- Hono - Framework web pequeno, simples e ultra-rápido para os Edges. Funciona em qualquer tempo de execução JavaScript.
- Koa - Framework web de próxima geração para Node.js
- Loopback - Framework Node.js para criação de APIs e fácil conexão com fontes de dados de infraestrutura.
- NestJS - Um framework Node.js para a construção de aplicações eficientes e escaláveis do lado do servidor com um suporte integrado de microserviços.
- Seneca - Um kit de ferramentas de microserviços para Node.js
- Serverless - Construir e manter aplicações web, móveis e IoT em execução no AWS Lambda e API Gateway (anteriormente conhecido como JAWS).
- tRPC - APIs de segurança de ponta a ponta.
- Cro - Bibliotecas para a criação de sistemas distribuídos reativos usando Perl 6.
- Mojolicious - Framework web da próxima geração para Perl.
- API Platform - API-primeiro framework web no topo do Symfony com suporte JSON-LD, Schema.org e Hydra.
- Ecotone - Framework baseado em princípios arquitetônicos de DDD, CQRS e Event Sourcing que fornece blocos de construção para criar aplicações escaláveis e extensíveis.
- Hyperf - Hyperf é um framework PHP CLI extremamente eficiente e flexível baseado no Swoole 4.5+, alimentado pelo servidor de coroutine de última geração e um grande número de componentes testados em batalha.
- Lumen - Um micro-quadro incrivelmente rápido.
- Slim - Micro-framework que ajuda você a escrever rapidamente aplicativos web simples e poderosos e APIs.
- Spiral - Framework projetado para aplicações de longa duração usando RoadRunner. Oferece recursos avançados como integração com o Temporal motor de fluxo de trabalho e Centrifugo servidor websocket. É particularmente eficaz para arquitetura de microservices, fornecendo suporte robusto para APIs REST e serviços gRPC.
- Swoft - PHP microservices coroutine framework para construção de sistemas web de alto desempenho, APIs, middleware e serviços básicos.
- Symfony - Micro-framework baseado nos componentes Symfony.
- Aiohttp - Cliente/servidor HTTP para assincio.
- Bottle - Micro-framework WSGI rápido, simples e leve para Python.
- Connexion - Framework Swagger/OpenAPI para Python no topo do Flask com validação automática de endpoint e suporte OAuth2.
- Falcon - Framework de API web Python sem metal para construir backends de aplicativos muito rápidos e microservices.
- FastAPI - Moderno, rápido (alto desempenho), framework web para a construção de APIs com Python 3.6+ baseado em dicas padrão tipo Python.
- Flask - Framework Python para microservices baseado em Werkzeug e Jinja 2.
- Nameko - Estrutura Python para construção de microserviços.
- Sanic - Sanic é um servidor Python 3.5+ semelhante ao Flask que está escrito para ir rápido.
- Tornado - Web framework e biblioteca de rede assíncrona.
- Twisted - Motor de programação de rede orientado a eventos.
- Web.py - Framework web minimalista para Python.
- Grape - Um framework de opinião para criar APIs tipo REST
- Hanami - Um moderno framework para Ruby.
- Praxis - Framework para projetar e implementar APIs.
- Scorched - Framework leve para Ruby.
- Sinatra - Sinatra é um DSL para criar rapidamente aplicações web em Ruby com o mínimo de esforço.
- Are we web yet? :star: - Um resumo do estado actual da programação web em Rust.
- Actix - Estrutura web poderosa, pragmática e extremamente rápida para a Rust.
- Tarpc - Framework RPC para Rust com foco na facilidade de uso.
- Tokio - Tempo de execução assíncrono para escrever aplicações de rede.
- Tower - Biblioteca de componentes modulares e reutilizáveis para a construção de clientes e servidores de rede robustos.
- Wtx - Framework cliente/servidor HTTP/2.
Frontend / UI
Seção intitulada “Frontend / UI”- Awesome Micro Frontends :star: - Uma lista de recursos sobre a Micro Frontends.
- Electrode - Plataforma de aplicação Universal React/Node.js.
- Micro Frontends - Estendendo a ideia de microservice para o desenvolvimento frontend.
- MiniApp White Paper - MiniApp padronização papel branco.
Capacidades
Seção intitulada “Capacidades”Gateways API / Serviços de borda
Seção intitulada “Gateways API / Serviços de borda”- Ambassador (c) - Não. Kubernetes- gateway API nativo para microservices construídos no Enviado.
- Apache APISIX - Gateway de API de alto desempenho, em tempo real e gateway de IA construído em NGINX e etcd, com roteamento a quente e mais de 100 plugins.
- APIcast - APIcast é um gateway de API construído em cima do NGINX. Faz parte da Plataforma de Gerenciamento de APIs Red Hat 3scale.
- Bunker Web - Hospedagem da aplicação Web e proxy reverso seguro por padrão.
- Caddy - Extensível servidor HTTP/2 com HTTPS automático.
- Camel - Capacita você a definir regras de roteamento e mediação em uma variedade de idiomas específicos de domínio, incluindo uma API fluente baseada em Java, arquivos de configuração Spring ou Blueprint XML e um Scala DSL.
- Envoy - Open source edge e proxy de serviço, dos desenvolvedores em Lyft.
- HAProxy - Balanceador de carga confiável e de alto desempenho TCP/HTTP.
- Istio - Uma plataforma aberta para conectar, gerenciar e proteger microserviços.
- Keepalived - Instalações simples e robustas para balanceamento de carga e alta disponibilidade para o sistema Linux e infraestruturas baseadas em Linux.
- Kong - Camada de gerenciamento de código aberto para APIs.
- KrakenD - Open source ultra performance API Gateway.
- Kuma - Plataforma agnóstico plano de controle de código aberto para rede de serviço e microserviços.
- Linkerd - Mesh de serviço resistente para aplicativos nativos de nuvem.
- Neutrino - Extensível balanceador de carga de software.
- OpenResty - Servidor de aplicação web rápido construído em cima de Nginx.
- Open Service Mesh - Mesh de serviço nativo de nuvem leve e extensível.
- Otoroshi - Moderno HTTP proxy reverso com gerenciamento de API leve.
- Pingora - Uma biblioteca para a construção de serviços de rede rápidos, confiáveis e evoluíveis.
- Skipper - Roteador HTTP útil para dissociar roteamento da lógica de serviço.
- Spring Cloud Gateway - API Gateway em cima da Primavera MVC. O objetivo é fornecer uma forma simples, mas eficaz de encaminhar para APIs.
- Tengine - Uma distribuição de Nginx com algumas características avançadas.
- Træfɪk - Um moderno proxy HTTP reverso e balanceador de carga feito para implantar microservices com facilidade.
- Traffic Server - Bloco de construção de alto desempenho para serviços em nuvem.
- Tyk - Open source, gateway de API rápida e escalável, portal e plataforma de gerenciamento de API.
- Vulcand - Balanceador de carga programático apoiado pela Etcd.
- Zuul - Um serviço de borda que fornece roteamento dinâmico, monitoramento, resiliência, segurança e muito mais.
Configuração e Descoberta
Seção intitulada “Configuração e Descoberta”- Central Dogma - Repositório de configuração de serviço controlado por versão de código aberto com base em Git, ZooKeeper e HTTP/2.
- Consul - Serviço descoberta e configuração facilitada. Distribuído, altamente disponível e informador de dados.
- Etcd - Loja de valor-chave altamente disponível para configuração compartilhada e descoberta de serviços.
- Eureka - Serviço baseado em REST que é usado principalmente na nuvem AWS para localizar serviços com o propósito de balanceamento de carga e failover de servidores de nível médio.
- Microconfig - Modo moderno e simples de gerenciamento de configuração de microservices.
- Nacos - Fácil de usar a plataforma de descoberta dinâmica de serviços, configuração e gerenciamento de serviços.
- SkyDNS - Serviço distribuído para anúncio e descoberta de serviços construídos em cima de etc. Ele utiliza consultas DNS para descobrir serviços disponíveis.
- Spring Cloud Config - Fornece suporte ao servidor e ao cliente para configuração externalizada em um sistema distribuído.
- ZooKeeper - Servidor de código aberto que permite uma coordenação distribuída altamente confiável.
Orquestração de fluxo de trabalho
Seção intitulada “Orquestração de fluxo de trabalho”- AWS Step Functions (c) - Coordene os componentes de aplicações e microserviços distribuídos usando fluxos de trabalho visuais.
- Cadence - Plataforma de código falsa.
- Conductor - Um motor de orquestração de microserviços.
- Inngest - Funções duráveis para lógica de fundo confiável, desde trabalhos de fundo a fluxos de trabalho complexos.
- Kestra - Open source microservices event-driven, linguagem e plataforma de programação.
- Temporal - Plataforma de orquestração de microserviços de código aberto para executar código crítico de missão em qualquer escala.
- Zeebe - Definir, orquestrar e monitorar processos de negócios em microserviços.
Elasticidade
Seção intitulada “Elasticidade”- Hazelcast - Grade de dados em memória aberta. Permite distribuir dados e computação em servidores, clusters e geografias e gerenciar conjuntos de dados muito grandes ou altas taxas de ingestão de dados. Tecnologia madura.
- Helix - Framework genérico de gerenciamento de cluster usado para o gerenciamento automático de recursos particionados, replicados e distribuídos hospedados em um cluster de nós.
- Ignite - Plataforma de alta performance, integrada e distribuída em memória para computação e transação em conjuntos de dados de grande escala em tempo real, ordens de magnitude mais rápidas do que possível com tecnologias tradicionais baseadas em disco ou flash.
- Libp2p - Uma estrutura e conjunto de protocolos para a construção de aplicações de rede peer-to-peer.
- Mesos - Abstrai CPU, memória, armazenamento e outros recursos de computação longe de máquinas (físicas ou virtuais), permitindo que os sistemas elásticos e tolerantes a falhas sejam facilmente construídos e executados de forma eficaz.
- Nomad - Distribuído, altamente disponível, agendador consciente do centro de dados.
- Redisson - Estruturas de dados Java distribuídas e escaláveis em cima do servidor Redis.
- Serf - Solução descentralizado para membros de cluster, detecção de falhas e orquestração.
- Valkey - Um novo projeto para retomar o desenvolvimento do antigo projeto Redes de código aberto.
- Zenoh - Protocolo Pub/sub/query unificando dados em movimento, dados em repouso e cálculos. Mistura eficientemente pub/sub tradicional com armazenamento geo distribuído, consultas e computação.
Agendadores de Trabalho / Automação de Carga de Trabalho
Seção intitulada “Agendadores de Trabalho / Automação de Carga de Trabalho”- Celery - Fila de tarefas/ficha de trabalho assíncrona com base no envio de mensagens distribuídas. Focado na operação em tempo real e suporta agendamento.
- Dkron - Distribuição, sistema de trabalho tolerante a falhas.
- Faktory - Servidor de tarefas persistentes de linguagem.
- Rundeck (c) - Programador de empregos e automatização de livros. Activar o acesso de auto-serviço a scripts e ferramentas existentes.
- Schedulix - O sistema de agendamento de trabalho empresarial de código aberto estabelece padrões inovadores para a automação profissional de processos de TI em ambientes avançados do sistema.
Desenvolvimento Local
Seção intitulada “Desenvolvimento Local”- mirrord - Executar código local como se fosse uma cápsula em um controle remoto Kubernetes cluster.
Registo
Seção intitulada “Registo”- Fluentd - Coletor de dados de código aberto para camada de registro unificado.
- Graylog - Plataforma de gerenciamento de logs de código aberto totalmente integrada.
- Kibana - Plataforma flexível de análise e visualização.
- LogDNA (c) - Software centralizado de gestão de registos. Colete instantaneamente, centralize e analise logs em tempo real de qualquer plataforma, em qualquer volume.
- Logstash - Ferramenta para gerenciar eventos e logs.
- Loki - Como Prometeu, mas para troncos.
Mensagens
Seção intitulada “Mensagens”- ØMQ - Camada de transporte inteligente.
- ActiveMQ - Servidor poderoso de mensagens de código aberto e padrões de integração.
- Aeron - Eficiente UDP confiável unicast, UDP multicast, e transporte de mensagens IPC.
- Beanstalk - Fila de trabalho simples e rápida.
- Bull - Fila rápida e confiável baseada em Redis para Node.
- Crossbar - Plataforma de rede de código aberto para aplicações distribuídas e microservice. Implementa o Protocolo de Mensagens de Aplicação Web (WAMP).
- Kafka - Publicar-subscrever mensagens repensadas como um registro de commit distribuído.
- Malamute - O corretor de mensagens da ZeroMQ.
- Mosquitto - Corretor de mensagens de código aberto que implementa o protocolo MQTT.
- NATS - Código aberto, sistema de mensagens de nuvem leve de alto desempenho.
- NSQ - Uma plataforma de mensagens distribuída em tempo real.
- Pulsar - Sistema de mensagens pub-sub distribuído.
- RabbitMQ - Um corretor de mensagens baseado em Erlang que funciona.
- Redpanda - Plataforma de transmissão de dados para desenvolvedores: compatível com API Kafka, 10x mais rápido, sem ZooKeeper e sem JVM.
- RocketMQ - Uma baixa latência, confiável, escalável, fácil de usar middleware orientado mensagem nascido do negócio de mensagens maciças alibaba.
Monitoramento e depuração
Seção intitulada “Monitoramento e depuração”- Beats - Transportadores leves para a Elasticsearch & Logstash.
- Elastalert - Alerta fácil e flexível para Elasticsearch.
- Ganglia - Um sistema de monitoramento distribuído escalável para sistemas de computação de alto desempenho, como clusters e grades.
- Grafana - Um painel de métricas de código aberto, rico em recursos e editor de gráficos para Graphite, InfluxDB e OpenTSDB.
- Graphite - Gráfico em tempo real escalável.
- IOpipe (c) - Monitoramento de desempenho de aplicação para Amazon Lambda.
- Jaeger - Um rastreamento de código aberto, de ponta a ponta distribuído
- OpenTelemetry - Telemetria de alta qualidade, ubíqua e portátil para permitir uma observação eficaz.
- Prometheus - Um sistema de monitoramento de serviços de código aberto e banco de dados de séries temporais.
- Riemann - Monitores de sistemas distribuídos.
- Sensu - Monitoramento da infra-estrutura de hoje.
- SkyWalking - Ferramenta de monitor de desempenho de aplicação para sistemas distribuídos, especialmente concebidos para microservices, nuvem nativa e container-based (Docker, K8s, Mesos) arquiteturas.
- Zabbix - Solução de monitoramento de classe empresarial de código aberto.
- Zipkin - Sistema de localização distribuído.
Reactividade
Seção intitulada “Reactividade”- Arroyo - Motor de processamento de fluxo distribuído para transformar, filtrar, agregar e juntar fluxos de dados escrevendo SQL.
- Reactor.io - Uma biblioteca Reactive de segunda geração para a construção de aplicações sem bloqueio na JVM com base na Especificação de Fluxos Reactivos.
- Reactive Kafka - API de Fluxos Reativos para Apache Kafka.
- ReactiveX - API para programação assíncrona com fluxos observáveis. Disponível para Java idiomático, Scala, C#, C++, Clojure, JavaScript, Python, Groovy, JRuby, entre outros.
- RSocket - Protocolo de aplicação fornecendo semântica de fluxo reativo.
Resiliência
Seção intitulada “Resiliência”- Awesome Chaos Engineering :star: - Uma lista de recursos de engenharia do caos.
- Raft Consensus - Algoritmo de consenso projetado para ser fácil de entender. É equivalente ao Paxos em tolerância a falhas e desempenho.
- Resilience4j - Biblioteca de tolerância a falhas projetada para Java8 e programação funcional.
- Svix - Webhooks serviço que envia webhooks para seus usuários com horários de repetição completa, backoff exponencial, verificação de assinatura e tipos de eventos.
Segurança
Seção intitulada “Segurança”- Cerbos Hub - Sistema de gerenciamento de autorização para criação, teste e implantação de políticas de acesso. Autorização escalável e fina em uma arquitetura de microservice.
- Dex - Serviço de autenticação/diretório opinado com conectores plugáveis. Provedor OpenID Connect e delegação OAuth 2.0 de terceiros.
- JWT - A JSON Web Tokens é um método aberto, padrão da indústria RFC 7519 para representar reivindicações de forma segura entre duas partes.
- Keycloak - Serviço de autenticação completo e extensível. Provedor OpenID Connect e delegação OAuth 2.0 de terceiros.
- OAuth - Fornece fluxos de autorização específicos para aplicações web, aplicativos desktop, telefones celulares e dispositivos de sala de estar. Muitas implementações.
- OpenID Connect - Bibliotecas, produtos e ferramentas implementando especificações atuais do OpenID e especificações relacionadas.
- Open Ziti - Zero confiança segurança e sobreposição de rede como puro software de código aberto.
- ORY - Infraestrutura e serviços de identidade de código aberto.
- OWASP Agent Memory Guard — Camada de defesa em tempo de execução para envenenamento por memória do agente IA (OWASP ASI06). Detecta entradas de memória adulteradas, injeção rápida em caminhos de memória e vazamento secreto. Políticas YAML, latência de microsegundos, zero dependências externas.
- SCIM - Sistema de Gestão de Identidades Cross-domain.
- Vault - Protege, armazena e controla firmemente o acesso a tokens, senhas, certificados, chaves API e outros segredos na computação moderna.
Serialização
Seção intitulada “Serialização”- Avro - Sistema de serialização de dados Apache fornecendo estruturas de dados ricas em um formato de dados compacto, rápido e binário.
- Bond - Framework multiplataforma para trabalhar com dados esquematizados, amplamente utilizado na Microsoft em serviços de alta escala.
- BooPickle - Biblioteca de serialização binária para comunicação de rede eficiente. Para Scala e Scala.js
- Cap’n Proto - Formato de intercâmbio de dados insanamente rápido e sistema RPC baseado em capacidade.
- CBOR - Implementação da norma CBOR (RFC 7049) em muitas línguas.
- Cereal - Biblioteca C++11 para serialização.
- Cheshire - Clojure JSON e JSON SMILE codificação/decodificação.
- Etch - Estrutura interplataforma, linguagem e transporte independente para a construção e consumo de serviços de rede.
- Fastjson - Processador JSON rápido.
- Ffjson - Serialização JSON mais rápida para Go.
- FST - Queda rápida de serialização.
- Jackson - Uma biblioteca Java multiuso para processar o formato de dados JSON.
- Jackson Afterburner - Módulo Jackson que usa geração de bytecode para acelerar ainda mais a ligação de dados (+30-40% de rendimento para serialização, desserialização).
- Kryo - Serialização e clonagem Java: rápido, eficiente, automático.
- Lite³ - Formato de serialização compatível com JSON.
- MessagePack - Formato de serialização binária eficiente.
- Protostuff - Uma biblioteca de serialização com suporte embutido para compatibilidade para frente e para trás (evolução do esquema) e validação.
- SBinary - Biblioteca para descrever formatos binários para tipos Scala.
- Thrift - O framework de software Apache Thrift, para o desenvolvimento de serviços cross-language escaláveis.
- yyjson - A biblioteca JSON mais rápida em C.
Armazenamento
Seção intitulada “Armazenamento”- Apache Cassandra - Orientado para colunas e proporcionando alta disponibilidade sem nenhum ponto de falha.
- Aerospike (c) - Banco de dados NoSQL de alto desempenho entregando velocidade em escala.
- ArangoDB - Uma base de dados distribuída livre e de código aberto com um modelo de dados flexível para documentos, gráficos e valores-chave.
- Citus - Distribuído PostgreSQL como uma extensão.
- CockroachDB (c) - Um banco de dados SQL nativo na nuvem modelado após o Google Spanner.
- Couchbase - Um banco de dados distribuído projetado para desempenho, escalabilidade e administração simplificada.
- Crate (c) - Base de dados SQL escalável com as guloseimas NoSQL.
- Druid - Armazenamento rápido de dados distribuídos orientado para colunas.
- Elasticsearch - Servidor de busca aberto distribuído, escalável e altamente disponível.
- Geode - Banco de dados de código aberto, distribuído, em memória para aplicações em escala.
- Infinispan - Altamente concorrente chave / valor datastore usado para cache.
- InfluxDB - Armazenamento de dados escaláveis para métricas, eventos e análises em tempo real.
- RethinkDB - Código aberto, banco de dados escalável que facilita a construção de aplicativos em tempo real.
- TiKV - Distribuído banco de dados de valor-chave transacional.
- TimescaleDB - Um banco de dados de séries temporais para análises em tempo real de alto desempenho embalado como uma extensão Postgres.
- Trino - Mecanismo de consulta SQL rápido distribuído para análise de big data que ajuda você a explorar seu universo de dados.
- Goreplay - Uma ferramenta para capturar e reproduzir tráfego HTTP ao vivo em um ambiente de teste.
- Keploy - Ferramenta de código aberto para testar APIs e zombar, capturando tráfego real e convertendo-o em casos de teste e tocos, permitindo testes confiáveis de microservice.
- Mitmproxy - Um programa de console interativo que permite que fluxos de tráfego sejam interceptados, inspecionados, modificados e reproduzidos.
- MockServer - Mocking, proxy de depuração e engenharia de caos para vários protocolos (HTTP, gRPC, GraphQL, LLM, MCP, Kafka, TCP e muito mais); dependências simuladas, tráfego de registro/replay, solicitações de verificação e falhas de injeção para testes de integração e resiliência.
- Mountebank - Multiplataforma, teste multiprotocolo duplica sobre o fio.
- Pact - Estrutura de teste de contrato para APIs HTTP e sistemas de mensagens assíncronas não-HTTP.
- RestQA - Uma ferramenta para gerenciar microservices simulando, unidade e teste de desempenho localmente com o melhor na experiência do desenvolvedor da classe.
- Specmatic - Converte especificações de API (OpenAPI, AsyncAPI, GraphQL, gRPC etc) em contratos executáveis para testes automatizados, virtualização de serviços e validação de compatibilidade backward sem escrever código.
- VCR - Grave as interações HTTP do seu conjunto de testes e reproduza-as durante futuras execuções de testes para testes rápidos, determinísticos e precisos. Veja a lista de portos para implementações em outras línguas.
- Wilma - Stub de serviço HTTP/HTTPS combinado e solução proxy transparente.
- WireMock - Biblioteca flexível para serviços web stubbing e zombando. Ao contrário de ferramentas de zombaria de propósito geral, ele funciona criando um servidor HTTP real que seu código sob teste pode conectar como seria um serviço web real.
- Hoverfly - Ferramenta de simulação de virtualização/API de serviços leves para desenvolvedores e testadores.
Integração e entrega contínuas
Seção intitulada “Integração e entrega contínuas”- Awesome CI/CD DevOps :star: - Uma lista de ferramentas incríveis para integração contínua, entrega contínua e DevOps.
Modelação e Documentação da API Web
Seção intitulada “Modelação e Documentação da API Web”- AsyncAPI - Especificação AsyncAPI, o padrão do setor para definir APIs assíncronas.
GraphQL
Seção intitulada “GraphQL”- GraphQL - Linguagem de consultas projetada para construir aplicações cliente, fornecendo uma sintaxe intuitiva e flexível e sistema para descrever seus requisitos de dados e interações.
- JSON:API - Uma especificação de como um cliente deve solicitar que os recursos sejam obtidos ou modificados, e como um servidor deve responder a essas solicitações.
- API Blueprint - Ferramentas para todo o ciclo de vida da API. Use-o para discutir sua API com outros. Gerar documentação automaticamente. Ou uma suite de testes. Ou mesmo algum código.
- OpenAPI - A especificação OpenAPI (OAS) fornece um meio consistente para transportar informações através de cada etapa do ciclo de vida da API.
- RAML - API RESTful Modeling Language, uma forma simples e sucinta de descrever APIs praticamente RESTful.
- ReDoc - Documentação de API gerada por OpenAPI/Swagger.
- Scalar - Plataforma API de código aberto: belas referências API e suporte a OpenAPI/Swagger de 1a classe.
- Slate - Bela documentação estática para sua API.
- Spring REST Docs - Document RESTful serviços combinando documentação escrita à mão com trechos gerados automaticamente produzidos com Spring MVC Test.
- Swagger - Uma representação simples e poderosa da sua API RESTful.
Normas / Recomendações
Seção intitulada “Normas / Recomendações”Rede Mundial
Seção intitulada “Rede Mundial”- W3C.REC-Webarch - Arquitetura da World Wide Web, Volume Um.
- RFC3986 - Identificador Uniforme de Recursos (URI): Syntax Genérico.
- RFC6570 - Modelo URI.
- RFC7320 - URI Design e Propriedade.
Auto-sobergia e descentralização
Seção intitulada “Auto-sobergia e descentralização”- DID - especificação W3C de identificadores descentralizados (DID): um novo tipo de identificador que permite a identidade digital verificável e descentralizada.
- DIDComm - Metodologia de comunicação privada construída no topo da concepção descentralizada de DIDs.
- DIDComm Protocols - Registro de protocolos construídos no DIDComm, para interações auto-soberanas de alta confiança sobre qualquer transporte.
- IDSA - A Associação Internacional de Espaços de Dados (IDSA) está em uma missão de criar o futuro da economia digital global com Espaços de Dados Internacionais (IDS), um sistema seguro e soberano de compartilhamento de dados em que todos os participantes podem realizar o valor total de seus dados.
HTTP/1.1
Seção intitulada “HTTP/1.1”- RFC7230 - Mensagem Sintaxe e Roteamento.
- RFC7231 - Semântica e Conteúdo.
- RFC7232 - Pedidos Condicionais.
- RFC7233 - Pedidos de alcance.
- RFC7234 - Caching.
- RFC7235 - Autenticação.
- RFC7807 - Detalhes de problemas para APIs HTTP.
- RFC7540 - Protocolo de Transferência de Hipertexto Versão 2.
- QUIC-WG - Grupo de Trabalho IETF que é fretado para entregar o próximo protocolo de transporte para a Internet.
- QUIC-Transport - Um transporte multiplexado e seguro.
- JSON-RPC 2.0 - Um protocolo de chamada remota sem estado e leve.
- Open RPC - A especificação OpenRPC define uma descrição padrão da interface linguagem-gnóstico para JSON-RPC 2.0 APIs.
Mensagens
Seção intitulada “Mensagens”- AMQP - Protocolo de espera de mensagens avançado.
- MQTT - Transporte de Telemetria MQ.
- STOMP - Protocolo de Mensagens Orientadas por Texto Simples.
Segurança
Seção intitulada “Segurança”- GNAP - O Grant Negociation and Authorization Protocol define um mecanismo para delegar a autorização de um software e transmitir essa delegação ao software. Esta delegação pode incluir acesso a um conjunto de APIs, bem como informações transmitidas diretamente ao software.PROJETO
- OIDCONN - OpenID Connect 1.0 é uma camada de identidade simples no topo do protocolo OAuth 2.0. Permite aos clientes verificar a identidade do usuário final com base na autenticação realizada por um Servidor de Autorização, bem como obter informações básicas sobre o usuário final de forma interoperável e semelhante ao REST.
- PASETO - Paseto é tudo o que você ama sobre JOSE (JWT, JWE, JWS) sem qualquer um dos muitos déficits de design que atormentam os padrões JOSE. PROJETO
- RFC5246 - O Protocolo de Segurança das Camadas de Transporte (TLS) versão 1.2.
- RFC6066 - Extensões TLS.
- RFC6347 - Datagram Transport Layer Security Versão 1.2.
- RFC6749 - O sistema de autorização OAuth 2.0.
- RFC6962 - Transparência do certificado.
- RFC7515 - JSON Web Signature (JWS) representa conteúdo protegido com assinaturas digitais ou Códigos de Autenticação de Mensagens (MACs) usando estruturas de dados baseadas em JSON.
- RFC7519 - JSON Web Token (JWT) é um meio compacto e seguro para representar reivindicações a serem transferidas entre duas partes.
- RFC7642 - SCIM: Definições, visão geral, conceitos e requisitos.
- RFC7643 - SCIM: Core Schema, fornece um esquema neutro de plataforma e modelo de extensão para representar usuários e grupos.
- RFC7644 - SCIM: Protocolo, nível de aplicação, protocolo REST para provisionamento e gestão de dados de identidade na web.
Descoberta do Serviço
Seção intitulada “Descoberta do Serviço”- DNS-SD - Mecanismo para que os clientes descubram uma lista de instâncias nomeadas de um serviço, utilizando consultas DNS padrão.
- RFC2782 - DNS RR para especificar a localização dos serviços (DNS SRV).
Formatos de Dados
Seção intitulada “Formatos de Dados”- RFC4627 - Nota de Objecto JavaScript (JSON).
- RFC7049 - Representação de Objectos Binários Concisos (CBOR).
- BSON - Binary JSON (BSON).
- JSON-LD - JSON para ligar dados.
- SBE - Codificação binária simples (SBE).
- MSGPACK - Especificação do pacote de mensagens.
Vocabulários
Seção intitulada “Vocabulários”- JSON Schema - Vocabulário que lhe permite anotar e validar documentos JSON.
- Schema.org - Colaborativa, atividade comunitária com uma missão de criar, manter e promover esquemas para dados estruturados na Internet, em páginas web, em mensagens de e-mail e além.
Unicode
Seção intitulada “Unicode”- UNIV8 - O Consórcio Unicode. O Unicode Standard, versão 8.0.0, (Mountain View, CA: The Unicode Consortium, 2015. ISBN 978-1-936213-10-8).
- RFC3629 - UTF-8, um formato de transformação da ISO 10646.
Design de Organização / Dinâmica de Equipe
Seção intitulada “Design de Organização / Dinâmica de Equipe”- How Do Committees Invent? :small_orange_diamond:PDF - Melvin E. Conway, revista Datamation 1968. O artigo original que define a Lei de Conway.
- Service per Team - Cada equipa é responsável por uma ou mais funções empresariais (por exemplo, capacidades empresariais). Uma equipe possui uma base de código composta por um ou mais módulos. Sua base de código é dimensionada de modo a não exceder a capacidade cognitiva da equipe. A equipe implementa seu código como um ou mais serviços. Uma equipe deve ter exatamente um serviço a menos que haja uma necessidade comprovada de ter vários serviços.
- Start with Team Cognitive Load - Team Topologies :small_red_triangle:YT - Sim, Londres. O debate “monolitos vs microservices” muitas vezes se concentra em aspectos tecnológicos, ignorando estratégia e dinâmica de equipe. Em vez de tecnologia, as organizações inteligentes estão começando com a carga cognitiva da equipe como o princípio orientador para o software moderno. Nesta palestra, explicamos como e por quê, ilustrados por estudos de caso reais.
Enterprise & Vertical
Seção intitulada “Enterprise & Vertical”- Commercetools - Plataforma de comércio sem cabeça.
- Equinox - Infosys Equinox é uma plataforma de comércio e marketing centrada em humanos que suporta experiências ricas e hiperpersonalizados em qualquer canal e touchpoint.
- Flamingo - Framework para construir aplicações flexíveis e modernas de e-commerce.
- Medusa - Plataforma de comércio aberto sem cabeça.
Artigos e Artigos
Seção intitulada “Artigos e Artigos”- Autonomy, Hyperconnectivity, and Residual Causality - Introdução filosófica à concepção de sistemas hiperliminares adaptativos através de teorias da ciência da complexidade.
- Awesome Scalability :star: - Uma lista de leitura atualizada e organizada para ilustrar os padrões de sistemas escaláveis, confiáveis e executantes em grande escala. Conceitos são explicados nos artigos de engenheiros proeminentes e referências credíveis. Estudos de caso são feitos de sistemas testados em batalha que servem milhões a bilhões de usuários.
- AKF Scale Cube - Modelo que descreve as dimensões para escalar um serviço.
- CALM :small_orange_diamond:PDF - Consistência como monotonicidade lógica.
- Canary Release - Técnica para reduzir o risco de introdução de uma nova versão de software na produção, lançando lentamente a mudança para um pequeno subconjunto de usuários antes de lançá-la para toda a infraestrutura e disponibilizá-la para todos.
- CAP Theorem - Declara que é impossível para um sistema informático distribuído fornecer simultaneamente as três seguintes garantias: Coerência, Disponibilidade e Tolerância de Partição.
- Formal Foundations of Serverless Computing :small_orange_diamond:PDF - A abstração computacional sem servidor expõe vários detalhes operacionais de baixo nível que tornam difícil para os programadores escreverem e raciocinarem sobre seu código. Este trabalho lança luz sobre este problema apresentando λ, uma semântica operacional da essência da computação sem servidor.
- Microservice Architecture - Forma particular de projetar aplicações de software como suites de serviços de implantação independente.
- Microservices - From Design to Deployment :small_orange_diamond:PDF - Série de sete partes de F5 em microservices.
- Microservices – Please, don’t - Aconselhamento crítico sobre alguns problemas relativos a uma abordagem microservices.
- Microservices Trade-Offs - Guia para ponderar custos e benefícios do estilo arquitetônico mircoservices.
- Reactive Manifesto - Definição de sistemas reactivos.
- Reactive Streams - Iniciativa para fornecer um padrão para processamento de fluxo assíncrono com contrapressão sem bloqueio.
- ROCAS :small_orange_diamond:PDF - Computação orientada a recursos para sistemas adaptativos.
- SECO :small_orange_diamond:PDF - Compreender os ecossistemas de software: uma abordagem de modelagem estratégica.
- Testing Strategies in a Microservice Architecture - Abordagens para gerenciar a complexidade de testes adicionais de múltiplos componentes implantáveis independentemente.
- Your Server as a Function :small_orange_diamond:PDF - Descreve três abstrações que se combinam para apresentar um modelo de programação poderoso para a construção de software de servidor seguro, modular e eficiente: futuros, serviços e filtros composíveis.
Sites & Organizações
Seção intitulada “Sites & Organizações”- Cloud Native Computing Foundation - A Cloud Native Computing Foundation constrói ecossistemas sustentáveis e promove uma comunidade em torno de uma constelação de projetos de alta qualidade que orquestram contêineres como parte de uma arquitetura de microserviços.
- CNCF Cloud Native Interactive Landscape - Paisagem interativa de tecnologias nativas de nuvem.
- Microservices Resource Guide - A escolha de Martin Fowler de artigos, vídeos, livros e podcasts que podem ensinar-lhe mais sobre o estilo arquitetônico microserviços.
- Microservice Patterns - padrões de arquitetura de microservices e melhores práticas.
- Microservice Antipatterns and Pitfalls - Microservice, principalmente anti-padrão e armadilhas.
Licença
Seção intitulada “Licença”Contribuir
Seção intitulada “Contribuir”Por favor, leia o Contribution Guidelines antes de submeter sua sugestão.
Sintam-se à vontade. open an issue ou create a pull request com as suas adições.
:star2: Obrigado!
HagiCode
O HagiCode é um ambiente de programação com agentes. Interações de interface ricas e práticas tornam o planejamento, a execução de agentes e o trabalho em projetos mais acessíveis e fáceis de acompanhar, criando uma experiência de desenvolvimento envolvente.
Uma experiência de desenvolvimento envolvente, com interações de interface ricas e práticas.
- InteligenteOs fluxos de trabalho do OpenSpec transformam a intenção em um caminho executável, da proposta ao design, às tarefas e à entrega.
- EficienteA execução multiagente mantém pesquisa, implementação e revisão em andamento em paralelo, em vários repositórios e com os Agent CLI que você já usa.
- InteressanteInterações de interface ricas e práticas tornam o planejamento, a execução de agentes e o trabalho em projetos mais acessíveis e fáceis de acompanhar.
Baixar para Windows
Compartilhar o HagiCode
Transforme ideias em software entregue.
O HagiCode é um ambiente de programação com agentes: os fluxos de trabalho do OpenSpec planejam a mudança, a execução multiagente a realiza e o Hero Scenario torna o longo percurso visível, para transformar ideias em software entregue.
- Inteligente
- Os fluxos do OpenSpec transformam a intenção em um caminho da proposta à entrega.
- Eficiente
- A execução multiagente conduz pesquisa, implementação e revisão em paralelo.
- Divertido
- As interações de interface facilitam o planejamento, a execução de agentes e os projetos.
© 2026 HagiCode | Powered By hagilight-starlight@0.21.0 | Branch: main | Commit: 745b50b | Built:


