Microservices
Source: https://github.com/mfornos/awesome-microservices at
417c83dc4de7
License: CC0-1.0
Read the English original
This edition is an AI-assisted translation.
Sélection de ressources sur les microservices 
Section intitulée « Sélection de ressources sur les microservices »Une liste des principes et technologies liés à l’architecture de microservice.
Sommaire
- Plateformes
- Cadres / temps d’exécution
- Outils de service
- Frontend / UI
- Capacités
- Passerelles d’API / Services de bord
- Configuration & Découverte
- Orchestration de flux de travail
- Élasticité
- Programmeurs d’emplois / Automatisation de la charge de travail
- Développement local
- Exploitation forestière
- Messagerie
- Surveillance et débogage
- Réactivité
- Résilience
- Sécurité
- Sérialisation
- Stockage
- Essais
- Intégration et livraison continues
- Modélisation et documentation des API Web
- Normes et recommandations
- Conception de l’organisation / Dynamique d’équipe
- Entreprise & Verticals
- Théorie
- Licence
- Contribution
Plateformes
Section intitulée « Plateformes »- 1Backend - Plate-forme de microservices natifs de l’IA.
- Jolie - Langue de programmation axée sur le microservice.
- OpenWhisk - Plateforme cloud open source sans serveur qui exécute des fonctions en réponse à des événements à n’importe quelle échelle.
- Pulumi - SDK pour l’infrastructure native du cloud comme code. Utilisez votre langue préférée pour prévisualiser et gérer les mises à jour de vos applications et de votre infrastructure, et déployer en permanence dans tout nuage (pas de YAML requis).
- Triton - Plateforme de gestion du cloud open source qui fournit une infrastructure de prochaine génération, basée sur des conteneurs, orientée vers le service dans un ou plusieurs centres de données.
Cadres / temps d’exécution
Section intitulée « Cadres / temps d’exécution »- Akka - Boîte à outils et temps d’exécution pour la construction d’applications très concurrentes, distribuées et résilientes sur le JVM.
- Axon (c) - Une plate-forme de développement et d’infrastructure de bout en bout pour le développement et le fonctionnement de toutes les applications DDD, CQRS et Event Sourcing sur JVM.
- Ballerina - Langue de programmation native Cloud.
- Bun - Exécution JavaScript tout-en-un rapide.
- Dapr - Open source runtime pour écrire des microservices hautement performants en utilisant n’importe quel langage de programmation.
- Deno - JavaScript, TypeScript et WebAssembly runtime avec des valeurs par défaut sécurisées et une excellente expérience de développeur.
- Eclipse Microprofile - Un forum ouvert pour optimiser Enterprise Java pour une architecture de microservices en innovant à travers de multiples implémentations et en collaborant sur des domaines d’intérêt communs dans un but de normalisation.
- Erlang/OTP - Langage de programmation utilisé pour construire des systèmes en temps réel soft massivement évolutives avec des exigences en haute disponibilité.
- Finagle - Système RPC extensible pour le JVM, utilisé pour construire des serveurs à haute devises.
- Gleam - Un langage convivial pour construire des systèmes de type sûr et évolutive.
- GraalVM - Durée d’exécution haute performance qui apporte des améliorations significatives dans les performances d’application et l’efficacité qui est idéal pour les microservices.
- Helidon - Collection de bibliothèques Java pour l’écriture de microservices qui fonctionnent sur un noyau web rapide alimenté par Netty.
- Ice - Cadre RPC complet avec support pour C++, C#, Java, JavaScript, Python, etc.
- Light-4j - Un débit élevé, faible latence, une petite empreinte mémoire et une plateforme de microservices plus productive.
- Micronaut - Un cadre moderne, basé sur JVM, complet pour construire des applications de microservice modulaires et facilement testables.
- Moleculer - Cadre de microservices rapide et puissant pour Node.js, Java, Go et Ruby.
- Open Liberty - Un cadre ouvert léger pour la construction rapide et efficace de microservices Java natifs du cloud.
- Pears - Durée d’exécution, développement et déploiement.
- SmallRye - API et implémentations adaptées au développement du cloud, y compris Eclipse MicroProfile.
- Spin - Un cadre open source pour construire et exécuter des microservices cloud rapides, sécurisés et composables avec WebAssembly.
- ScaleCube - Boîte à outils pour la construction de microservices réactifs pour le JVM : faible latence, haut débit, évolutive et résistante.
- Vert.X - Boîte à outils pour la construction d’applications réactives sur le JVM.
- Vert.X Toolbox - Un ensemble de composants Vert.x pour construire des applications de microservices réactifs.
- Wangle - Un cadre fournissant un ensemble d’abstractions communes client/serveur pour les services de construction de manière cohérente, modulaire et compacte.
Outils de service
Section intitulée « Outils de service »Polyglotte
Section intitulée « Polyglotte »- GRPC - Un framework RPC général haute performance, open source qui place le mobile et HTTP/2 en premier. Bibliothèques en C, C++, Java, Go, Node.js, Python, Ruby, Objective-C, PHP et C#.
- Lwan - Serveur web haute performance et évolutive.
- uSockets - Miniscule multiplateforme événementiel, réseau & crypto pour les applications async.
- Cap’n Proto RPC - La mise en œuvre du CPR Cap.
- C++ Micro Services - Un système de module dynamique de type OSGi C++ et un registre de services.
- Enduro/X - Cadre de service XATMI pour GNU/Linux.
- Pistache - Une boîte à outils REST haute performance écrite en C++.
- Poco - Bibliothèques de classe C++ pour la construction d’applications et de serveurs en réseau.
- Sogou Workflow - Moteur de programmation de qualité Enterprise visant à satisfaire la plupart des exigences de développement de moteur.
- uWebSockets - Serveur web simple, sécurisé et conforme aux normes pour les applications les plus exigeantes.
- Awesome Microservices .NET Core :star: - Une collection de formations impressionnantes, articles, vidéos, livres, cours, exemples de projets et outils pour les microservices dans .NET Core.
- Vibe.d - Des E/S asynchrones qui ne vous gênent pas, écrit en D.
Erlang VM
Section intitulée « Erlang VM »- Phoenix - Cadre pour la construction d’applications HTML5, de moteurs d’API et de systèmes distribués.
- Plug - Une spécification et des commodités pour les modules composites entre applications web.
- Cowboy - Petit serveur HTTP rapide et modulaire écrit en Erlang.
- Mochiweb - Bibliothèque Erlang pour la construction de serveurs HTTP légers.
- Chi - Routeur léger, idiomatique et Composable pour la construction de services Go HTTP.
- Echo - Cadre de serveur HTTP rapide et sans fin pour Go. Jusqu’à 10x plus rapide que le reste.
- Fiber - Express inspired web framework construit sur Fasthttp, le moteur HTTP le plus rapide pour Go. Conçu pour faciliter les choses pour un développement rapide avec une allocation de mémoire zéro et des performances en tête.
- Gin - Gin est un cadre web HTTP écrit en Go (Golang). Il dispose d’une API de type Martini avec de meilleures performances, jusqu’à 40 fois plus rapide.
- Goa - Microservices HTTP basés sur la conception en Go.
- GoFr - Un cadre de développement des microservices qui met l’accent sur l’évolutivité et la robustesse. Conçu pour simplifier le développement des microservices.
- Go Chassis - Un cadre pour le développement rapide des microservices à Go qui est facile à intégrer à certains écosystèmes nuageux.
- Go-micro - Un cadre de développement des systèmes distribués.
- Go-zero - Un cadre de développement de systèmes web et rpc distribués.
- Gorilla - Boîte à outils Web pour le langage de programmation Go.
- Iris - Cadre micro web rapide, simple et efficace pour Go.
- Lura - Cadre pour construire des passerelles API ultra-performantes avec des middlewares.
- RPCX - Un cadre de services RPC distribué basé sur NET/RPC comme Alibaba Dubbo et Weibo Motan.
- Scotty - Micro web framework inspiré de Sinatra de Ruby, utilisant WAI et Warp.
- Servant - DSL de type web.
- Yesod - Le cadre web Haskell RESTful.
- Compojure - Une bibliothèque de routage concise pour Ring/Clojure.
- Duct - Un cadre côté serveur pour Clojure.
- System - Construit sur la bibliothèque des composants de Stuart Sierra, offre un ensemble de composants prêts à l’emploi.
- Tesla - Base commune pour certains microservices Clojure d’Otto.de.
- ActiveJ - Librairie légère et rapide pour des applications distribuées complexes et des solutions similaires à Memcached.
- Airlift - Cadre pour la construction de services REST en Java.
- Armeria - Open-source asynchrone HTTP/2 RPC/REST client/serveur bibliothèque construite en haut de Java 8, Netty, Thrift et gRPC.
- Disruptor - Bibliothèque de messagerie interfil haute performance.
- Dropwizard - Cadre Java pour le développement de services web opérationnels, performants et RESTful.
- Dubbo - Un cadre RPC haute performance, basé sur java open-sourced par Alibaba.
- Conjure - Un ensemble de bibliothèques pour définir et créer des serveurs et clients RESTish/RPC basés sur Feign ou Retrofit en tant que client et Dropwizard/Jersey avec des définitions de service JAX-RS en tant que serveur.
- Jersey - Services RESTful en Java. Mise en œuvre de référence JAX-RS.
- Quarkus - A Kubernetes Pile Java native adaptée pour OpenJDK HotSpot et GraalVM, conçue à partir des meilleures bibliothèques et normes Java de race.
- Ratpack - Ensemble de bibliothèques Java qui facilitent les applications HTTP rapides, efficaces, évolutives et bien testées. un soutien spécifique pour la langue Groovy est fourni.
- Spring Boot - Rendre facile la création d’applications printanières autonomes et de qualité de production.
- Http4k - Boîte à outils HTTP légère mais complète écrite en Kotlin pur qui permet le service et la consommation de services HTTP de manière fonctionnelle et cohérente.
- Ktor - Cadre pour la construction de serveurs et de clients asynchrones dans les systèmes connectés en utilisant le langage de programmation Kotlin.
- Finatra - Rapide, testable, les services HTTP Scala construits sur Twitter-Server et Finagle.
- Http4s - Une interface minimale, idiomatique Scala pour HTTP
- Play - Le cadre web haute vitesse pour Java et Scala.
- Actionhero - Multi-transport Node.js serveur API avec des capacités de cluster intégrées et des tâches retardées.
- Express - Cadre web minimaliste et rapide pour Node.js
- Fastify - Cadre web rapide, rapide et bas, pour Node.js.
- FeathersJS - Une couche REST open source et API en temps réel pour les applications modernes.
- Hono - Cadre web petit, simple et ultrarapide pour les Bords. Il fonctionne sur n’importe quel fonctionnement JavaScript.
- Koa - Cadre web de nouvelle génération pour Node.js
- Loopback - Node.js framework pour créer des API et se connecter facilement aux sources de données.
- NestJS - Un cadre Node.js pour la construction d’applications serveur efficaces et évolutives avec un support microservices intégré.
- Seneca - Un kit de microservices pour Node.js
- Serverless - Construisez et maintenez des applications web, mobiles et IoT fonctionnant sur AWS Lambda et API Gateway (anciennement JAWS).
- tRPC - API de bout en bout.
Pourcentage
Section intitulée « Pourcentage »- Cro - Bibliothèques pour la création de systèmes distribués réactifs utilisant Perl 6.
- Mojolicious - Cadre web de prochaine génération pour Perl.
- API Platform - API-premier cadre web en plus de Symfony avec JSON-LD, Schema.org et Hydra support.
- Ecotone - Cadre basé sur les principes architecturaux de DDD, CQRS et Event Sourcing qui fournit des éléments de construction pour créer des applications évolutives et extensibles.
- Hyperf - Hyperf est un framework PHP CLI extrêmement performant et flexible basé sur Swoole 4.5+, alimenté par le serveur coroutine ultramoderne et un grand nombre de composants éprouvés.
- Lumen - Un micro-cadre très rapide.
- Slim - Micro-cadre qui vous aide à écrire rapidement des applications Web simples mais puissantes et des API.
- Spiral - Cadre conçu pour les applications de longue durée RoadRunner. Il offre des fonctionnalités avancées comme l’intégration avec le Temporal moteur et Centrifugo Serveur websocket. Il est particulièrement efficace pour l’architecture des microservices, fournissant un support robuste pour les API REST et les services gRPC.
- Swoft - Cadre coroutine de microservices PHP pour la construction de systèmes web haute performance, API, intergiciel et services de base.
- Symfony - Micro-cadre basé sur les composants Symfony.
- Aiohttp - Client/serveur HTTP pour asyncio.
- Bottle - Micro-cadre web WSGI rapide, simple et léger pour Python.
- Connexion - Cadre Swagger/OpenAPI pour Python en haut de Flask avec validation automatique des paramètres et support OAuth2.
- Falcon - Bare-metal Python web API framework pour construire des moteurs d’application et des microservices très rapides.
- FastAPI - Moderne, rapide (haute performance), cadre web pour la construction d’APIs avec Python 3.6+ basé sur des conseils standard de type Python.
- Flask - Cadre Python pour les microservices basé sur Werkzeug et Jinja 2.
- Nameko - Cadre Python pour la construction de microservices.
- Sanic - Sanic est un serveur web Python 3.5+ qui est écrit pour aller vite.
- Tornado - Cadre Web et bibliothèque de réseautage asynchrone.
- Twisted - Moteur de programmation réseau par événement.
- Web.py - Cadre web minimaliste pour Python.
- Grape - Un cadre d’évaluation pour créer des API ressemblant à REST
- Hanami - Un cadre web moderne pour Ruby.
- Praxis - Cadre pour la conception et la mise en œuvre des API.
- Scorched - Cadre web léger pour Ruby.
- Sinatra - Sinatra est un DSL pour créer rapidement des applications web dans Ruby avec un minimum d’effort.
- Are we web yet? :star: - Un résumé de l’état actuel de la programmation web dans Rust.
- Actix - Cadre web puissant, pragmatique et extrêmement rapide pour Rust.
- Tarpc - Cadre RPC pour Rust avec un accent sur la facilité d’utilisation.
- Tokio - Runtime asynchrone pour écrire des applications réseau.
- Tower - Bibliothèque de composants modulaires et réutilisables pour construire des clients et serveurs de réseau robustes.
- Wtx - Cadre client/serveur HTTP/2.
Frontend / UI
Section intitulée « Frontend / UI »- Awesome Micro Frontends :star: - Une liste de ressources sur Micro Frontends.
- Electrode - Plateforme d’application Universal React/Node.js.
- Micro Frontends - Étendre l’idée du microservice au développement frontal.
- MiniApp White Paper - Livre blanc sur la normalisation MiniApp.
Capacités
Section intitulée « Capacités »Passerelles d’API / Services de bord
Section intitulée « Passerelles d’API / Services de bord »- Ambassador (c) - Oui. Kubernetes-Native API passerelle pour les microservices construit sur Envoy.
- Apache APISIX - passerelle API haute performance en temps réel et passerelle AI construite sur NGINX et etcd, avec routage à chaud et 100 plugins.
- APIcast - APIcast est une passerelle API construite en haut de NGINX. Il fait partie de la plateforme de gestion de l’API à l’échelle Red Hat 3.
- Bunker Web - Hébergement d’applications Web et proxy inversé sécurisé par défaut.
- Caddy - Serveur Web HTTP/2 extensible avec HTTPS automatique.
- Camel - Vous permet de définir des règles de routage et de médiation dans une variété de langages spécifiques au domaine, y compris une API couramment basée sur Java, des fichiers de configuration XML Spring ou Blueprint et un DSL Scala.
- Envoy - Open source edge and service proxy, des développeurs de Lyft.
- HAProxy - Balanceur de charge TCP/HTTP fiable et performant.
- Istio - Une plateforme ouverte pour connecter, gérer et sécuriser les microservices.
- Keepalived - Des installations simples et robustes pour l’équilibrage des charges et une grande disponibilité pour le système Linux et les infrastructures basées sur Linux.
- Kong - Couche de gestion open source pour les API.
- KrakenD - Open source ultra performance API Gateway.
- Kuma - Plan de contrôle agnostique de la plate-forme open source pour les services maillage et microservices.
- Linkerd - Mesh de service résistant pour les applications natives du cloud.
- Neutrino - Balanceur de charge extensible.
- OpenResty - Serveur d’applications web rapide construit sur Nginx.
- Open Service Mesh - Mesh de service natif des nuages léger et extensible.
- Otoroshi - Proxy HTTP moderne avec gestion légère de l’API.
- Pingora - Une bibliothèque pour construire des services réseau rapides, fiables et évolutifs.
- Skipper - Routeur HTTP utile pour découpler le routage de la logique de service.
- Spring Cloud Gateway - API Gateway en haut de Spring MVC. vise à fournir un moyen simple, mais efficace de route vers les API.
- Tengine - Une distribution de Nginx avec quelques fonctionnalités avancées.
- Træfɪk - Un proxy HTTP moderne et un équilibreur de charge pour déployer les microservices avec facilité.
- Traffic Server - Bloc de construction haute performance pour les services cloud.
- Tyk - Open source, passerelle API rapide et évolutive, portail et plateforme de gestion d’API.
- Vulcand - Balanceur de charge programmatique soutenu par Etcd.
- Zuul - Un service de bord qui fournit un routage dynamique, la surveillance, la résilience, la sécurité, et plus encore.
Configuration & Découverte
Section intitulée « Configuration & Découverte »- Central Dogma - Dépôt de configuration de service sous contrôle de version ouvert basé sur Git, ZooKeeper et HTTP/2.
- Consul - Découverte du service et configuration facile. Distribué, très disponible, et datacenter-aware.
- Etcd - Magasin à valeur clé hautement disponible pour la configuration partagée et la découverte de service.
- Eureka - service basé sur REST qui est principalement utilisé dans le cloud AWS pour localiser des services dans le but d’équilibrer la charge et d’affaiblir les serveurs de niveau intermédiaire.
- Microconfig - Mode moderne et simple de gestion de la configuration du microservice.
- Nacos - Plate-forme de découverte, de configuration et de gestion de service dynamique facile à utiliser.
- SkyDNS - Service distribué pour l’annonce et la découverte de services construits en plus de etcd. Il utilise les requêtes DNS pour découvrir les services disponibles.
- Spring Cloud Config - Fournit une prise en charge du serveur et du client pour la configuration externalisée dans un système distribué.
- ZooKeeper - Serveur open source qui permet une coordination distribuée très fiable.
Orchestration de flux de travail
Section intitulée « Orchestration de flux de travail »- AWS Step Functions (c) - Coordonner les composants des applications distribuées et des microservices en utilisant des flux de travail visuels.
- Cadence - Une plate-forme de code abominable.
- Conductor - Un moteur d’orchestration de microservices.
- Inngest - Fonctions durables pour une logique de fond fiable, des tâches de fond aux workflows complexes.
- Kestra - Plate-forme d’orchestration et de programmation de microservices open source pilotés par des événements, langue-agnostique.
- Temporal - Plateforme d’orchestration de microservices open source pour exécuter le code critique de mission à n’importe quelle échelle.
- Zeebe - Définir, orchestrer et surveiller les processus commerciaux à travers les microservices.
Élasticité
Section intitulée « Élasticité »- Hazelcast - Grille de données en mémoire ouverte. Vous permet de distribuer des données et des calculs entre serveurs, clusters et géographies, et de gérer de très grands ensembles de données ou des taux élevés d’ingestion de données. Technologie mature.
- Helix - Cadre générique de gestion des grappes utilisé pour la gestion automatique des ressources partagées, reproduites et distribuées hébergées sur un groupe de nœuds.
- Ignite - Plate-forme en mémoire haute performance, intégrée et distribuée pour l’informatique et la transaction sur des ensembles de données à grande échelle en temps réel, ordres de grandeur plus rapides que possible avec les technologies traditionnelles basées sur le disque ou flash.
- Libp2p - Un cadre et une série de protocoles pour la construction d’applications de réseau entre pairs.
- Mesos - Résumés CPU, mémoire, stockage, et d’autres ressources de calcul loin des machines (physiques ou virtuelles), permettant des systèmes de distribution élastiques et tolérants aux défauts d’être facilement construit et exécuté efficacement.
- Nomad - Distribué, hautement disponible, datacenter-aware programmer.
- Redisson - Structures de données Java distribuées et évolutives sur le serveur Redis.
- Serf - Solution décentralisée pour l’adhésion au cluster, la détection des défaillances et l’orchestration.
- Valkey - Un nouveau projet pour reprendre le développement du projet Redis auparavant open source.
- Zenoh - Protocole Pub/sous/query unifiant les données en mouvement, les données au repos et les calculs. Mélange efficacement pub/sous traditionnel avec stockage géodistribué, requêtes et calculs.
Programmeurs d’emplois / Automatisation de la charge de travail
Section intitulée « Programmeurs d’emplois / Automatisation de la charge de travail »- Celery - Tâche asynchrone file / file d’attente d’emploi basée sur le passage de message distribué. Concentré sur le fonctionnement en temps réel et prend en charge le calendrier.
- Dkron - Distribué, système de planification des tâches tolérant les erreurs.
- Faktory - Serveur d’arrière-plan de l’agnostique linguistique.
- Rundeck (c) - Planificateur de travail et automatisation de l’exécution. Permettre l’accès libre-service aux scripts et outils existants.
- Schedulix - Le système de planification d’emploi d’entreprise open source établit des normes révolutionnaires pour l’automatisation professionnelle des processus informatiques dans les environnements de systèmes avancés.
Développement local
Section intitulée « Développement local »- mirrord - Exécutez le code local comme si c’était un pod dans une télécommande Kubernetes Groupe.
Exploitation forestière
Section intitulée « Exploitation forestière »- Fluentd - Collecteur de données open source pour la couche de journalisation unifiée.
- Graylog - Plateforme de gestion de log open source entièrement intégrée.
- Kibana - Plateforme d’analyse et de visualisation flexible.
- LogDNA (c) - Logiciel de gestion centralisée des journaux. Collectez, centralisez et analysez instantanément les journaux en temps réel depuis n’importe quelle plateforme, à n’importe quel volume.
- Logstash - Outil de gestion des événements et des journaux.
- Loki - Comme Prométhée, mais pour les bûches.
Messagerie
Section intitulée « Messagerie »- ØMQ - Couche de transport intelligente sans courtier.
- ActiveMQ - Un puissant serveur de messagerie et d’intégration open source.
- Aeron - Transport efficace de messages UDP unicast, UDP multicast et IPC.
- Beanstalk - Une file d’attente simple et rapide.
- Bull - Une file d’attente rapide et fiable pour le nœud Redis.
- Crossbar - Plate-forme de mise en réseau ouverte pour les applications distribuées et microservices. Il met en œuvre le protocole ouvert de messagerie d’applications Web (WAMP).
- Kafka - Publier-subscribe messagerie repensée comme un journal de commit distribué.
- Malamute - Courtier de messagerie d’entreprise ZeroMQ.
- Mosquitto - Courtier de messages open source qui implémente le protocole MQTT.
- NATS - Open source, haute performance, système de messagerie en nuage léger.
- NSQ - Une plateforme de messagerie distribuée en temps réel.
- Pulsar - Système de messagerie pub-sub.
- RabbitMQ - Un courtier de messages basé sur Erlang qui fonctionne.
- Redpanda - Plate-forme de données de streaming pour les développeurs: Kafka API compatible, 10x plus rapide, aucun ZooKeeper et aucun JVM.
- RocketMQ - Un middleware à faible latence, fiable, évolutif, facile à utiliser orienté message né de l’activité de messagerie massive alibaba.
Surveillance et débogage
Section intitulée « Surveillance et débogage »- Beats - expéditeurs légers pour Elasticsearch & Logstash.
- Elastalert - Alerte facile et flexible pour Elasticsearch.
- Ganglia - Un système évolutif de surveillance répartie pour les systèmes informatiques à haute performance tels que les clusters et les grilles.
- Grafana - Un open source, dispose de riches métriques tableau de bord et éditeur de graphiques pour Graphite, InfluxDB et OpenTSDB.
- Graphite - Graphage évolutif en temps réel.
- IOpipe (c) - Surveillance des performances de l’application pour Amazon Lambda.
- Jaeger - Un traçage distribué de bout en bout, source ouverte
- OpenTelemetry - Télémétrie de haute qualité, omniprésente et portable pour permettre une observation efficace.
- Prometheus - Un système de surveillance des services open source et une base de données chronologiques.
- Riemann - Surveille les systèmes distribués.
- Sensu - Surveillance des infrastructures d’aujourd’hui.
- SkyWalking - Outil de moniteur de performance d’application pour les systèmes distribués, spécialement conçu pour les microservices, les natifs du cloud et les conteneurs (Docker, K8sLes architectures.
- Zabbix - Solution de surveillance ouverte de classe entreprise.
- Zipkin - Système de traçage distribué.
Réactivité
Section intitulée « Réactivité »- Arroyo - Moteur de traitement de flux distribué pour transformer, filtrer, agréger et rejoindre les flux de données en écrivant SQL.
- Reactor.io - Une bibliothèque réactive de deuxième génération pour la construction d’applications non-bloquantes sur le JVM basée sur la spécification Reactive Streams.
- Reactive Kafka - API des flux réactifs pour Apache Kafka.
- ReactiveX - API pour programmation asynchrone avec flux observables. Disponible pour Java idiomatique, Scala, C#, C++, Clojure, JavaScript, Python, Groovy, JRuby, etc.
- RSocket - Protocole d’application fournissant la sémantique Reactive Streams.
Résilience
Section intitulée « Résilience »- Awesome Chaos Engineering :star: - Une liste de ressources d’ingénierie du chaos.
- Raft Consensus - Algorithme de consensus conçu pour être facile à comprendre. C’est l’équivalent de Paxos dans la tolérance aux défauts et la performance.
- Resilience4j - Bibliothèque de tolérance aux défauts conçue pour Java8 et programmation fonctionnelle.
- Svix - Service Webhooks qui envoie des webhooks à vos utilisateurs avec des horaires complets de réessayer, backoff exponentiel, vérification de signature et types d’événements.
Sécurité
Section intitulée « Sécurité »- Cerbos Hub - Système de gestion des autorisations pour la rédaction, l’essai et le déploiement des politiques d’accès. Autorisation évolutive et fine dans une architecture microservice.
- Dex - Service d’auth/répertoire avec connecteurs rechargeables. OpenID Connect fournisseur et délégation de tiers OAuth 2.0.
- JWT - Les jetons Web JSON sont une méthode ouverte et standard de l’industrie RFC 7519 pour représenter les revendications en toute sécurité entre deux parties.
- Keycloak - Service complet et extensible. OpenID Connect fournisseur et délégation de tiers OAuth 2.0.
- OAuth - Fournit des flux d’autorisation spécifiques pour les applications Web, les applications de bureau, les téléphones mobiles et les appareils de salon. De nombreuses mises en œuvre.
- OpenID Connect - Bibliothèques, produits et outils mettant en œuvre les spécifications OpenID actuelles et les spécifications connexes.
- Open Ziti - Zero confiance sécurité et superposition réseau comme logiciel open source pure.
- ORY - Infrastructure et services d’identité open source.
- OWASP Agent Memory Guard — Couche de défense contre les intoxications à la mémoire des agents de l’IA (OWASP ASI06). Détecte les entrées de mémoire altérées, l’injection rapide dans les chemins de mémoire et les fuites secrètes. Politiques YAML, latence microseconde, aucune dépendance externe.
- SCIM - Système de gestion de l’identité trans-domaine.
- Vault - Sécurise, stocke et contrôle étroitement l’accès aux jetons, mots de passe, certificats, clés API et autres secrets dans l’informatique moderne.
Sérialisation
Section intitulée « Sérialisation »- Avro - Système de sérialisation des données Apache fournissant de riches structures de données au format compact, rapide et binaire.
- Bond - Cadre multiplateforme pour travailler avec les données schématisées, largement utilisé chez Microsoft dans les services à grande échelle.
- BooPickle - Bibliothèque de sérialisation binaire pour une communication réseau efficace. Pour Scala et Scala.js
- Cap’n Proto - Format d’échange de données et système RPC basé sur les capacités.
- CBOR - Mise en œuvre de la norme CBOR (RFC 7049) dans de nombreuses langues.
- Cereal - Bibliothèque C++11 pour la sérialisation.
- Cheshire - Clojure JSON et JSON SMILE encodage/décodage.
- Etch - Cadre transplateforme, linguistique et indépendant des transports pour la construction et la consommation de services de réseau.
- Fastjson - Processeur JSON rapide.
- Ffjson - Sérialisation JSON plus rapide pour aller.
- FST - La sérialisation rapide du java tombe en place.
- Jackson - Une bibliothèque Java polyvalente pour le traitement des données JSON.
- Jackson Afterburner - Module Jackson qui utilise la génération d’octécodes pour accélérer la fixation des données (+30-40% de débit pour la sérialisation, la désérialisation).
- Kryo - Sérialisation et clonage Java : rapide, efficace, automatique.
- Lite³ - Format de sérialisation à copie zéro compatible JSON.
- MessagePack - Format de sérialisation binaire efficace.
- Protostuff - Une bibliothèque de sérialisation avec support intégré pour la compatibilité avant-arrière (évolution du schéma) et la validation.
- SBinary - Bibliothèque pour décrire les formats binaires pour les types Scala.
- Thrift - le cadre logiciel Apache Thrift, pour le développement de services translingues évolutifs.
- yyjson - La bibliothèque JSON la plus rapide de C.
Stockage
Section intitulée « Stockage »- Apache Cassandra - Orientée vers la colonne et offrant une grande disponibilité sans aucun point de défaillance.
- Aerospike (c) - Base de données NoSQL haute performance offrant une vitesse à l’échelle.
- ArangoDB - Une base de données libre et ouverte distribuée avec un modèle de données flexible pour les documents, les graphiques et les valeurs clés.
- Citus - Distribué PostgreSQL comme une extension.
- CockroachDB (c) - Une base de données SQL cloud-native modélisée après Google Slanner.
- Couchbase - Une base de données distribuée conçue pour la performance, l’évolutivité et l’administration simplifiée.
- Crate (c) - Base de données SQL évolutive avec les goodies NoSQL.
- Druid - Data store rapide, orienté colonne.
- Elasticsearch - Serveur de recherche open source distribué, évolutif et très disponible.
- Geode - Open source, distribué, base de données en mémoire pour les applications hors échelle.
- Infinispan - Datastore clé/valeur très concurrente utilisé pour la mise en cache.
- InfluxDB - Datastore évolutive pour les mesures, les événements et l’analyse en temps réel.
- RethinkDB - Open source, base de données évolutive qui facilite la construction d’applications en temps réel.
- TiKV - Base de données à valeur transactionnelle distribuée.
- TimescaleDB - Une base de données de séries chronologiques pour l’analyse en temps réel haute performance emballée comme une extension Postgres.
- Trino - Moteur de requête SQL distribué rapidement pour l’analyse des mégadonnées qui vous aide à explorer votre univers de données.
- Goreplay - Un outil pour capturer et rejouer le trafic HTTP en direct dans un environnement de test.
- Keploy - Outil open-source pour tester et simuler les API en capturant le trafic réel et en le transformant en boîtiers et goujons de test, permettant des tests de microservice fiables.
- Mitmproxy - Un programme de console interactif qui permet d’intercepter, d’inspecter, de modifier et de rejouer les flux de trafic.
- MockServer - Mocking, debugging proxy and chaos engineering for multiple protocols (HTTP, gRPC, GraphQL, LLM, MCP, Kafka, TCP et bien plus); dépendances simulées, trafic record/replay, vérification des demandes, et injection de défauts pour l’intégration et les tests de résilience.
- Mountebank - Le test multiprotocole multiplateforme double sur le fil.
- Pact - Cadre de test contractuel pour les API HTTP et les systèmes de messagerie non-HTTP asynchrones.
- RestQA - Un outil pour gérer les microservices de simulation, d’unité et de tests de performance localement avec la meilleure expérience de développeur de classe.
- Specmatic - Convertit les spécifications de l’API (OpenAPI, AsyncAPI, GraphQL, gRPC, etc.) en contrats exécutables pour les tests automatisés, la virtualisation de service et la validation de compatibilité en arrière sans code d’écriture.
- VCR - Enregistrez les interactions HTTP de votre suite de test et rejouez-les lors de futurs tests pour des tests rapides, déterministes et précis. Voir la liste des ports pour les implémentations dans d’autres langues.
- Wilma - Tige de service HTTP/HTTPS combinée et solution proxy transparente.
- WireMock - Librairie flexible pour les services web d’étalage et de moquerie. Contrairement aux outils de moquerie d’usage général, il fonctionne en créant un serveur HTTP réel auquel votre code en cours d’essai peut se connecter comme un véritable service web.
- Hoverfly - Virtualisation de service légère / outil de simulation API pour les développeurs et les testeurs.
Intégration et livraison continues
Section intitulée « Intégration et livraison continues »- Awesome CI/CD DevOps :star: - Une liste d’outils formidables pour l’intégration continue, la livraison continue et DevOps.
Modélisation et documentation des API Web
Section intitulée « Modélisation et documentation des API Web »- AsyncAPI - La spécification AsyncAPI, la norme industrielle pour la définition des API asynchrones.
GraphiqueQL
Section intitulée « GraphiqueQL »- GraphQL - Un langage de requête conçu pour construire des applications clientes en fournissant une syntaxe et un système intuitifs et flexibles pour décrire leurs besoins en données et leurs interactions.
- JSON:API - Spécification de la façon dont un client doit demander que les ressources soient récupérées ou modifiées, et comment un serveur doit répondre à ces demandes.
- API Blueprint - Des outils pour tout votre cycle de vie de l’API. Utilisez-le pour discuter de votre API avec d’autres. Générer la documentation automatiquement. Ou une suite de test. Ou même un code.
- OpenAPI - La spécification OpenAPI (OEA) fournit un moyen cohérent de transmettre l’information à chaque étape du cycle de vie de l’API.
- RAML - RESTful API Modeling Language, une façon simple et succincte de décrire les API pratiquement-RESTful.
- ReDoc - Documentation API générée par OpenAPI/Swagger.
- Scalar - Plateforme d’API open-source : belles références d’API et support OpenAPI/Swagger de première classe.
- Slate - Belle documentation statique pour votre API.
- Spring REST Docs - Documenter les services REST en combinant la documentation écrite à la main avec des extraits autogénérés produits avec Spring MVC Test.
- Swagger - Une représentation simple mais puissante de votre API RESTful.
Normes et recommandations
Section intitulée « Normes et recommandations »Réseau mondial
Section intitulée « Réseau mondial »- W3C.REC-Webarch - Architecture du World Wide Web, volume 1.
- RFC3986 - Identificateur de ressource uniforme (URI): Syntaxe générique.
- RFC6570 - Modèle URI.
- RFC7320 - Conception et propriété URI.
Autosouverainité et décentralisation
Section intitulée « Autosouverainité et décentralisation »- DID - Spécification W3C des identifiants décentralisés (IDD) : un nouveau type d’identificateur permettant une identité numérique vérifiable et décentralisée.
- DIDComm - La méthodologie de communication privée s’est construite au sommet de la conception décentralisée des DID.
- DIDComm Protocols - Registre des protocoles construits sur DIDComm, pour des interactions hautement fiables et autonomes sur tout transport.
- IDSA - L’Association internationale des espaces de données (IDSA) a pour mission de créer l’avenir de l’économie numérique mondiale avec International Data Spaces (IDS), un système sécurisé et souverain de partage de données dans lequel tous les participants peuvent réaliser la pleine valeur de leurs données.
HTTP/1.1
Section intitulée « HTTP/1.1 »- RFC7230 - Syntaxe des messages et routage.
- RFC7231 - Sémantique et contenu.
- RFC7232 - Demandes conditionnelles.
- RFC7233 - Demandes de portée.
- RFC7234 - Cache.
- RFC7235 - Authentification.
- RFC7807 - Détails du problème pour les API HTTP.
- RFC7540 - Protocole de transfert hypertexte Version 2.
- QUIC-WG - Groupe de travail IETF qui est affrété pour fournir le prochain protocole de transport pour l’Internet.
- QUIC-Transport - Un transport multiplexé et sécurisé basé sur UDP.
- JSON-RPC 2.0 - Un protocole d’appel à distance apatride et léger.
- Open RPC - La spécification OpenRPC définit une description standard de l’interface langage-agnostique de programmation pour les API JSON-RPC 2.0.
Messagerie
Section intitulée « Messagerie »- AMQP - Protocole de saisie de message avancé.
- MQTT - Transport télémétrique MQ.
- STOMP - Protocole de messagerie simple orienté texte.
Sécurité
Section intitulée « Sécurité »- GNAP - Le Protocole de négociation et d’autorisation des subventions définit un mécanisme de délégation de l’autorisation à un logiciel et transmet cette délégation au logiciel. Cette délégation peut inclure l’accès à un ensemble d’API ainsi que l’information transmise directement au logiciel.PROJET DE
- OIDCONN - OpenID Connect 1.0 est une simple couche d’identité en plus du protocole OAuth 2.0. Il permet aux clients de vérifier l’identité de l’utilisateur final en fonction de l’authentification effectuée par un serveur d’autorisation, ainsi que d’obtenir des informations de base sur le profil de l’utilisateur final d’une manière interopérable et semblable à REST.
- PASETO - Paseto est tout ce que vous aimez à propos de JOSE (JWT, JWE, JWS) sans aucun des nombreux déficits de conception qui pénalisent les normes JOSE. PROJET DE
- RFC5246 - Le protocole de sûreté de la couche de transport (TLS) version 1.2.
- RFC6066 - Extensions TLS.
- RFC6347 - Sécurité de la couche de transport de données Version 1.2.
- RFC6749 - Le cadre d’autorisation OAuth 2.0.
- RFC6962 - Transparence du certificat.
- RFC7515 - JSON Web Signature (JWS) représente le contenu sécurisé par des signatures numériques ou des codes d’authentification des messages (CMA) utilisant des structures de données basées sur JSON.
- RFC7519 - JSON Web Token (JWT) est un moyen compact et sûr de représenter les revendications à transférer entre deux parties.
- RFC7642 - SCIM: Définitions, aperçu, concepts et exigences.
- RFC7643 - SCIM: Core Schema, fournit un schéma et un modèle d’extension neutres pour représenter les utilisateurs et les groupes.
- RFC7644 - SCIM: Protocole, un niveau d’application, protocole REST pour la fourniture et la gestion des données d’identité sur le web.
Découverte des services
Section intitulée « Découverte des services »- DNS-SD - Mécanisme permettant aux clients de découvrir une liste d’instances nommées d’un service, en utilisant des requêtes DNS standard.
- RFC2782 - Un DNS RR pour spécifier l’emplacement des services (DNS SRV).
Formats de données
Section intitulée « Formats de données »- RFC4627 - Notation d’objet JavaScript (JSON).
- RFC7049 - Représentation concise d’objets binaires (CBOR).
- BSON - Binary JSON (BSON).
- JSON-LD - JSON pour lier les données.
- SBE - Encodage binaire simple (SBE).
- MSGPACK - Spécification MessagePack.
Vocabulaires
Section intitulée « Vocabulaires »- JSON Schema - Vocabulaire qui vous permet d’annoter et de valider les documents JSON.
- Schema.org - Une activité communautaire concertée avec la mission de créer, de maintenir et de promouvoir des schémas de données structurées sur Internet, sur les pages Web, dans les messages électroniques et au-delà.
- UNIV8 - Le consortium Unicode. La norme Unicode, version 8.0.0, (Montagne, CA: The Unicode Consortium, 2015. ISBN 978-1-936213-10-8).
- RFC3629 - UTF-8, format de transformation de la norme ISO 10646.
Conception de l’organisation / Dynamique d’équipe
Section intitulée « Conception de l’organisation / Dynamique d’équipe »- How Do Committees Invent? :small_orange_diamond:PDF - Melvin E. Conway, magazine Datamation 1968. L’article original définissant la loi de Conway.
- Service per Team - Chaque équipe est responsable d’une ou de plusieurs fonctions commerciales (p. ex. capacités commerciales). Une équipe possède une base de codes comprenant un ou plusieurs modules. Sa base de code est dimensionnée de façon à ne pas dépasser la capacité cognitive de l’équipe. L’équipe déploie son code comme un ou plusieurs services. Une équipe devrait avoir exactement un seul service à moins qu’il n’y ait un besoin prouvé d’avoir plusieurs services.
- Start with Team Cognitive Load - Team Topologies :small_red_triangle:YT - Ça fait 19 Londres. Le débat “monolithes vs microservices” se concentre souvent sur les aspects technologiques, ignorant la stratégie et la dynamique d’équipe. Au lieu de la technologie, les organisations de pensée intelligente commencent par la charge cognitive de l’équipe comme principe directeur pour les logiciels modernes. Dans ce discours, nous expliquons comment et pourquoi, illustrés par des études de cas réelles.
Entreprise & Verticals
Section intitulée « Entreprise & Verticals »- Commercetools - Une plateforme de commerce sans tête.
- Equinox - Infosys Equinox est une plateforme de commerce et de marketing centrée sur l’humain qui soutient des expériences riches et hyper-personnalisées sur n’importe quel canal et point de contact.
- Flamingo - Cadre pour construire des applications de commerce électronique flexibles et modernes.
- Medusa - Plateforme de commerce open source sans tête.
Articles et papiers
Section intitulée « Articles et papiers »- Autonomy, Hyperconnectivity, and Residual Causality - Introduction philosophique à la conception de systèmes hyperliminaux adaptatifs par des théories scientifiques de complexité.
- Awesome Scalability :star: - Une liste de lecture actualisée et organisée pour illustrer les modèles de systèmes à grande échelle évolutifs, fiables et performants. Les concepts sont expliqués dans les articles d’ingénieurs éminents et de références crédibles. Des études de cas sont tirées de systèmes éprouvés au combat qui servent des millions à des milliards d’utilisateurs.
- AKF Scale Cube - Modèle représentant les dimensions d’un service.
- CALM :small_orange_diamond:PDF - Cohérence comme monotonicité logique.
- Canary Release - Technique pour réduire le risque d’introduire une nouvelle version logicielle dans la production en déployant lentement le changement vers un petit sous-ensemble d’utilisateurs avant de le déployer vers l’ensemble de l’infrastructure et de la mettre à la disposition de tous.
- CAP Theorem - Déclare qu’il est impossible pour un système informatique distribué de fournir simultanément les trois garanties suivantes : Cohérence, disponibilité et tolérance à la partition.
- Formal Foundations of Serverless Computing :small_orange_diamond:PDF - L’abstraction informatique sans serveur expose plusieurs détails opérationnels de bas niveau qui rendent difficile pour les programmeurs d’écrire et de raisonner sur leur code. Cet article met en lumière ce problème en présentant λ, une sémantique opérationnelle de l’essence de l’informatique sans serveur.
- Microservice Architecture - Une manière particulière de concevoir des applications logicielles en tant que suites de services déployables indépendamment.
- Microservices - From Design to Deployment :small_orange_diamond:PDF - Série F5 en sept parties sur les microservices.
- Microservices – Please, don’t - Conseils critiques sur certains problèmes concernant une approche des microservices.
- Microservices Trade-Offs - Guide pour réfléchir aux coûts et aux avantages du style architectural mircoservices.
- Reactive Manifesto - Définition des systèmes réactifs.
- Reactive Streams - Initiative visant à fournir une norme pour le traitement des flux asynchrones avec une contre-pression sans blocage.
- ROCAS :small_orange_diamond:PDF - Informatique orientée ressources pour systèmes adaptatifs.
- SECO :small_orange_diamond:PDF - Comprendre les écosystèmes logiciels : une approche de modélisation stratégique.
- Testing Strategies in a Microservice Architecture - Approches pour gérer la complexité supplémentaire des essais de multiples composants déployables indépendamment.
- Your Server as a Function :small_orange_diamond:PDF - Décrit trois abstractions qui se combinent pour présenter un modèle de programmation puissant pour construire un logiciel serveur sûr, modulaire et efficace : Futurs, services et filtres Composables.
Sites et organisations
Section intitulée « Sites et organisations »- Cloud Native Computing Foundation - La Cloud Native Computing Foundation construit des écosystèmes durables et encourage une communauté autour d’une constellation de projets de haute qualité qui orchestrent des conteneurs dans le cadre d’une architecture de microservices.
- CNCF Cloud Native Interactive Landscape - Paysage interactif des technologies natives du cloud.
- Microservices Resource Guide - Le choix d’articles, de vidéos, de livres et de podcasts de Martin Fowler qui peuvent vous apprendre davantage sur le style architectural des microservices.
- Microservice Patterns - Les modèles d’architecture microservice et les meilleures pratiques.
- Microservice Antipatterns and Pitfalls - Microservice principalement connu antipatterns et pièges.
Contribution
Section intitulée « Contribution »S’il vous plaît, lisez le Contribution Guidelines avant de soumettre votre suggestion.
N’hésitez pas open an issue ou create a pull request avec vos additions.
:star2: Je vous remercie !
HagiCode
HagiCode est un espace de développement agentique. Des interactions d’interface riches et pratiques rendent la planification, l’exécution des agents et le travail sur les projets accessibles et faciles à suivre, pour une expérience de développement engageante.
Une expérience de développement engageante grâce à des interactions d’interface riches et pratiques.
- IntelligentLes workflows OpenSpec transforment une intention en parcours exécutable, de la proposition à la livraison en passant par la conception et les tâches.
- EfficaceL’exécution multi-agent fait avancer recherche, réalisation et revue en parallèle, sur plusieurs dépôts et avec les Agent CLI que vous utilisez déjà.
- IntéressantDes interactions d’interface riches et pratiques rendent la planification, l’exécution des agents et le travail sur les projets accessibles et faciles à suivre.
Télécharger pour Windows
Partager HagiCode
Transformez vos idées en logiciels livrés.
HagiCode est un espace de développement agentique : les workflows OpenSpec planifient le changement, l’exécution multi-agent le réalise et Hero Scenario rend le long parcours visible, pour transformer vos idées en logiciels livrés.
- Intelligent
- Les workflows OpenSpec transforment une intention en parcours, de la proposition à la livraison.
- Efficace
- L’exécution multi-agent mène recherche, réalisation et revue en parallèle.
- Ludique
- Les interactions d’interface facilitent la planification, l’exécution des agents et les projets.
© 2026 HagiCode | Powered By hagilight-starlight@0.21.0 | Branch: main | Commit: 745b50b | Built:


